Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Launching the WSDL Editor from PlugIn
Launching the WSDL Editor from PlugIn [message #227591] Tue, 10 February 2009 15:43 Go to next message
Peter Liu is currently offline Peter Liu
Messages: 12
Registered: July 2009
Junior Member
I've read the thread about "Bringing the WSDL Editor in the Debugger."
I've a similar problem but not the same. I don't have version problems.
I used WTP 3.1M4 as the target platform. I downloaded the source code from
HEAD. I tried to launch the target platform from my development platform
(i.e. Plug In). I got an error. Later I got an XML editor instead of
the WSDL editor. Here are the screenshots:

http://cs.senecac.on.ca/~pliu/wtp/launch_feb10.JPG
http://cs.senecac.on.ca/~pliu/wtp/launch2_feb10.JPG
http://cs.senecac.on.ca/~pliu/wtp/launch3_feb10.JPG.

Please help me. Thanks.
Re: Launching the WSDL Editor from PlugIn [message #227666 is a reply to message #227591] Wed, 11 February 2009 10:14 Go to previous messageGo to next message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

Peter, are you sure your target is OK? That is, have you downloaded and
installed all the WTP prerequisited? Make sure you start the target at least
once and that the WSDL editor works.
In my PDE target definition I have the check-box "Build target platform
based on the target's installed plug-ins "checked. See the attached
screenshot.

Valentin

"Peter Liu" <peter.liu@senecac.on.ca> wrote in message
news:3bdf3d272f58bac7ab372cb5b4d3e98c$1@www.eclipse.org...
> I've read the thread about "Bringing the WSDL Editor in the Debugger."
> I've a similar problem but not the same. I don't have version problems.
> I used WTP 3.1M4 as the target platform. I downloaded the source code from
> HEAD. I tried to launch the target platform from my development platform
> (i.e. Plug In). I got an error. Later I got an XML editor instead of
> the WSDL editor. Here are the screenshots:
>
> http://cs.senecac.on.ca/~pliu/wtp/launch_feb10.JPG
> http://cs.senecac.on.ca/~pliu/wtp/launch2_feb10.JPG
> http://cs.senecac.on.ca/~pliu/wtp/launch3_feb10.JPG.
>
> Please help me. Thanks.
>


  • Attachment: target.PNG
    (Size: 5.56KB, Downloaded 177 times)
Re: Launching the WSDL Editor from PlugIn [message #227776 is a reply to message #227666] Thu, 12 February 2009 16:31 Go to previous messageGo to next message
Peter Liu is currently offline Peter Liu
Messages: 12
Registered: July 2009
Junior Member
Hi, Valentin.

Thank your for your reply. I couldn't view your screenshot.
I still have the same problem.
Following your advice, this is what I did.
1. I could run the target platform (WTP 31M4) successfully.
Here is the screenshot:
http://cs.senecac.on.ca/~pliu/opensource_wtp/target212.JPG

2. On the Plug In development platform, I checked the box as suggested.
Here is the screenshot:
http://cs.senecac.on.ca/~pliu/opensource_wtp/plugin_target_2 12.JPG

(I didn't hit the reload button for one trial; the system loaded all
the plug ins anyway. I hit the reload button for another trial.)

3. I downloaded the "wst.wsdl" and "wst.wsdl.ui" components from the CVS
repository. I changed a Java class and then tried to run it with
configuration. Here are 2 screenshots:

http://cs.senecac.on.ca/~pliu/opensource_wtp/runconfig_212.J PG
http://cs.senecac.on.ca/~pliu/opensource_wtp/runconfig2_212. JPG

4. Initially, I got the error dialog box saying about the workbench UI
state.
The workbench was set to some default state. As a result, there's no
WSDL editor.

5. When I tried to launch the target platform from the development again,
I got XML editor again.

What else could I do? Any help will be appreciated.

Peter.
Re: Launching the WSDL Editor from PlugIn [message #227782 is a reply to message #227776] Thu, 12 February 2009 16:47 Go to previous messageGo to next message
Eclipse User
Originally posted by: valentinbaciu.hotmail.com

Peter, the code in head is newer than M4. How about you grab M5, set up a
target and give it a try?

Valentin

"Peter Liu" <peter.liu@senecac.on.ca> wrote in message
news:604e4f45df86f04994e3422ac87ac98e$1@www.eclipse.org...
> Hi, Valentin.
>
> Thank your for your reply. I couldn't view your screenshot.
> I still have the same problem.
> Following your advice, this is what I did.
> 1. I could run the target platform (WTP 31M4) successfully. Here is the
> screenshot: http://cs.senecac.on.ca/~pliu/opensource_wtp/target212.JPG
>
> 2. On the Plug In development platform, I checked the box as suggested.
> Here is the screenshot:
> http://cs.senecac.on.ca/~pliu/opensource_wtp/plugin_target_2 12.JPG
>
> (I didn't hit the reload button for one trial; the system loaded all the
> plug ins anyway. I hit the reload button for another trial.)
>
> 3. I downloaded the "wst.wsdl" and "wst.wsdl.ui" components from the CVS
> repository. I changed a Java class and then tried to run it with
> configuration. Here are 2 screenshots:
>
> http://cs.senecac.on.ca/~pliu/opensource_wtp/runconfig_212.J PG
> http://cs.senecac.on.ca/~pliu/opensource_wtp/runconfig2_212. JPG
>
> 4. Initially, I got the error dialog box saying about the workbench UI
> state.
> The workbench was set to some default state. As a result, there's no
> WSDL editor.
>
> 5. When I tried to launch the target platform from the development again,
> I got XML editor again.
>
> What else could I do? Any help will be appreciated.
>
> Peter.
>
>
Re: Launching the WSDL Editor from PlugIn [message #227835 is a reply to message #227782] Fri, 13 February 2009 15:06 Go to previous message
Peter Liu is currently offline Peter Liu
Messages: 12
Registered: July 2009
Junior Member
Hi, Valentin.

Your advice works! My problem was caused by *inconsistent" versions between
the code I checked out from HEAD and the target platform. I was using
3.1M4.
Now I use 3.1M5 and my problem disappeared. Thank you so much for you help.

Peter.
Previous Topic:hiding design and source tabs of xml of editor
Next Topic:wsgen ant task <-> preferences
Goto Forum:
  


Current Time: Mon Jul 28 14:36:44 EDT 2014

Powered by FUDForum. Page generated in 0.04476 seconds