Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » FileChooser in RAP(Scout 3.8)
FileChooser in RAP [message #1327779] Fri, 02 May 2014 06:31 Go to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi all,
I have a problem with FileChooser in RAP because it doesn't work correctly (see image below), instead in SWT works fine.

I followed this tutorial http://wiki.eclipse.org/Scout/HowTo/3.9/Add_FileChooser_support_for_RAP_UI

index.php/fa/18008/0/

I use Eclipse Juno 3.8

And this is my configuration:
index.php/fa/18033/0/

Thanks in advance for any help and suggestions

[Updated on: Wed, 07 May 2014 10:45]

Report message to a moderator

Re: FileChooser in RAP [message #1339036 is a reply to message #1327779] Wed, 07 May 2014 09:36 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi all,
I find also this problem in the Dependencies for RAP .product and I think is the reason of my problem.
The five following plug-ins are marked with a red X:


  • org.apache.commons.io
  • org.apache.commons.fileupload
  • org.eclipse.rap.rwt.supplemental.filedialog
  • org.eclipse.rap.rwt.supplemental.fileupload
  • org.eclipse.scout.rt.ui.rap.incubator.filechooser


index.php/fa/18032/0/

Any suggestions about a possible solution of this problem?

Thanks in advance for any help
Re: FileChooser in RAP [message #1340757 is a reply to message #1339036] Thu, 08 May 2014 02:55 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
Hi marco,

I am not sure if it helps but it may worth a try. In the SDK's Scout Object Properties, uncheck "RAP FileChooser Support (Incubation)" and select it again. In my case this creates a "ScoutRAP.target" where the bundles will be loaded.

index.php/fa/18041/0/

Please keep me updated, I will be glad to help if this attempt does not work.

Best regards,
Matthias
  • Attachment: rap.png
    (Size: 33.58KB, Downloaded 168 times)
Re: FileChooser in RAP [message #1341132 is a reply to message #1340757] Thu, 08 May 2014 06:37 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi Matthias,
I followed your suggestion, I uncheck "RAP FileChooser Support" and after I clean and rebuild my project. Afert that, I check "RAP FileChooser Support" again and I clean and rebuild again my project but unfortunately nothing change.

Re: FileChooser in RAP [message #1341157 is a reply to message #1341132] Thu, 08 May 2014 06:50 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
do you have the ScoutRAP.target? Is it empty or does it contain the bundles?
Re: FileChooser in RAP [message #1341368 is a reply to message #1341157] Thu, 08 May 2014 08:57 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi Matthias,
yes I have different ScoutRAP.target (one for RAP, one for SWT, etc)
And the Target Content contains 895 items (see image below)
index.php/fa/18045/0/

But I found in my console the following message, probably is directed linked to my problem. This message appears now after I follow your suggestion.
What do you think?

!ENTRY org.eclipse.osgi 2 0 2014-05-08 12:10:47.085
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-08 12:10:47.085
!MESSAGE Bundle update@../../Projects/scout/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.scout.rt.ui.rap.incubator.filechooser_3.8.2.201302111336.jar was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap.incubator.filechooser 2 0 2014-05-08 12:10:47.085
!MESSAGE Missing required bundle org.eclipse.scout.rt.ui.rap_3.8.2.

!ENTRY org.eclipse.osgi 2 0 2014-05-08 12:10:47.095
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-08 12:10:47.095
!MESSAGE Bundle org.eclipse.scout.rt.ui.rap.incubator.filechooser_3.8.2.201302111336 [98] was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap.incubator.filechooser 2 0 2014-05-08 12:10:47.095
!MESSAGE Missing required bundle org.eclipse.scout.rt.ui.rap_3.8.2.

[Updated on: Thu, 08 May 2014 09:02]

Report message to a moderator

Re: FileChooser in RAP [message #1341414 is a reply to message #1341368] Thu, 08 May 2014 09:24 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
hm... does the ScoutRAP.target contain the bundles your product is missing? (org.eclipse.scout.rt.ui.rap.incubator.filechooser, ...) ?

And did you try "Set as target platform" in the ScoutRAP.target ?!

[Updated on: Thu, 08 May 2014 09:25]

Report message to a moderator

Re: FileChooser in RAP [message #1341433 is a reply to message #1341414] Thu, 08 May 2014 09:31 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Yes, my ScoutRAP.target contains this bundle but it isn't checked.

Now I try to check it and I make a test
Re: FileChooser in RAP [message #1343291 is a reply to message #1341433] Fri, 09 May 2014 04:10 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi Matthias,
after this operation my UI.RAP goes in error and disappeared from the list (see image below)
index.php/fa/18051/0/

And the following packages go in errors (see image below)
index.php/fa/18052/0/

For example in class "StandaloneRwtEnvironment" the error reported is "AbstractStandaloneRwtEnvironment cannot be resolved to a type"

On the MANIFEST.MF, the error is located to Require-Bundle for the package "org.eclipse.scout.rt.ui.rap"

Can you help me to repair this errors?

Thanks in advance for your help
Re: FileChooser in RAP [message #1343326 is a reply to message #1343291] Fri, 09 May 2014 04:31 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
the bundle "org.eclipse.scout.rt.ui.rap" is activated in the ScoutRAP.target?
Re: FileChooser in RAP [message #1343393 is a reply to message #1343326] Fri, 09 May 2014 05:13 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
For SWT, the bundle "org.eclipse.scout.rt.ui.rap" is activated in the ScoutRAP.target

For RAP, in the ScoutRAP.target I have the following situation
index.php/fa/18053/0/

First of all, have you an idea why I have a double entry of "org.eclipse.scout.rt.ui.rap"?
Second, I need to check only "org.eclipse.scout.rt.ui.rap" or also "org.eclipse.scout.rt.ui.rap.incubator.filechooser"?

Thanks in advance for your help
Re: FileChooser in RAP [message #1343410 is a reply to message #1343393] Fri, 09 May 2014 05:21 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
Honestly, I don't know why there are 2 entries. I would check both and do "set as target platform" afterwards
Re: FileChooser in RAP [message #1343420 is a reply to message #1343410] Fri, 09 May 2014 05:29 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Ok, I do.
The situation has improved a little; the error on MANIFEST.MF resolved but remain open on plugin.xml
index.php/fa/18056/0/

and StandaloneRwtEnvironment.java
index.php/fa/18055/0/
  • Attachment: err1.PNG
    (Size: 11.85KB, Downloaded 111 times)
  • Attachment: err2.PNG
    (Size: 35.14KB, Downloaded 109 times)
Re: FileChooser in RAP [message #1343430 is a reply to message #1343420] Fri, 09 May 2014 05:33 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
hm... can you select all projects in the workspace and press f5. Additionally I would do a clean all projects.
Re: FileChooser in RAP [message #1343441 is a reply to message #1343430] Fri, 09 May 2014 05:36 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Yes, I alredy clean and rebuild but these errors remains.

Now I try to start the RAP and give me the following messages:
!SESSION 2014-05-09 11:35:13.668 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_24
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=it_IT
Framework arguments:  -product org.zeiss.mo.scout.CZVEDIController.ui.rap.product
Command-line arguments:  -product org.zeiss.mo.scout.CZVEDIController.ui.rap.product -data C:\Projects\scout/../runtime-CZVEDIController-rap-dev.product -dev file:C:/Projects/scout/.metadata/.plugins/org.eclipse.pde.core/CZVEDIController-rap-dev.product/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2014-05-09 11:35:15.764
!MESSAGE Product org.zeiss.mo.scout.CZVEDIController.ui.rap.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2014-05-09 11:35:15.814
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-09 11:35:15.824
!MESSAGE Bundle update@../Projects/scout/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.rap.rwt.supplemental.fileupload_1.5.0.20120220-1720.jar was not resolved.
!SUBENTRY 2 org.eclipse.rap.rwt.supplemental.fileupload 2 0 2014-05-09 11:35:15.824
!MESSAGE Missing required bundle org.eclipse.rap.rwt_1.5.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-09 11:35:15.824
!MESSAGE Bundle update@../Projects/scout/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.rap.rwt.supplemental.filedialog_1.5.0.20120220-1720.jar was not resolved.
!SUBENTRY 2 org.eclipse.rap.rwt.supplemental.filedialog 2 0 2014-05-09 11:35:15.824
!MESSAGE Missing required bundle org.eclipse.rap.rwt_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-09 11:35:15.824
!MESSAGE Bundle update@../Projects/scout/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.scout.rt.ui.rap_3.8.2.201302111336.jar was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.824
!MESSAGE Missing required bundle org.eclipse.rap.jface_1.5.0.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.824
!MESSAGE Missing required bundle org.eclipse.rap.ui_1.5.0.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.824
!MESSAGE Missing required bundle org.eclipse.rap.ui.forms_1.5.0.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.824
!MESSAGE Missing required bundle org.eclipse.rap.jface.databinding_1.5.0.

!ENTRY org.eclipse.osgi 2 0 2014-05-09 11:35:15.834
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-09 11:35:15.834
!MESSAGE Bundle org.zeiss.mo.scout.CZVEDIController.ui.rap_1.0.0.qualifier [9] was not resolved.
!SUBENTRY 2 org.zeiss.mo.scout.CZVEDIController.ui.rap 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.scout.rt.ui.rap_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-09 11:35:15.834
!MESSAGE Bundle org.eclipse.rap.rwt.supplemental.filedialog_1.5.0.20120220-1720 [82] was not resolved.
!SUBENTRY 2 org.eclipse.rap.rwt.supplemental.filedialog 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.rap.rwt_0.0.0.
!SUBENTRY 2 org.eclipse.rap.rwt.supplemental.filedialog 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.rap.rwt.supplemental.fileupload_1.5.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-09 11:35:15.834
!MESSAGE Bundle org.eclipse.rap.rwt.supplemental.fileupload_1.5.0.20120220-1720 [83] was not resolved.
!SUBENTRY 2 org.eclipse.rap.rwt.supplemental.fileupload 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.rap.rwt_1.5.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-09 11:35:15.834
!MESSAGE Bundle org.eclipse.scout.rt.ui.rap_3.8.2.201302111336 [85] was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.rap.jface_1.5.0.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.rap.jface.databinding_1.5.0.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.rap.ui.forms_1.5.0.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap 2 0 2014-05-09 11:35:15.834
!MESSAGE Missing required bundle org.eclipse.rap.ui_1.5.0.


Instead in SWT all works fine

[Updated on: Fri, 09 May 2014 05:37]

Report message to a moderator

Re: FileChooser in RAP [message #1349476 is a reply to message #1343441] Mon, 12 May 2014 04:00 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
Hi marco,
can you open your ScoutRAP.target in a text editor and add the following locations:

<location includeAllPlatforms="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.rap.runtime.feature.group" version="1.5.2.20130205-2024"/>
<repository location="http://download.eclipse.org/releases/juno"/>
</location>

<location includeAllPlatforms="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.scout.rt.rap.feature.feature.group" version="3.8.2.201302111336"/>
<repository location="http://download.eclipse.org/releases/juno"/>
</location>


After this, the plugin.xml should not contain any errors
Re: FileChooser in RAP [message #1349529 is a reply to message #1349476] Mon, 12 May 2014 04:26 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi Matthias,
I do what you suggest only in ScoutRAP.target for RAP section, not in SWT or Swing section, after that I clean and rebuild entirerly my project but the errors that I highlighted in my previous post remains.

I check and for the class StandaloneRwtEnvironment.java, the error become the following "The hierarchy of the type StandaloneRwtEnvironment is inconsistent"; instead in plugin.xml remains all the same.

Have you other suggestions or ideas?
Re: FileChooser in RAP [message #1349547 is a reply to message #1349529] Mon, 12 May 2014 04:35 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
Hm...

Try the following: Switch to a new and empty workspace. Create a new Scout Project and enable the RAP Filechooser support. Verify that the newly created project works. If it does, compare the ScoutRAP.target and *.product files with your real project ones.



Re: FileChooser in RAP [message #1349593 is a reply to message #1349547] Mon, 12 May 2014 05:00 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi Matthias,
I create a new project and add FileChooser but when I start in RAP my project give me the same error present in my official project. But I haven't signs of error on plugin.xml and on class StandaloneRwtEnvironment.java, now I compare them.

The console error message is:

eclipse.buildId=unknown
java.version=1.6.0_24
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=it_IT
Framework arguments:  -product org.zeiss.test.ui.rap.product
Command-line arguments:  -product org.zeiss.test.ui.rap.product -data C:\Projects\scout/../runtime-test-rap-dev.product -dev file:C:/Projects/scout/.metadata/.plugins/org.eclipse.pde.core/test-rap-dev.product/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.osgi 2 0 2014-05-12 10:55:13.409
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-12 10:55:13.409
!MESSAGE Bundle update@../../Projects/scout/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.scout.rt.ui.rap.incubator.filechooser_3.8.2.201302111336.jar was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap.incubator.filechooser 2 0 2014-05-12 10:55:13.409
!MESSAGE Missing required bundle org.eclipse.scout.rt.ui.rap_3.8.2.

!ENTRY org.eclipse.osgi 2 0 2014-05-12 10:55:13.409
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-05-12 10:55:13.409
!MESSAGE Bundle org.eclipse.scout.rt.ui.rap.incubator.filechooser_3.8.2.201302111336 [85] was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap.incubator.filechooser 2 0 2014-05-12 10:55:13.409
!MESSAGE Missing required bundle org.eclipse.scout.rt.ui.rap_3.8.2.
Re: FileChooser in RAP [message #1349627 is a reply to message #1349593] Mon, 12 May 2014 05:25 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi Matthias,
I find some differences in ScoutRAP.target and *.product, I replace some difference and now I'm back to the initial situation reported on the initial post of this thread.

Quote:
Hi all,
I have a problem with FileChooser in RAP because it doesn't work correctly (see image below), instead in SWT works fine.

I followed this tutorial http://wiki.eclipse.org/Scout/HowTo/3.9/Add_FileChooser_support_for_RAP_UI

index.php/fa/18008/0/

I use Eclipse Juno 3.8

And this is my configuration:
index.php/fa/18033/0/

Thanks in advance for any help and suggestions

Attachment: img_FileChooser.PNG
(Size: 3.92KB, Downloaded 201 times)
Attachment: imgRapVers.PNG
Re: FileChooser in RAP [message #1349647 is a reply to message #1349627] Mon, 12 May 2014 05:33 Go to previous messageGo to next message
Matthias Nick is currently offline Matthias Nick
Messages: 163
Registered: August 2013
Senior Member
Can you paste the complete ScoutRAP.target file to me?
Re: FileChooser in RAP [message #1349656 is a reply to message #1349647] Mon, 12 May 2014 05:35 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Here it is:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde version="3.8"?>

<target name="ScoutRAP" sequenceNumber="18">
<locations>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.scout.rt.ui.rap.incubator.filechooser.feature.feature.group" version="3.8.2.201302111336"/>
<location path="${eclipse_home}\rap_target" type="Directory"/>
</location>
<location path="${eclipse_home}\" type="Directory"/>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.rap.runtime.feature.group" version="1.5.2.20130205-2024"/>
<repository location="http://download.eclipse.org/releases/juno"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.scout.rt.rap.feature.feature.group" version="3.8.2.201302111336"/>
<repository location="http://download.eclipse.org/releases/juno"/>
</location>
<location path="C:\eclipse_scout\deltapack_4.2.2" type="Directory"/>
<location path="C:\eclipse_scout\rap_target" type="Directory"/>
<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.rap.incubator.supplemental.fileupload.feature.feature.group" version="1.5.0.20120220-1720"/>
<repository location="http://download.eclipse.org/rt/rap/1.5/incubator"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.scout.rt.ui.rap.incubator.filechooser.feature.feature.group" version="3.8.2.201302111336"/>
<repository location="http://download.eclipse.org/scout/releases/3.8"/>
</location>
</locations>
<includeBundles>
<plugin id="javax.el.source"/>
<plugin id="org.eclipse.jface.databinding"/>
<plugin id="javax.mail"/>
<plugin id="org.eclipse.ui.workbench"/>
<plugin id="org.eclipse.ui.views.properties.tabbed.source"/>
<plugin id="org.eclipse.platform"/>
<plugin id="org.eclipse.e4.ui.workbench.addons.swt"/>
<plugin id="org.eclipse.mylyn.discovery.ui"/>
<plugin id="org.eclipse.equinox.security.ui"/>
<plugin id="org.eclipse.mylyn.discovery.core"/>
<plugin id="org.eclipse.core.filebuffers.source"/>
<plugin id="org.eclipse.core.runtime.compatibility.registry.source"/>
<plugin id="org.eclipse.rap.tools.launch.rwt.source"/>
<plugin id="org.eclipse.ui.externaltools.source"/>
<plugin id="org.eclipse.jdt"/>
<plugin id="org.eclipse.wst.wsdl.ui"/>
<plugin id="org.eclipse.ant.launching"/>
<plugin id="org.eclipse.emf.codegen"/>
<plugin id="org.eclipse.wst.validation.ui"/>
<plugin id="org.eclipse.equinox.launcher.source"/>
<plugin id="org.eclipse.osgi.services"/>
<plugin id="org.eclipse.wst.command.env.infopop"/>
<plugin id="org.eclipse.ecf.filetransfer"/>
<plugin id="org.eclipse.mylyn.wikitext.confluence.core"/>
<plugin id="org.eclipse.ui.editors" version="3.6.0.v20100520-0800"/>
<plugin id="org.eclipse.wst.common.project.facet.ui"/>
<plugin id="org.eclipse.e4.ui.di.source"/>
<plugin id="org.eclipse.wst.command.env"/>
<plugin id="org.eclipse.ui.intro"/>
<plugin id="org.eclipse.equinox.p2.metadata.repository"/>
<plugin id="org.eclipse.pde.ds.ui"/>
<plugin id="org.eclipse.wst.ws.parser"/>
<plugin id="org.eclipse.wst.ws.infopop"/>
<plugin id="org.eclipse.ltk.core.refactoring.source"/>
<plugin id="org.hamcrest.core.source"/>
<plugin id="org.eclipse.equinox.p2.jarprocessor"/>
<plugin id="org.eclipse.jem.beaninfo"/>
<plugin id="org.eclipse.e4.ui.workbench3"/>
<plugin id="org.eclipse.mylyn.commons.workbench"/>
<plugin id="org.eclipse.jetty.continuation.source"/>
<plugin id="org.eclipse.jdt.launching.source"/>
<plugin id="org.eclipse.wb.os" version="1.6.1.r42x201401161243"/>
<plugin id="org.eclipse.team.svn.sources"/>
<plugin id="org.eclipse.wst.html.core"/>
<plugin id="org.eclipse.libra.framework.core"/>
<plugin id="org.eclipse.pde.ds.ui.source"/>
<plugin id="org.eclipse.equinox.preferences.source"/>
<plugin id="org.eclipse.jst.jee.ui"/>
<plugin id="org.eclipse.pde"/>
<plugin id="org.eclipse.equinox.p2.publisher.eclipse"/>
<plugin id="org.eclipse.equinox.event.source"/>
<plugin id="org.eclipse.e4.ui.workbench.addons.swt.source" version="0.10.3.v20130124-185622"/>
<plugin id="org.eclipse.mylyn.help.ui"/>
<plugin id="org.eclipse.equinox.p2.ui.sdk"/>
<plugin id="org.eclipse.equinox.p2.publisher"/>
<plugin id="javax.xml.bind"/>
<plugin id="org.eclipse.scout.svg.ui.swing"/>
<plugin id="org.eclipse.equinox.frameworkadmin.equinox"/>
<plugin id="org.eclipse.wb.core.databinding.xml" version="1.7.0.r42x201405021458"/>
<plugin id="org.eclipse.wst.internet.monitor.ui"/>
<plugin id="org.eclipse.libra.framework.editor.integration"/>
<plugin id="org.eclipse.scout.rt.ui.rap" version="3.8.2.201302111336"/>
<plugin id="org.eclipse.xsd.edit"/>
<plugin id="org.eclipse.gef.doc.isv"/>
<plugin id="org.eclipse.mylyn.team.ui"/>
<plugin id="org.eclipse.core.runtime.source"/>
<plugin id="org.eclipse.scout.nls.sdk.services.source"/>
<plugin id="org.eclipse.wst.xml.ui.infopop"/>
<plugin id="org.eclipse.pde.api.tools.source"/>
<plugin id="org.eclipse.mylyn.ide.ui"/>
<plugin id="org.eclipse.equinox.p2.directorywatcher"/>
<plugin id="org.eclipse.jst.standard.schemas"/>
<plugin id="org.apache.xmlrpc"/>
<plugin id="org.eclipse.ui.views.source"/>
<plugin id="org.eclipse.compare.core.source"/>
<plugin id="org.eclipse.jetty.http"/>
<plugin id="org.eclipse.e4.core.services"/>
<plugin id="org.eclipse.wb.swing.FormLayout" version="1.7.0.r42x201405021531"/>
<plugin id="org.eclipse.text.source"/>
<plugin id="org.eclipse.rap.tools.launch"/>
<plugin id="org.eclipse.scout.svg.ui.swt.source"/>
<plugin id="org.eclipse.wb.rcp.databinding" version="1.6.1.r42x201401161337"/>
<plugin id="org.eclipse.e4.ui.model.workbench.source"/>
<plugin id="org.eclipse.wb.rcp.SWT_AWT" version="1.7.0.r42x201405021546"/>
<plugin id="org.eclipse.mylyn.wikitext.tasks.ui"/>
<plugin id="org.eclipse.scout.sdk.rap.source"/>
<plugin id="org.eclipse.wst.common.infopop"/>
<plugin id="org.eclipse.libra.framework.equinox.ui"/>
<plugin id="org.eclipse.team.core.source"/>
<plugin id="org.eclipse.epp.package.scout"/>
<plugin id="org.apache.ws.commons.util"/>
<plugin id="org.eclipse.pde.runtime"/>
<plugin id="org.eclipse.jem.workbench"/>
<plugin id="org.eclipse.zest.doc.isv"/>
<plugin id="org.eclipse.gef.examples.logic"/>
<plugin id="org.eclipse.scout.sdk.ui.source"/>
<plugin id="org.eclipse.platform.source"/>
<plugin id="org.eclipse.wst.wsi.ui"/>
<plugin id="org.eclipse.core.databinding"/>
<plugin id="org.eclipse.ui.intro.source"/>
<plugin id="org.eclipse.equinox.p2.director.app.source"/>
<plugin id="org.eclipse.rcp.source"/>
<plugin id="org.eclipse.jst.jee"/>
<plugin id="org.eclipse.e4.ui.model.workbench"/>
<plugin id="org.eclipse.equinox.security.ui.source"/>
<plugin id="org.eclipse.ui.navigator.resources.source"/>
<plugin id="javax.xml.soap"/>
<plugin id="javax.xml.ws"/>
<plugin id="org.eclipse.wb.core.databinding" version="1.7.0.r42x201405021448"/>
<plugin id="org.eclipse.compare.source"/>
<plugin id="org.eclipse.wst.xsd.core"/>
<plugin id="org.eclipse.equinox.p2.artifact.repository.source"/>
<plugin id="org.eclipse.wst.common.emf"/>
<plugin id="org.eclipse.jst.common.project.facet.ui"/>
<plugin id="org.eclipse.equinox.p2.extensionlocation.source"/>
<plugin id="org.eclipse.scout.sdk.rap.ui.source"/>
<plugin id="org.eclipse.emf.ecore"/>
<plugin id="org.eclipse.pde.ui.templates.source"/>
<plugin id="org.eclipse.jst.ws.jaxws.dom.integration"/>
<plugin id="org.eclipse.scout.sdk.compatibility"/>
<plugin id="org.eclipse.ui.workbench.source" version="3.104.0.v20130204-164612"/>
<plugin id="org.eclipse.scout.sdk.util"/>
<plugin id="org.eclipse.ui.navigator.source"/>
<plugin id="org.eclipse.wb.runtime.lib" version="1.6.1.r42x201401161243"/>
<plugin id="javax.servlet.source"/>
<plugin id="org.eclipse.team.cvs.core.source"/>
<plugin id="org.eclipse.jdt.ui.source"/>
<plugin id="org.eclipse.wb.rcp" version="1.6.1.r42x201401161337"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v38v42.fragment"/>
<plugin id="org.eclipse.wst.xml.core"/>
<plugin id="org.eclipse.jsch.ui"/>
<plugin id="org.eclipse.wst.html.ui"/>
<plugin id="org.eclipse.jst.ws.jaxws.ui"/>
<plugin id="org.eclipse.scout.rt.ui.swing.browser.swt.fragment.source"/>
<plugin id="org.eclipse.scout.service.source"/>
<plugin id="org.eclipse.equinox.p2.ui.importexport"/>
<plugin id="org.eclipse.search"/>
<plugin id="org.eclipse.jst.j2ee.web"/>
<plugin id="org.eclipse.search.source"/>
<plugin id="org.eclipse.jdt.ui"/>
<plugin id="org.eclipse.core.runtime.compatibility.registry"/>
<plugin id="org.eclipse.equinox.p2.publisher.eclipse.source"/>
<plugin id="org.eclipse.team.svn.mylyn"/>
<plugin id="org.eclipse.core.expressions"/>
<plugin id="org.eclipse.wst.sse.ui.infopop"/>
<plugin id="org.apache.lucene.core"/>
<plugin id="org.eclipse.jst.j2ee.jca"/>
<plugin id="org.eclipse.team.ui.source"/>
<plugin id="org.eclipse.jetty.security.source"/>
<plugin id="org.eclipse.libra.framework.felix.ui"/>
<plugin id="org.apache.derby.jdbc_1082.fragment.source"/>
<plugin id="org.eclipse.wb.rcp.nebula" version="1.6.1.r42x201401161337"/>
<plugin id="org.eclipse.wst.common.emfworkbench.integration"/>
<plugin id="org.eclipse.scout.sdk.help.source"/>
<plugin id="org.eclipse.jdt.launching"/>
<plugin id="org.eclipse.ltk.core.refactoring"/>
<plugin id="org.eclipse.rap.tools.intro"/>
<plugin id="org.eclipse.ui"/>
<plugin id="org.eclipse.debug.ui.source"/>
<plugin id="org.eclipse.equinox.jsp.jasper.registry.source"/>
<plugin id="org.eclipse.help.ui"/>
<plugin id="org.apache.commons.logging"/>
<plugin id="org.eclipse.compare.win32.source"/>
<plugin id="org.eclipse.team.svn.resource.ignore.rules.jdt.source"/>
<plugin id="org.eclipse.scout.rt.jdbc.derby.source"/>
<plugin id="org.eclipse.jst.server.core"/>
<plugin id="org.eclipse.gef.examples.text"/>
<plugin id="org.eclipse.wb.core.databinding.xml" version="1.6.1.r42x201401161254"/>
<plugin id="org.eclipse.jst.jee.web"/>
<plugin id="org.eclipse.equinox.app"/>
<plugin id="org.eclipse.mylyn.commons.notifications.core"/>
<plugin id="org.eclipse.team.svn.mylyn.source"/>
<plugin id="org.eclipse.ui.console"/>
<plugin id="org.eclipse.wb.runtime.lib" version="1.7.0.r42x201405021445"/>
<plugin id="org.eclipse.wb.core.java" version="1.7.0.r42x201405021448"/>
<plugin id="org.eclipse.swt.win32.win32.x86_64.source" version="3.100.1.v4236b"/>
<plugin id="org.w3c.dom.smil"/>
<plugin id="org.eclipse.equinox.preferences"/>
<plugin id="org.eclipse.team.cvs.ssh2.source"/>
<plugin id="org.eclipse.wst.validation"/>
<plugin id="org.eclipse.wst.common.uriresolver"/>
<plugin id="org.eclipse.wst.css.core"/>
<plugin id="org.apache.felix.gogo.command.source"/>
<plugin id="org.eclipse.mylyn.commons.identity"/>
<plugin id="org.eclipse.jdt.doc.user"/>
<plugin id="org.eclipse.scout.nls.sdk.simple"/>
<plugin id="org.eclipse.zest.layouts"/>
<plugin id="org.eclipse.help.webapp"/>
<plugin id="org.eclipse.ui.source"/>
<plugin id="org.eclipse.gef.examples.ui.pde"/>
<plugin id="org.eclipse.wb.core.databinding" version="1.6.1.r42x201401161246"/>
<plugin id="org.apache.jasper.glassfish.source"/>
<plugin id="org.eclipse.ui.workbench.source" version="3.104.0.v20121219-151754"/>
<plugin id="org.eclipse.jdt.core.manipulation.source"/>
<plugin id="org.eclipse.scout.rt.ui.swt"/>
<plugin id="org.eclipse.e4.ui.workbench.renderers.swt.source" version="0.10.3.v20121206-163705"/>
<plugin id="org.eclipse.wb.rcp.databinding" version="1.7.0.r42x201405021526"/>
<plugin id="org.eclipse.equinox.http.registry"/>
<plugin id="javax.xml.stream"/>
<plugin id="org.eclipse.core.filesystem.source"/>
<plugin id="org.apache.ant.source"/>
<plugin id="org.eclipse.wst.common.environment"/>
<plugin id="org.jdom"/>
<plugin id="org.eclipse.jst.common.annotations.controller"/>
<plugin id="org.eclipse.wst.wsdl.ui.doc.user"/>
<plugin id="org.eclipse.scout.net.source"/>
<plugin id="org.eclipse.jface.text.source"/>
<plugin id="org.eclipse.pde.build.source"/>
<plugin id="org.eclipse.e4.ui.workbench3.source"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.ssl"/>
<plugin id="org.eclipse.wst.xml.ui"/>
<plugin id="org.eclipse.scout.http.servletfilter.source"/>
<plugin id="org.eclipse.libra.framework.jonas"/>
<plugin id="org.eclipse.team.cvs.core"/>
<plugin id="org.eclipse.equinox.p2.metadata.repository.source"/>
<plugin id="org.eclipse.core.jobs.source"/>
<plugin id="org.eclipse.e4.core.services.source"/>
<plugin id="org.eclipse.equinox.servletbridge"/>
<plugin id="org.eclipse.wb.swing" version="1.6.1.r42x201401161333"/>
<plugin id="org.eclipse.equinox.jsp.jasper.registry"/>
<plugin id="org.eclipse.equinox.jsp.jasper.source"/>
<plugin id="org.eclipse.gef.examples.logic.source"/>
<plugin id="org.eclipse.scout.rt.client"/>
<plugin id="org.eclipse.wst.sse.doc.user"/>
<plugin id="org.eclipse.epp.mpc.core"/>
<plugin id="org.eclipse.scout.rt.ui.swt.source"/>
<plugin id="org.eclipse.e4.core.contexts.source" version="1.2.0.v20121024-182359"/>
<plugin id="org.eclipse.equinox.p2.ui.source"/>
<plugin id="org.eclipse.scout.rt.ui.rap.incubator.filechooser"/>
<plugin id="org.eclipse.wst.ws.explorer"/>
<plugin id="org.eclipse.help"/>
<plugin id="org.eclipse.jetty.security"/>
<plugin id="org.eclipse.mylyn.commons.ui"/>
<plugin id="org.eclipse.equinox.simpleconfigurator"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v35.fragment.source"/>
<plugin id="org.eclipse.equinox.simpleconfigurator.manipulator"/>
<plugin id="org.eclipse.team.svn.resource.ignore.rules.jdt"/>
<plugin id="org.eclipse.ui.ide.source"/>
<plugin id="org.eclipse.jst.ws.jaxws.core"/>
<plugin id="org.eclipse.core.databinding.beans.source"/>
<plugin id="org.apache.ant"/>
<plugin id="org.eclipse.equinox.p2.touchpoint.eclipse.source"/>
<plugin id="org.eclipse.team.svn.ui.startup"/>
<plugin id="com.jcraft.jsch.source"/>
<plugin id="org.eclipse.swt.win32.win32.x86_64.source" version="3.100.1.v4235f"/>
<plugin id="org.eclipse.mylyn.wikitext.twiki.ui"/>
<plugin id="org.eclipse.osgi.source"/>
<plugin id="org.eclipse.equinox.p2.discovery.compatibility"/>
<plugin id="org.eclipse.osgi.util.source"/>
<plugin id="org.eclipse.pde.build"/>
<plugin id="org.apache.commons.codec" version="1.3.0.v201101211617"/>
<plugin id="org.eclipse.pde.ui.templates"/>
<plugin id="org.apache.commons.httpclient.source"/>
<plugin id="org.eclipse.equinox.p2.repository"/>
<plugin id="org.eclipse.equinox.http.servletbridge"/>
<plugin id="org.eclipse.wst.web.ui"/>
<plugin id="org.eclipse.e4.core.di.extensions"/>
<plugin id="org.eclipse.wb.rcp.databinding.xwt" version="1.6.1.r42x201401161343"/>
<plugin id="org.eclipse.scout.rt.ui.rap" version="3.8.2.201302111336"/>
<plugin id="org.eclipse.ui.win32"/>
<plugin id="org.eclipse.wb.swt" version="1.6.1.r42x201401161320"/>
<plugin id="org.eclipse.wst.ws.service.policy"/>
<plugin id="org.eclipse.wb.os.win32" version="1.7.0.r42x201405021445"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v38v42.fragment.source"/>
<plugin id="org.eclipse.scout.nls.sdk"/>
<plugin id="org.eclipse.scout.rt.feature.about"/>
<plugin id="org.eclipse.e4.ui.css.swt.theme.source"/>
<plugin id="org.eclipse.team.cvs.ui"/>
<plugin id="org.eclipse.mylyn.bugzilla.core"/>
<plugin id="org.eclipse.libra.framework.editor.ui"/>
<plugin id="org.eclipse.e4.ui.workbench"/>
<plugin id="org.eclipse.e4.ui.css.core"/>
<plugin id="org.eclipse.osgi.services.source"/>
<plugin id="org.eclipse.jst.jsp.ui.infopop"/>
<plugin id="org.apache.batik.ext.awt"/>
<plugin id="org.eclipse.equinox.security.win32.x86_64"/>
<plugin id="org.eclipse.jst.j2ee.ejb"/>
<plugin id="org.eclipse.wb.swing.jsr296" version="1.7.0.r42x201405021531"/>
<plugin id="org.apache.commons.logging.source"/>
<plugin id="org.eclipse.jem"/>
<plugin id="org.eclipse.wb.core" version="1.6.1.r42x201401161243"/>
<plugin id="org.junit4"/>
<plugin id="org.eclipse.ui.editors" version="3.8.0.v20120523-1540"/>
<plugin id="org.eclipse.e4.ui.services.source" version="0.10.2.v20121129-151235"/>
<plugin id="org.eclipse.mylyn.commons.core"/>
<plugin id="org.eclipse.wst.internet.cache"/>
<plugin id="org.apache.commons.fileupload"/>
<plugin id="org.eclipse.compare"/>
<plugin id="org.eclipse.scout.sdk.compatibility.source"/>
<plugin id="org.eclipse.ui.views"/>
<plugin id="javax.xml.rpc"/>
<plugin id="org.eclipse.jdt.annotation"/>
<plugin id="org.eclipse.update.configurator.source"/>
<plugin id="org.eclipse.mylyn.wikitext.twiki.core"/>
<plugin id="org.eclipse.equinox.launcher.win32.win32.x86_64"/>
<plugin id="org.eclipse.jst.server.ui"/>
<plugin id="org.eclipse.wb.doc.user" version="1.7.0.r42x201405021506"/>
<plugin id="org.eclipse.equinox.app.source"/>
<plugin id="org.apache.batik.dom"/>
<plugin id="org.eclipse.ui.workbench.texteditor"/>
<plugin id="org.eclipse.scout.sdk.rap.ui"/>
<plugin id="org.eclipse.jst.common.project.facet.core"/>
<plugin id="org.eclipse.wb.core.ui" version="1.7.0.r42x201405021455"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient"/>
<plugin id="javax.annotation"/>
<plugin id="org.eclipse.wb.swing.doc.user" version="1.6.1.r42x201401180444"/>
<plugin id="org.eclipse.scout.sdk.ws.jaxws"/>
<plugin id="org.eclipse.equinox.security"/>
<plugin id="org.eclipse.pde.runtime.source"/>
<plugin id="org.eclipse.jst.j2ee.ui"/>
<plugin id="com.oracle.oracle11g.jdbc.fragment"/>
<plugin id="org.eclipse.equinox.p2.ui"/>
<plugin id="org.eclipse.ui.workbench.texteditor.source"/>
<plugin id="org.eclipse.e4.ui.widgets.source"/>
<plugin id="org.eclipse.text"/>
<plugin id="org.eclipse.core.resources.source"/>
<plugin id="org.eclipse.ui.editors" version="3.7.0.v20110517-0800"/>
<plugin id="org.eclipse.equinox.security.source"/>
<plugin id="org.eclipse.wb.os.win32" version="1.6.1.r42x201401161243"/>
<plugin id="org.eclipse.team.core"/>
<plugin id="org.eclipse.team.ui"/>
<plugin id="org.eclipse.jetty.continuation"/>
<plugin id="org.eclipse.compare.win32"/>
<plugin id="org.eclipse.wb.swing.FormLayout" version="1.6.1.r42x201401161333"/>
<plugin id="org.eclipse.compare.core"/>
<plugin id="org.eclipse.jdt.annotation.source"/>
<plugin id="org.eclipse.ecf.filetransfer.source"/>
<plugin id="org.polarion.eclipse.team.svn.connector.sources"/>
<plugin id="org.objectweb.asm.source"/>
<plugin id="org.eclipse.mylyn.commons.notifications.ui"/>
<plugin id="org.polarion.eclipse.team.svn.connector.javahl17"/>
<plugin id="org.eclipse.equinox.p2.ui.sdk.scheduler"/>
<plugin id="org.eclipse.jst.j2ee"/>
<plugin id="org.eclipse.mylyn.tasks.index.core"/>
<plugin id="org.eclipse.draw2d"/>
<plugin id="org.eclipse.e4.ui.services.source" version="0.10.3.v20130123-162658"/>
<plugin id="org.eclipse.mylyn.commons.screenshots"/>
<plugin id="org.w3c.css.sac"/>
<plugin id="org.eclipse.wst.internet.monitor.core"/>
<plugin id="org.eclipse.core.net"/>
<plugin id="org.eclipse.jdt.compiler.apt"/>
<plugin id="org.eclipse.scout.sdk.rap"/>
<plugin id="org.eclipse.jdt.compiler.tool"/>
<plugin id="com.bsiag.scout.rt.server.jdbc.oracle11g2.source"/>
<plugin id="org.eclipse.wst.sse.ui"/>
<plugin id="org.eclipse.pde.ds.core"/>
<plugin id="org.objectweb.asm"/>
<plugin id="org.eclipse.emf.edit.ui"/>
<plugin id="org.polarion.eclipse.team.svn.connector"/>
<plugin id="org.eclipse.jsch.core"/>
<plugin id="javax.xml"/>
<plugin id="org.eclipse.team.svn.nl1"/>
<plugin id="org.eclipse.wb.core" version="1.7.0.r42x201405021445"/>
<plugin id="org.apache.batik.parser"/>
<plugin id="org.eclipse.wb.swing.FormLayout.lib" version="1.7.0.r42x201405021531"/>
<plugin id="org.eclipse.ui.forms.source"/>
<plugin id="org.eclipse.rap.rwt.supplemental.filedialog"/>
<plugin id="org.eclipse.mylyn.ide.ant"/>
<plugin id="org.eclipse.core.databinding.property.source"/>
<plugin id="org.eclipse.jdt.core"/>
<plugin id="org.eclipse.wb.swing.jsr296" version="1.6.1.r42x201401161333"/>
<plugin id="org.eclipse.sdk"/>
<plugin id="org.eclipse.rap.tools.templates.source"/>
<plugin id="org.eclipse.mylyn.wikitext.tracwiki.ui"/>
<plugin id="org.eclipse.equinox.p2.reconciler.dropins.source"/>
<plugin id="org.eclipse.wb.swing.MigLayout" version="1.6.1.r42x201401161333"/>
<plugin id="com.ibm.icu.source"/>
<plugin id="org.eclipse.mylyn.wikitext.confluence.ui"/>
<plugin id="org.eclipse.jst.ws.jaxb.core"/>
<plugin id="org.eclipse.jst.j2ee.navigator.ui"/>
<plugin id="org.eclipse.jetty.xml"/>
<plugin id="com.jcraft.jsch"/>
<plugin id="org.eclipse.scout.sdk.util.source"/>
<plugin id="org.eclipse.equinox.p2.director"/>
<plugin id="org.eclipse.zest.core.source"/>
<plugin id="org.eclipse.wst.ws"/>
<plugin id="org.eclipse.equinox.p2.repository.tools"/>
<plugin id="org.eclipse.ecf.provider.filetransfer"/>
<plugin id="org.eclipse.jdt.doc.isv"/>
<plugin id="org.eclipse.equinox.http.jetty"/>
<plugin id="org.eclipse.wst.wsi"/>
<plugin id="org.eclipse.gef"/>
<plugin id="org.apache.lucene.analysis"/>
<plugin id="org.eclipse.scout.rt.ui.svg.calendar"/>
<plugin id="org.eclipse.e4.ui.css.core.source"/>
<plugin id="javax.inject"/>
<plugin id="org.eclipse.wst.sse.core"/>
<plugin id="org.eclipse.osgi"/>
<plugin id="org.eclipse.rcp"/>
<plugin id="org.eclipse.e4.ui.workbench.addons.swt.source" version="0.10.2.v20121204-133635"/>
<plugin id="org.apache.batik.util.gui"/>
<plugin id="org.eclipse.equinox.p2.updatechecker.source"/>
<plugin id="org.eclipse.rap.tools.launch.rwt"/>
<plugin id="org.eclipse.platform.doc.isv"/>
<plugin id="org.eclipse.help.base"/>
<plugin id="org.easymock"/>
<plugin id="org.eclipse.libra.framework.editor.core"/>
<plugin id="org.eclipse.mylyn.wikitext.tracwiki.core"/>
<plugin id="org.eclipse.jetty.io.source"/>
<plugin id="org.eclipse.wb.xwt" version="1.7.0.r42x201405021548"/>
<plugin id="org.eclipse.mylyn.commons.identity.core"/>
<plugin id="org.eclipse.jdt.junit"/>
<plugin id="org.eclipse.core.databinding.observable.source"/>
<plugin id="org.eclipse.core.jobs"/>
<plugin id="org.eclipse.ant.launching.source"/>
<plugin id="org.eclipse.jface"/>
<plugin id="org.eclipse.debug.core"/>
<plugin id="org.eclipse.e4.core.commands"/>
<plugin id="org.eclipse.mylyn.context.ui"/>
<plugin id="org.eclipse.ecf.identity.source"/>
<plugin id="org.eclipse.e4.ui.widgets"/>
<plugin id="org.eclipse.equinox.p2.ui.importexport.source"/>
<plugin id="org.apache.lucene.analysis.source"/>
<plugin id="org.eclipse.pde.ui.source"/>
<plugin id="org.eclipse.e4.ui.workbench.source" version="0.10.3.v20121207-204447"/>
<plugin id="org.eclipse.e4.ui.workbench.swt.source" version="0.10.3.v20130124-133900"/>
<plugin id="org.eclipse.core.externaltools.source"/>
<plugin id="org.polarion.eclipse.team.svn.connector.javahl16.sources"/>
<plugin id="org.eclipse.mylyn.commons.net"/>
<plugin id="org.eclipse.mylyn.tasks.core"/>
<plugin id="org.eclipse.jst.common.frameworks"/>
<plugin id="org.eclipse.jst.jsp.core"/>
<plugin id="org.eclipse.wst.dtd.core"/>
<plugin id="org.eclipse.jdt.compiler.tool.source"/>
<plugin id="org.eclipse.team.svn.nl1.sources"/>
<plugin id="org.eclipse.wb.rcp.swing2swt" version="1.7.0.r42x201405021526"/>
<plugin id="org.eclipse.mylyn.resources.ui"/>
<plugin id="org.eclipse.gef.examples.shapes"/>
<plugin id="com.oracle.oracle11g.jdbc.fragment.source"/>
<plugin id="org.eclipse.equinox.ds.source"/>
<plugin id="org.eclipse.cvs"/>
<plugin id="org.eclipse.equinox.http.jetty.source"/>
<plugin id="org.eclipse.scout.svg.ui.swt"/>
<plugin id="org.eclipse.wst.jsdt.core"/>
<plugin id="org.eclipse.mylyn.commons.notifications.feed"/>
<plugin id="org.uddi4j"/>
<plugin id="org.apache.lucene.source"/>
<plugin id="org.eclipse.ui.intro.universal.source"/>
<plugin id="org.eclipse.equinox.frameworkadmin.source"/>
<plugin id="org.eclipse.rap.rwt.supplemental.filedialog.source"/>
<plugin id="org.eclipse.scout.nls.sdk.source"/>
<plugin id="org.eclipse.jst.common.annotations.ui"/>
<plugin id="org.eclipse.wst.ws.service.policy.ui"/>
<plugin id="org.eclipse.e4.ui.bindings.source" version="0.10.2.v20121107-162442"/>
<plugin id="org.eclipse.jst.j2ee.core"/>
<plugin id="org.jsoup"/>
<plugin id="org.eclipse.mylyn.commons.xmlrpc"/>
<plugin id="org.eclipse.mylyn.bugzilla.ui"/>
<plugin id="org.eclipse.scout.svg.client"/>
<plugin id="org.eclipse.platform.doc.user"/>
<plugin id="org.eclipse.jst.j2ee.ejb.annotation.model"/>
<plugin id="org.eclipse.jface.text"/>
<plugin id="org.eclipse.mylyn.wikitext.help.ui"/>
<plugin id="org.eclipse.rap.rwt.supplemental.fileupload.source"/>
<plugin id="org.eclipse.wb.core.ui" version="1.6.1.r42x201401161252"/>
<plugin id="org.eclipse.help.webapp.source"/>
<plugin id="org.eclipse.jetty.server.source"/>
<plugin id="org.eclipse.ecf.source"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v36.fragment.source"/>
<plugin id="org.eclipse.jst.ws.annotations.core"/>
<plugin id="org.eclipse.wb.core.java" version="1.6.1.r42x201401161246"/>
<plugin id="org.eclipse.jsch.ui.source"/>
<plugin id="javax.el"/>
<plugin id="org.apache.batik.dom.svg"/>
<plugin id="org.eclipse.scout.rt.rap.target"/>
<plugin id="org.eclipse.wb.rcp.nebula" version="1.7.0.r42x201405021526"/>
<plugin id="org.eclipse.wb.core.xml" version="1.6.1.r42x201401161254"/>
<plugin id="org.eclipse.jetty.server"/>
<plugin id="org.eclipse.scout.net"/>
<plugin id="org.eclipse.e4.ui.bindings"/>
<plugin id="org.eclipse.wb.doc.user" version="1.6.1.r42x201401161302"/>
<plugin id="org.eclipse.core.runtime.compatibility.source"/>
<plugin id="org.eclipse.wb.rcp.SWT_AWT" version="1.6.1.r42x201401161350"/>
<plugin id="org.eclipse.mylyn.tasks.index.ui"/>
<plugin id="org.eclipse.equinox.jsp.jasper"/>
<plugin id="org.apache.batik.util"/>
<plugin id="org.eclipse.e4.core.di.extensions.source"/>
<plugin id="org.eclipse.wb.swing.FormLayout.lib" version="1.6.1.r42x201401161333"/>
<plugin id="org.eclipse.ui.win32.source"/>
<plugin id="org.eclipse.jst.jsp.ui"/>
<plugin id="org.eclipse.ecf.ssl"/>
<plugin id="org.eclipse.core.variables"/>
<plugin id="org.eclipse.scout.sdk.ui"/>
<plugin id="org.eclipse.team.cvs.ssh2"/>
<plugin id="org.eclipse.pde.core"/>
<plugin id="org.eclipse.core.expressions.source"/>
<plugin id="javax.wsdl" version="1.5.1.v201012040544"/>
<plugin id="org.eclipse.scout.rt.shared.legacy.texts.fragment"/>
<plugin id="org.eclipse.wst.xsd.ui"/>
<plugin id="org.eclipse.scout.rt.server.source"/>
<plugin id="org.eclipse.ui.ide"/>
<plugin id="org.polarion.eclipse.team.svn.connector.javahl17.win64"/>
<plugin id="org.eclipse.equinox.p2.repository.tools.source"/>
<plugin id="org.eclipse.wst.wsdl"/>
<plugin id="org.eclipse.wb.swing.java6" version="1.7.0.r42x201405021531"/>
<plugin id="org.eclipse.gef.examples.shapes.source"/>
<plugin id="org.eclipse.core.commands.source"/>
<plugin id="org.eclipse.equinox.common.source"/>
<plugin id="org.eclipse.equinox.registry.source"/>
<plugin id="org.apache.derby.jdbc_1053.fragment"/>
<plugin id="org.eclipse.pde.launching"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v37v41.fragment.source"/>
<plugin id="org.eclipse.equinox.bidi.source"/>
<plugin id="org.eclipse.scout.nls.sdk.simple.source"/>
<plugin id="org.eclipse.scout.rt.ui.swing.browser.swt.fragment"/>
<plugin id="org.eclipse.core.net.source"/>
<plugin id="org.eclipse.ui.browser"/>
<plugin id="org.eclipse.pde.core.source"/>
<plugin id="org.eclipse.wb.swing.databinding" version="1.7.0.r42x201405021531"/>
<plugin id="org.eclipse.core.filesystem.win32.x86_64"/>
<plugin id="org.eclipse.jst.j2ee.jca.ui"/>
<plugin id="org.eclipse.ui.navigator.resources"/>
<plugin id="org.eclipse.jem.beaninfo.vm"/>
<plugin id="org.eclipse.e4.ui.css.swt.theme"/>
<plugin id="org.eclipse.scout.nls.sdk.services"/>
<plugin id="org.eclipse.scout.jaxws216"/>
<plugin id="org.eclipse.wst.standard.schemas"/>
<plugin id="org.eclipse.team.svn.ui"/>
<plugin id="org.eclipse.pde.junit.runtime.source"/>
<plugin id="org.eclipse.equinox.launcher"/>
<plugin id="com.sun.el.source"/>
<plugin id="org.eclipse.mylyn.commons.notifications"/>
<plugin id="org.eclipse.equinox.p2.ui.sdk.scheduler.source"/>
<plugin id="org.eclipse.wb.swt.widgets.baseline" version="1.6.1.r42x201401161337"/>
<plugin id="org.eclipse.jst.ws.jaxws.dom.runtime"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient.ssl"/>
<plugin id="org.eclipse.ui.cheatsheets"/>
<plugin id="org.eclipse.ui.editors.source"/>
<plugin id="org.eclipse.team.svn.ui.nl1"/>
<plugin id="org.eclipse.e4.core.contexts.source" version="1.2.0.v20121221-192508"/>
<plugin id="org.eclipse.jst.common.ui"/>
<plugin id="org.eclipse.wb.swing.databinding" version="1.6.1.r42x201401161333"/>
<plugin id="org.eclipse.wst.common.modulecore"/>
<plugin id="org.eclipse.gef.examples.flow.source"/>
<plugin id="org.eclipse.equinox.p2.operations"/>
<plugin id="org.eclipse.gef.source"/>
<plugin id="org.eclipse.wst.jsdt.web.support.jsp"/>
<plugin id="org.apache.wsil4j"/>
<plugin id="org.eclipse.scout.rt.ui.swing"/>
<plugin id="org.eclipse.scout.jaxws216.source"/>
<plugin id="org.eclipse.mylyn.wikitext.textile.ui"/>
<plugin id="org.eclipse.libra.framework.jonas.ui"/>
<plugin id="org.eclipse.libra.facet.ui"/>
<plugin id="org.eclipse.wb.swing.doc.user" version="1.7.0.r42x201405030444"/>
<plugin id="org.eclipse.pde.source"/>
<plugin id="org.eclipse.jst.ws"/>
<plugin id="org.eclipse.emf.common"/>
<plugin id="org.eclipse.equinox.p2.transport.ecf.source"/>
<plugin id="org.eclipse.pde.ua.core"/>
<plugin id="org.eclipse.equinox.p2.director.app"/>
<plugin id="org.eclipse.ant.ui"/>
<plugin id="org.eclipse.wst.server.core"/>
<plugin id="org.eclipse.update.configurator"/>
<plugin id="org.sat4j.pb"/>
<plugin id="org.junit" version="3.8.2.v3_8_2_v20100427-1100"/>
<plugin id="org.eclipse.pde.api.tools.ui.source"/>
<plugin id="org.eclipse.team.svn.core"/>
<plugin id="org.eclipse.wst.css.ui"/>
<plugin id="org.eclipse.mylyn.wikitext.textile.core"/>
<plugin id="org.eclipse.mylyn.tasks.ui"/>
<plugin id="org.eclipse.emf.common.ui"/>
<plugin id="org.apache.batik.svggen"/>
<plugin id="org.eclipse.equinox.p2.reconciler.dropins"/>
<plugin id="org.eclipse.e4.ui.workbench.renderers.swt.source" version="0.10.3.v20130124-170312"/>
<plugin id="org.eclipse.pde.ui"/>
<plugin id="org.apache.batik.swing"/>
<plugin id="org.eclipse.equinox.registry"/>
<plugin id="org.eclipse.wst.wsdl.validation"/>
<plugin id="org.eclipse.wst.server.discovery"/>
<plugin id="org.eclipse.team.svn.revision.graph.source"/>
<plugin id="org.eclipse.ecf.identity"/>
<plugin id="org.eclipse.wst.jsdt.web.core"/>
<plugin id="org.eclipse.equinox.http.servlet"/>
<plugin id="org.eclipse.jface.source" version="3.8.102.v20130123-162658"/>
<plugin id="org.apache.derby.jdbc_1053.fragment.source"/>
<plugin id="org.eclipse.scout.rt.client.source"/>
<plugin id="org.eclipse.wst.validation.infopop"/>
<plugin id="org.eclipse.core.variables.source"/>
<plugin id="org.eclipse.draw2d.doc.isv"/>
<plugin id="org.apache.felix.gogo.runtime.source"/>
<plugin id="org.eclipse.jem.beaninfo.vm.common"/>
<plugin id="org.eclipse.ant.core.source"/>
<plugin id="org.eclipse.e4.core.di"/>
<plugin id="org.eclipse.wst.dtd.ui.infopop"/>
<plugin id="org.eclipse.wst.dtdeditor.doc.user"/>
<plugin id="org.eclipse.mylyn.wikitext.ui"/>
<plugin id="org.eclipse.jdt.junit.core"/>
<plugin id="org.eclipse.scout.http.servletfilter"/>
<plugin id="org.eclipse.jdt.apt.ui.source"/>
<plugin id="org.eclipse.equinox.p2.touchpoint.natives.source"/>
<plugin id="org.eclipse.wst.common.modulecore.ui"/>
<plugin id="org.eclipse.core.contenttype"/>
<plugin id="org.eclipse.ui.cheatsheets.source"/>
<plugin id="org.eclipse.jdt.debug.source"/>
<plugin id="org.eclipse.wb.swt.widgets.baseline" version="1.7.0.r42x201405021526"/>
<plugin id="org.junit" version="4.10.0.v4_10_0_v20120426-0900"/>
<plugin id="org.eclipse.wb.core.xml" version="1.7.0.r42x201405021458"/>
<plugin id="org.eclipse.mylyn.commons.repositories.core"/>
<plugin id="org.eclipse.core.filesystem"/>
<plugin id="org.eclipse.equinox.p2.core.source"/>
<plugin id="org.apache.lucene"/>
<plugin id="org.eclipse.jetty.webapp"/>
<plugin id="org.eclipse.zest.core"/>
<plugin id="org.eclipse.mylyn.commons.repositories"/>
<plugin id="org.eclipse.xsd"/>
<plugin id="org.apache.batik.bridge"/>
<plugin id="javax.servlet"/>
<plugin id="org.polarion.eclipse.team.svn.connector.svnkit17"/>
<plugin id="org.eclipse.equinox.p2.ui.sdk.source"/>
<plugin id="org.eclipse.osgi.util"/>
<plugin id="org.eclipse.scout.svg.client.source"/>
<plugin id="org.eclipse.scout.sdk.help"/>
<plugin id="org.eclipse.jetty.io"/>
<plugin id="org.sat4j.core"/>
<plugin id="org.eclipse.jdt.apt.core"/>
<plugin id="org.eclipse.emf.ecore.change"/>
<plugin id="org.eclipse.equinox.p2.engine"/>
<plugin id="com.sun.el"/>
<plugin id="org.eclipse.mylyn.java.ui"/>
<plugin id="org.eclipse.mylyn.team.cvs"/>
<plugin id="org.eclipse.jdt.core.manipulation"/>
<plugin id="org.eclipse.mylyn.pde.ui"/>
<plugin id="org.eclipse.wb.swing.java6" version="1.6.1.r42x201401161333"/>
<plugin id="org.eclipse.equinox.p2.updatesite"/>
<plugin id="org.eclipse.e4.ui.css.swt.source"/>
<plugin id="org.apache.derby.jdbc_1082.fragment"/>
<plugin id="org.eclipse.team.svn.core.nl1"/>
<plugin id="org.eclipse.mylyn.wikitext.core"/>
<plugin id="org.eclipse.jdt.junit.core.source"/>
<plugin id="com.sun.syndication"/>
<plugin id="org.eclipse.core.databinding.property"/>
<plugin id="org.apache.felix.gogo.runtime"/>
<plugin id="org.eclipse.wb.swing" version="1.7.0.r42x201405021531"/>
<plugin id="org.eclipse.jst.common.annotations.core"/>
<plugin id="org.eclipse.ui.ide.application.source"/>
<plugin id="org.eclipse.rap.rwt.supplemental.fileupload"/>
<plugin id="org.eclipse.jsch.core.source"/>
<plugin id="org.eclipse.scout.sdk"/>
<plugin id="org.eclipse.debug.core.source"/>
<plugin id="org.eclipse.equinox.p2.ql.source"/>
<plugin id="org.eclipse.pde.ds.core.source"/>
<plugin id="org.eclipse.libra.framework.felix"/>
<plugin id="org.eclipse.equinox.p2.publisher.source"/>
<plugin id="org.eclipse.wb.rcp.swing2swt" version="1.6.1.r42x201401161337"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v35.fragment"/>
<plugin id="org.eclipse.ui.navigator"/>
<plugin id="org.eclipse.equinox.p2.operations.source"/>
<plugin id="org.eclipse.ui.views.log.source"/>
<plugin id="org.eclipse.jetty.servlet.source"/>
<plugin id="org.eclipse.equinox.p2.jarprocessor.source"/>
<plugin id="org.junit.source" version="3.8.2.v3_8_2_v20100427-1100"/>
<plugin id="org.eclipse.scout.rt.jdbc.derby"/>
<plugin id="org.eclipse.mylyn.java.tasks"/>
<plugin id="org.eclipse.wb.rcp.databinding.emf" version="1.7.0.r42x201405021526"/>
<plugin id="org.eclipse.wst.command.env.core"/>
<plugin id="org.eclipse.e4.core.di.source"/>
<plugin id="org.eclipse.e4.ui.workbench.source" version="0.11.0.v20130125-100758"/>
<plugin id="org.eclipse.wb.swing.MigLayout.lib" version="1.6.1.r42x201401161333"/>
<plugin id="org.eclipse.wb.rcp.databinding.emf" version="1.6.1.r42x201401161337"/>
<plugin id="org.eclipse.wst.dtd.ui"/>
<plugin id="org.eclipse.scout.sdk.ws.jaxws.source"/>
<plugin id="org.eclipse.emf.edit"/>
<plugin id="org.eclipse.ui.trace"/>
<plugin id="org.eclipse.ui.net"/>
<plugin id="org.eclipse.core.runtime.compatibility"/>
<plugin id="org.eclipse.core.runtime.compatibility.auth"/>
<plugin id="org.apache.batik.css"/>
<plugin id="org.eclipse.equinox.p2.updatesite.source"/>
<plugin id="org.apache.lucene.core.source"/>
<plugin id="org.eclipse.pde.junit.runtime"/>
<plugin id="org.eclipse.wb.core.lib" version="1.7.0.r42x201405021445"/>
<plugin id="org.eclipse.jdt.debug.ui"/>
<plugin id="org.eclipse.gef.examples.flow"/>
<plugin id="org.eclipse.e4.core.commands.source"/>
<plugin id="org.eclipse.mylyn.bugzilla.ide"/>
<plugin id="org.eclipse.wst.wsi.ui.doc.user"/>
<plugin id="org.eclipse.wst.common.ui"/>
<plugin id="org.eclipse.ui.views.properties.tabbed"/>
<plugin id="javax.jws"/>
<plugin id="org.eclipse.core.resources"/>
<plugin id="org.apache.axis"/>
<plugin id="org.eclipse.mylyn.tasks.search"/>
<plugin id="org.hamcrest.core"/>
<plugin id="org.apache.commons.io"/>
<plugin id="org.eclipse.swt.win32.win32.x86_64"/>
<plugin id="org.eclipse.wb.os" version="1.7.0.r42x201405021445"/>
<plugin id="org.eclipse.mylyn.wikitext.mediawiki.ui"/>
<plugin id="org.eclipse.mylyn.context.core"/>
<plugin id="javax.wsdl" version="1.6.2.v201012040545"/>
<plugin id="org.eclipse.pde.api.tools.ui"/>
<plugin id="org.eclipse.equinox.http.registry.source"/>
<plugin id="org.eclipse.mylyn.monitor.core"/>
<plugin id="org.eclipse.wst.xmleditor.doc.user"/>
<plugin id="com.ibm.icu"/>
<plugin id="org.polarion.eclipse.team.svn.connector.javahl16"/>
<plugin id="org.eclipse.equinox.concurrent"/>
<plugin id="org.eclipse.equinox.p2.garbagecollector.source"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient.ssl.source"/>
<plugin id="org.eclipse.scout.sdk.source"/>
<plugin id="org.eclipse.pde.ua.ui"/>
<plugin id="org.eclipse.scout.commons.source"/>
<plugin id="org.eclipse.wst.server.ui"/>
<plugin id="org.eclipse.debug.ui"/>
<plugin id="org.eclipse.libra.framework.equinox"/>
<plugin id="org.eclipse.jetty.http.source"/>
<plugin id="org.polarion.eclipse.team.svn.connector.svnkit16"/>
<plugin id="org.eclipse.libra.framework.knopflerfish"/>
<plugin id="org.eclipse.jetty.servlet"/>
<plugin id="org.eclipse.equinox.bidi"/>
<plugin id="org.eclipse.equinox.p2.updatechecker"/>
<plugin id="org.eclipse.wb.runtime" version="1.7.0.r42x201405021445"/>
<plugin id="org.eclipse.rap.tools.launch.source"/>
<plugin id="org.eclipse.equinox.security.win32.x86_64.source"/>
<plugin id="org.eclipse.e4.ui.css.swt"/>
<plugin id="org.eclipse.zest.layouts.source"/>
<plugin id="org.eclipse.e4.ui.workbench.swt.source" version="0.10.2.v20121207-204447"/>
<plugin id="org.eclipse.draw2d.source"/>
<plugin id="org.eclipse.jst.ws.jaxws.utils"/>
<plugin id="org.eclipse.scout.rt.ui.swing.source"/>
<plugin id="org.eclipse.jetty.util"/>
<plugin id="org.apache.felix.gogo.shell"/>
<plugin id="org.eclipse.swt"/>
<plugin id="org.eclipse.jdt.compiler.apt.source"/>
<plugin id="org.eclipse.pde.api.tools"/>
<plugin id="org.eclipse.core.contenttype.source"/>
<plugin id="org.eclipse.jdt.apt.core.source"/>
<plugin id="org.eclipse.core.runtime"/>
<plugin id="org.eclipse.jdt.junit4.runtime.source"/>
<plugin id="org.eclipse.help.base.source"/>
<plugin id="org.eclipse.e4.ui.bindings.source" version="0.10.3.v20130123-162658"/>
<plugin id="org.eclipse.jdt.junit.runtime.source"/>
<plugin id="org.eclipse.wb.core.lib" version="1.6.1.r42x201401161243"/>
<plugin id="org.eclipse.scout.commons"/>
<plugin id="org.eclipse.wst.command.env.ui"/>
<plugin id="org.apache.xml.resolver"/>
<plugin id="org.eclipse.ltk.ui.refactoring"/>
<plugin id="org.eclipse.equinox.common"/>
<plugin id="org.eclipse.equinox.event"/>
<plugin id="org.eclipse.mylyn.commons.team"/>
<plugin id="org.eclipse.equinox.util"/>
<plugin id="org.eclipse.wb.xwt" version="1.6.1.r42x201401161343"/>
<plugin id="org.eclipse.scout.rt.ui.svg.calendar.source"/>
<plugin id="org.eclipse.wb.rcp.doc.user" version="1.7.0.r42x201405030426"/>
<plugin id="org.eclipse.jdt.apt.pluggable.core"/>
<plugin id="org.eclipse.ui.views.log"/>
<plugin id="org.eclipse.wst.common.snippets"/>
<plugin id="org.eclipse.mylyn.monitor.ui"/>
<plugin id="org.eclipse.jetty.util.source"/>
<plugin id="org.eclipse.mylyn.context.tasks.ui"/>
<plugin id="org.eclipse.equinox.p2.touchpoint.eclipse"/>
<plugin id="org.eclipse.equinox.p2.metadata"/>
<plugin id="org.eclipse.libra.facet"/>
<plugin id="org.eclipse.core.externaltools"/>
<plugin id="org.polarion.eclipse.team.svn.connector.svnkit16.sources"/>
<plugin id="org.apache.commons.httpclient"/>
<plugin id="org.apache.commons.discovery"/>
<plugin id="org.eclipse.wst.web"/>
<plugin id="org.eclipse.jst.ws.jaxws.dom.ui"/>
<plugin id="org.eclipse.libra.framework.knopflerfish.ui"/>
<plugin id="org.eclipse.e4.ui.di"/>
<plugin id="org.eclipse.ui.externaltools"/>
<plugin id="org.apache.felix.gogo.command"/>
<plugin id="org.eclipse.wst.jsdt.ui"/>
<plugin id="org.eclipse.equinox.p2.directorywatcher.source"/>
<plugin id="org.eclipse.jdt.junit.source"/>
<plugin id="org.eclipse.equinox.p2.ui.discovery"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.source"/>
<plugin id="org.eclipse.emf.ecore.xmi"/>
<plugin id="org.eclipse.wst.common.core"/>
<plugin id="javax.activation"/>
<plugin id="org.eclipse.ui.forms"/>
<plugin id="org.eclipse.equinox.p2.extensionlocation"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.httpclient.source"/>
<plugin id="org.eclipse.jdt.debug"/>
<plugin id="org.eclipse.scout.rt.shared.legacy.texts.fragment.source"/>
<plugin id="org.eclipse.pde.ua.ui.source"/>
<plugin id="org.eclipse.jem.util"/>
<plugin id="org.eclipse.ui.intro.universal"/>
<plugin id="org.eclipse.jface.databinding.source"/>
<plugin id="org.eclipse.jdt.source"/>
<plugin id="org.eclipse.equinox.frameworkadmin.equinox.source"/>
<plugin id="org.eclipse.jface.source" version="3.8.101.v20121026-132746"/>
<plugin id="org.eclipse.equinox.p2.discovery"/>
<plugin id="org.eclipse.ui.ide.application"/>
<plugin id="org.eclipse.wb.rcp.databinding.xwt" version="1.7.0.r42x201405021548"/>
<plugin id="org.eclipse.rap.tools.intro.source"/>
<plugin id="org.eclipse.equinox.p2.director.source"/>
<plugin id="org.apache.xml.serializer"/>
<plugin id="com.bsiag.scout.rt.server.jdbc.oracle11g2"/>
<plugin id="org.eclipse.scout.rt.shared.source"/>
<plugin id="org.eclipse.jdt.apt.ui"/>
<plugin id="org.eclipse.equinox.p2.touchpoint.natives"/>
<plugin id="org.eclipse.wb.runtime" version="1.6.1.r42x201401161243"/>
<plugin id="org.eclipse.e4.ui.workbench.renderers.swt"/>
<plugin id="org.eclipse.rap.tools.templates"/>
<plugin id="org.eclipse.wb.swing.MigLayout" version="1.7.0.r42x201405021531"/>
<plugin id="org.eclipse.jem.proxy"/>
<plugin id="org.apache.commons.codec.source"/>
<plugin id="osgi.enterprise"/>
<plugin id="org.eclipse.equinox.p2.console"/>
<plugin id="org.eclipse.ui.console.source"/>
<plugin id="org.eclipse.wst.common.frameworks.ui"/>
<plugin id="org.eclipse.equinox.p2.core"/>
<plugin id="org.w3c.dom.svg"/>
<plugin id="org.apache.batik.transcoder"/>
<plugin id="org.eclipse.pde.launching.source"/>
<plugin id="org.apache.log4j"/>
<plugin id="org.apache.xerces"/>
<plugin id="org.apache.commons.codec" version="1.8.0"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v36.fragment"/>
<plugin id="org.eclipse.jdt.apt.pluggable.core.source"/>
<plugin id="org.eclipse.equinox.frameworkadmin"/>
<plugin id="org.eclipse.equinox.p2.artifact.repository"/>
<plugin id="org.eclipse.ecf"/>
<plugin id="javax.servlet.jsp.source"/>
<plugin id="org.eclipse.wst.command.env.doc.user"/>
<plugin id="org.apache.jasper.glassfish"/>
<plugin id="org.eclipse.equinox.simpleconfigurator.source"/>
<plugin id="org.eclipse.equinox.console.source"/>
<plugin id="org.eclipse.equinox.http.servlet.source"/>
<plugin id="org.eclipse.emf.ecore.edit"/>
<plugin id="org.eclipse.emf"/>
<plugin id="org.eclipse.equinox.p2.transport.ecf"/>
<plugin id="org.eclipse.scout.service"/>
<plugin id="org.eclipse.jdt.core.source"/>
<plugin id="org.eclipse.wb.rcp" version="1.7.0.r42x201405021526"/>
<plugin id="org.eclipse.mylyn.wikitext.mediawiki.core"/>
<plugin id="org.eclipse.rap.doc"/>
<plugin id="org.eclipse.equinox.util.source"/>
<plugin id="org.eclipse.core.databinding.source"/>
<plugin id="org.eclipse.equinox.console"/>
<plugin id="org.eclipse.equinox.p2.ql"/>
<plugin id="org.apache.batik.xml"/>
<plugin id="org.eclipse.scout.sdk.compatibility.v37v41.fragment"/>
<plugin id="org.eclipse.libra.framework.ui"/>
<plugin id="org.eclipse.epp.mpc.ui"/>
<plugin id="org.eclipse.ltk.ui.refactoring.source"/>
<plugin id="javax.servlet.jsp"/>
<plugin id="org.eclipse.core.filebuffers"/>
<plugin id="org.eclipse.team.cvs.ui.source"/>
<plugin id="org.eclipse.mylyn.tasks.bugs"/>
<plugin id="org.eclipse.ui.browser.source"/>
<plugin id="org.eclipse.jst.jsf.doc.user"/>
<plugin id="org.eclipse.equinox.p2.garbagecollector"/>
<plugin id="org.eclipse.team.svn.help"/>
<plugin id="org.eclipse.jdt.debug.ui.source"/>
<plugin id="org.eclipse.mylyn.commons.repositories.ui"/>
<plugin id="org.eclipse.e4.ui.workbench.swt"/>
<plugin id="org.eclipse.ecf.provider.filetransfer.ssl.source"/>
<plugin id="org.eclipse.core.commands"/>
<plugin id="org.eclipse.equinox.p2.repository.source"/>
<plugin id="org.eclipse.team.svn.revision.graph"/>
<plugin id="org.eclipse.wst.jsdt.web.ui"/>
<plugin id="org.eclipse.ui.net.source"/>
<plugin id="org.eclipse.wst.common.project.facet.core"/>
<plugin id="org.eclipse.wb.rcp.doc.user" version="1.6.1.r42x201401180426"/>
<plugin id="org.apache.felix.gogo.shell.source"/>
<plugin id="org.eclipse.pde.doc.user"/>
<plugin id="org.eclipse.scout.svg.ui.swing.source"/>
<plugin id="org.eclipse.ui.trace.source"/>
<plugin id="org.eclipse.wst.common.frameworks"/>
<plugin id="org.eclipse.ecf.ssl.source"/>
<plugin id="org.eclipse.help.source"/>
<plugin id="org.eclipse.ant.core"/>
<plugin id="org.eclipse.wb.layout.group" version="1.6.1.r42x201401161311"/>
<plugin id="org.eclipse.core.databinding.beans"/>
<plugin id="org.eclipse.help.ui.source"/>
<plugin id="org.eclipse.jdt.junit.runtime"/>
<plugin id="org.eclipse.team.svn"/>
<plugin id="org.eclipse.ant.ui.source"/>
<plugin id="org.junit.source" version="4.10.0.v4_10_0_v20120426-0900"/>
<plugin id="org.eclipse.wb.swt" version="1.7.0.r42x201405021519"/>
<plugin id="org.eclipse.scout.rt.feature.about.source"/>
<plugin id="org.eclipse.cvs.source"/>
<plugin id="org.eclipse.equinox.simpleconfigurator.manipulator.source"/>
<plugin id="org.eclipse.wst.jsdt.manipulation"/>
<plugin id="org.eclipse.core.databinding.observable"/>
<plugin id="org.eclipse.wst.xsdeditor.doc.user"/>
<plugin id="org.eclipse.e4.core.contexts"/>
<plugin id="org.eclipse.jdt.junit4.runtime"/>
<plugin id="org.eclipse.equinox.ds"/>
<plugin id="org.apache.commons.lang"/>
<plugin id="org.eclipse.gef.examples.text.source"/>
<plugin id="org.eclipse.wb.swing.MigLayout.lib" version="1.7.0.r42x201405021531"/>
<plugin id="org.eclipse.e4.ui.services"/>
<plugin id="org.eclipse.core.net.win32.x86_64"/>
<plugin id="org.eclipse.equinox.p2.console.source"/>
<plugin id="org.eclipse.epp.mpc.help.ui"/>
<plugin id="org.eclipse.wst.ws.ui"/>
<plugin id="org.eclipse.wb.layout.group" version="1.7.0.r42x201405021517"/>
<plugin id="org.eclipse.pde.visualization"/>
<plugin id="org.eclipse.scout.rt.server"/>
<plugin id="org.eclipse.equinox.p2.metadata.source"/>
<plugin id="org.eclipse.equinox.p2.engine.source"/>
<plugin id="org.eclipse.scout.rt.shared"/>
<plugin id="org.eclipse.pde.ua.core.source"/>
</includeBundles>
<launcherArgs>
<vmArgs>-Xms256m -Xmx512m -XX:MaxPermSize=256m</vmArgs>
</launcherArgs>
</target>
Re: FileChooser in RAP [message #1354151 is a reply to message #1349656] Wed, 14 May 2014 02:06 Go to previous messageGo to next message
Urs Beeli is currently offline Urs Beeli
Messages: 322
Registered: October 2012
Location: Bern, Switzerland
Senior Member
Have you tried opening your product file and clicking on the "validate" button (the one looking like a page with a check mark near the upper right corner)?
index.php/fa/18084/0/

In my experience, if an application complains about missing bundles at startup, these are missing from the product (having them in the target is a pre-requisite for adding them to the product). If "validate" tells you that there are missing bundles, switch to the "Dependencies" tab and add the missing plugins to your product (you might need a few iterations of validate and adding dependencies; or you can just click on "add required plugins", thought that is usually a bit over-enthusiastic in what it adds).

Once "validate" tells you that "No problems are detected" you can change back to the "Overview" tab, click on "Synchronsie" and then launch your product from within the product file (this will overwrite any run configurations that might have been stored for this product).
  • Attachment: validate.png
    (Size: 3.66KB, Downloaded 91 times)
Re: FileChooser in RAP [message #1354486 is a reply to message #1354151] Wed, 14 May 2014 05:24 Go to previous messageGo to next message
marco giudici is currently offline marco giudici
Messages: 121
Registered: February 2013
Senior Member
Hi Urs,
I validate the RAP product and give me the following missing dependencies

index.php/fa/18085/0/

I click on the button "Add Required Plug-Ins" and after that I do again a validation but give me the same result.

Any other suggestions?
Re: FileChooser in RAP [message #1366475 is a reply to message #1354486] Mon, 19 May 2014 06:25 Go to previous message
Ken Lee is currently offline Ken Lee
Messages: 97
Registered: March 2012
Member
Hi Marco,

Before I have a deeper look into your problem, can you please confirm first that you're using a plain installation of Eclipse Scout Juno SR2 [1]? Have you made any changes to your Eclipse installation by using the "Install New Software..." menu?

The ScoutRAP.target initially includes all the bundles that are located in your local Eclipse Scout installation directory which are included with

<location path="${eclipse_home}\" type="Directory"/>
<location path="${eclipse_home}\rap_target" type="Directory"/>


All Scout bundles for SWT/Swing and also for RAP (second entry) are set for the target platform.

Since the Scout RAP Filechooser is not included in the Eclipse package (because the RAP fileupload widget is still in incubation phase), you need to include the P2 update site for this widget directly. So your ScoutRAP.target file should look like

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde version="3.8"?><target name="ScoutRAP" sequenceNumber="1">
<locations>
<location path="${eclipse_home}\" type="Directory"/>
<location path="${eclipse_home}\rap_target" type="Directory"/>

<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.rap.incubator.supplemental.fileupload.feature.feature.group" version="1.5.0.20120220-1720"/>
<repository location="http://download.eclipse.org/rt/rap/1.5/incubator"/>
</location>

<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.scout.rt.ui.rap.incubator.filechooser.feature.feature.group" version="3.8.2.201302111336"/>
<repository location="http://download.eclipse.org/scout/releases/3.8"/>
</location>

</locations>
<launcherArgs>
<vmArgs>-Xms256m -Xmx512m -XX:MaxPermSize=256m</vmArgs>
</launcherArgs>
</target>


If you use the Scout SDK checkbox "RAP FileChooser Support (Incubation)", these P2 update sites will automatically be included.

In your *.product files, you need to add the bundles

<plugin id="org.apache.commons.fileupload"/>
<plugin id="org.apache.commons.io"/>
<plugin id="org.eclipse.rap.rwt.supplemental.filedialog"/>
<plugin id="org.eclipse.rap.rwt.supplemental.fileupload"/>
<plugin id="org.eclipse.scout.rt.ui.rap.incubator.filechooser"/>


(this step is also done automatically if you install the FileChooser via Scout SDK.

Now, to your actual problem:

AbstractFileChooserField contains a configuration method

protected boolean getConfiguredTypeLoad() {
  return false;  
}


that returns false by default. Depending on this configuration, a different field will be created in RAP (see FileChooserFieldFactory [2]).

What you probably want is to have the RwtScoutFileUploadField which allows you to upload files from your client to the Scout RAP server. Therefore, you need to override the method type load:

    public class MyFileUploadField extends AbstractFileChooserField {

      @Override
      protected String getConfiguredLabel() {
        return TEXTS.get("MyFileUpload");
      }

      @Override
      protected boolean getConfiguredTypeLoad() {
        return true;
      }
    }


Does that solve your problem?

[1] https://www.eclipse.org/downloads/packages/eclipse-scout-developers/junosr2
[2] https://dev.eclipse.org/svnroot/technology/org.eclipse.scout/scout.rt.incubator/branches/3.8/org.eclipse.scout.rt.ui.rap.incubator.filechooser/src/org/eclipse/scout/rt/ui/rap/form/fields/filechooserfield/FileChooserFieldFactory.java

[Updated on: Mon, 19 May 2014 06:27]

Report message to a moderator

Previous Topic:LinkageError in Scout
Next Topic:Logback config
Goto Forum:
  


Current Time: Fri Aug 22 19:43:56 EDT 2014

Powered by FUDForum. Page generated in 0.02712 seconds