Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Recurrent OutOfMemoryError during Eclipse publish operation to server
Recurrent OutOfMemoryError during Eclipse publish operation to server [message #226716] Thu, 15 January 2009 10:43 Go to next message
Barbara McInnes is currently offline Barbara McInnes
Messages: 3
Registered: July 2009
Junior Member
Hi,

I've created a test server using my Tomcat installation and
provide these VM args in my launch configuration -Xms512m -Xmx768m
-XX:PermSize=256m -XX:MaxPermSize=256m. Whenever I publish a web project
to it I get the following error:

!ENTRY org.eclipse.core.jobs 4 2 2008-12-17 14:32:52.110
!MESSAGE An internal error occurred during: "Publishing to Tomcat v6.0
Server at localhost...".
!STACK 0
java.lang.OutOfMemoryError: Requested array size exceeds VM limit
at
org.eclipse.wst.server.core.internal.ModulePublishInfo.loadR esource(ModulePublishInfo.java:189)
at
org.eclipse.wst.server.core.internal.ModulePublishInfo.load( ModulePublishInfo.java:184)
at
org.eclipse.wst.server.core.internal.ModulePublishInfo.<init >(ModulePublishInfo.java:84)
at
org.eclipse.wst.server.core.internal.ServerPublishInfo.load( ServerPublishInfo.java:274)
at
org.eclipse.wst.server.core.internal.ServerPublishInfo.<init >(ServerPublishInfo.java:56)
at
org.eclipse.wst.server.core.internal.PublishInfo.getServerPu blishInfo(PublishInfo.java:75)
at
org.eclipse.wst.server.core.internal.Server.getServerPublish Info(Server.java:843)
at org.eclipse.wst.server.core.internal.Server.doPublish(Server .java:886)
at org.eclipse.wst.server.core.internal.Server.publish(Server.j ava:874)
at
org.eclipse.wst.server.core.internal.PublishServerJob.run(Pu blishServerJob.java:72)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

This does *not* happen the first few times I run a project after creating
the server, but pops up after a small number of server/eclipse
start/stops. Once it starts, it will not go away until I delete the server
and re-create it. Restarting my desktop or eclipse has not effect - the
error still comes immediately I try to start the server again.

I can continue to recreate my server on a regular basis, but it is a pain
and I'd really really like to know how I can fix it. I've looked for
other threads on the topic and any I've found have resorted to the delete
/ recreate approach.

I'm using Tomcat 6.0.18, Eclipse 3.3.2 and JDK 1.5.0_14 on Windows XP
Professional 2002 SP 3 with 2GB memory.

Any help gratefully appreciated,

Barbara
Re: Recurrent OutOfMemoryError during Eclipse publish operation to server [message #226724 is a reply to message #226716] Thu, 15 January 2009 14:18 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1309
Registered: July 2009
Senior Member
This appears to be https://bugs.eclipse.org/bugs/show_bug.cgi?id=212075.
Upgrading to WTP 2.0.3, or a current Eclipse 3.4.x/WTP 3.0.x should
fix this.

Cheers,
Larry


Barbara McInnes wrote:
> Hi,
> I've created a test server using my Tomcat installation and provide
> these VM args in my launch configuration -Xms512m -Xmx768m
> -XX:PermSize=256m -XX:MaxPermSize=256m. Whenever I publish a web
> project to it I get the following error:
> !ENTRY org.eclipse.core.jobs 4 2 2008-12-17 14:32:52.110 !MESSAGE An
> internal error occurred during: "Publishing to Tomcat v6.0 Server at
> localhost...". !STACK 0 java.lang.OutOfMemoryError: Requested array size
> exceeds VM limit at
> org.eclipse.wst.server.core.internal.ModulePublishInfo.loadR esource(ModulePublishInfo.java:189)
> at
> org.eclipse.wst.server.core.internal.ModulePublishInfo.load( ModulePublishInfo.java:184)
> at
> org.eclipse.wst.server.core.internal.ModulePublishInfo.<init >(ModulePublishInfo.java:84)
> at
> org.eclipse.wst.server.core.internal.ServerPublishInfo.load( ServerPublishInfo.java:274)
> at
> org.eclipse.wst.server.core.internal.ServerPublishInfo.<init >(ServerPublishInfo.java:56)
> at
> org.eclipse.wst.server.core.internal.PublishInfo.getServerPu blishInfo(PublishInfo.java:75)
> at
> org.eclipse.wst.server.core.internal.Server.getServerPublish Info(Server.java:843)
> at
> org.eclipse.wst.server.core.internal.Server.doPublish(Server .java:886)
> at org.eclipse.wst.server.core.internal.Server.publish(Server.j ava:874)
> at
> org.eclipse.wst.server.core.internal.PublishServerJob.run(Pu blishServerJob.java:72)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
> This does *not* happen the first few times I run a project after
> creating the server, but pops up after a small number of server/eclipse
> start/stops. Once it starts, it will not go away until I delete the
> server and re-create it. Restarting my desktop or eclipse has not
> effect - the error still comes immediately I try to start the server again.
>
> I can continue to recreate my server on a regular basis, but it is a
> pain and I'd really really like to know how I can fix it. I've looked
> for other threads on the topic and any I've found have resorted to the
> delete / recreate approach.
> I'm using Tomcat 6.0.18, Eclipse 3.3.2 and JDK 1.5.0_14 on Windows XP
> Professional 2002 SP 3 with 2GB memory.
> Any help gratefully appreciated,
> Barbara
>
>
Re: Recurrent OutOfMemoryError during Eclipse publish operation to server [message #227406 is a reply to message #226724] Wed, 28 January 2009 09:50 Go to previous messageGo to next message
Barbara McInnes is currently offline Barbara McInnes
Messages: 3
Registered: July 2009
Junior Member
Hi again, Thanks for the reply. I tried upgrading WTP to 2.0.3 and
thought it had solved the issue, but sadly it hasn't! I'll just have to
try upgrading altogether at some point. Thanks again.
Re: Recurrent OutOfMemoryError during Eclipse publish operation to server [message #227418 is a reply to message #227406] Wed, 28 January 2009 16:23 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1309
Registered: July 2009
Senior Member
Barbara McInnes wrote:
> Hi again, Thanks for the reply. I tried upgrading WTP to 2.0.3 and
> thought it had solved the issue, but sadly it hasn't! I'll just have to
> try upgrading altogether at some point. Thanks again.
>

Out of curiosity, how big are the ".dat" file(s) in the
"<workspace>/.metadata/.plugins/org.eclipse.wst.server.core/publish " folder?

Cheers,
Larry
Re: Recurrent OutOfMemoryError during Eclipse publish operation to server [message #227461 is a reply to message #227418] Thu, 29 January 2009 19:31 Go to previous messageGo to next message
Nadeem Aboobaker is currently offline Nadeem Aboobaker
Messages: 20
Registered: July 2009
Junior Member
Larry Isaacs wrote:

> Barbara McInnes wrote:
>> Hi again, Thanks for the reply. I tried upgrading WTP to 2.0.3 and
>> thought it had solved the issue, but sadly it hasn't! I'll just have to
>> try upgrading altogether at some point. Thanks again.
>>

> Out of curiosity, how big are the ".dat" file(s) in the
> "<workspace>/.metadata/.plugins/org.eclipse.wst.server.core/publish " folder?

> Cheers,
> Larry


We're running into the same problem on Eclipse 3.3.2 with WTP 2.0.
Upgrading to WTP 2.0.3 did not solve the problem. Is there any other
solution on Eclipse 3.3.2 that we can try? Re-creating the server every
time can be annoying, and upgrading to Eclipse 3.4 and WTP 3.0.x is not an
option. Also, I didn't see this bug specifically listed on the notes for
WTP 2.0.3.

Thanks,
Nadeem
Re: Recurrent OutOfMemoryError during Eclipse publish operation to server [message #227488 is a reply to message #227461] Fri, 30 January 2009 14:18 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1309
Registered: July 2009
Senior Member
Nadeem wrote:
> Larry Isaacs wrote:
>
>> Barbara McInnes wrote:
>>> Hi again, Thanks for the reply. I tried upgrading WTP to 2.0.3 and
>>> thought it had solved the issue, but sadly it hasn't! I'll just have
>>> to try upgrading altogether at some point. Thanks again.
>>>
>
>> Out of curiosity, how big are the ".dat" file(s) in the
>> "<workspace>/.metadata/.plugins/org.eclipse.wst.server.core/publish "
>> folder?
>
>> Cheers,
>> Larry
>
>
> We're running into the same problem on Eclipse 3.3.2 with WTP 2.0.
> Upgrading to WTP 2.0.3 did not solve the problem. Is there any other
> solution on Eclipse 3.3.2 that we can try? Re-creating the server every
> time can be annoying, and upgrading to Eclipse 3.4 and WTP 3.0.x is not
> an option. Also, I didn't see this bug specifically listed on the notes
> for WTP 2.0.3.
>
> Thanks,
> Nadeem
>

My comment about WTP 2.0.3 was based on CVS code tags. This bug was
intended to be fixed in 2.0.3. However, inspection of my WTP 2.0.3,
obtained from downloaded zip, shows the same org.eclipse.wst.server.core
plug-in as WTP 2.0.2 (i.e.
org.eclipse.wst.server.core_1.0.206.v20080108b.jar). So it appears this
bug fix missed actually getting into WTP 2.0.3. If you have or can add
the WST SDK 2.0.3 to your current or a separate Eclipse 3.3.x, this bug
is easy to patch (i.e. there are a number of steps, but each is simple
and straightforward).

Cheers,
Larry
Previous Topic:axiom - correct loaction for jars?
Next Topic:Using the Web Page Editor with my own tags.
Goto Forum:
  


Current Time: Thu Oct 23 11:03:18 GMT 2014

Powered by FUDForum. Page generated in 0.02662 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software