Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » [JPT] Recent history of org.eclipse.jpt.feature
[JPT] Recent history of org.eclipse.jpt.feature [message #226618] Wed, 14 January 2009 15:26 Go to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

In trying to debug a feature installation problem, I think I've found
the root cause but it confuses me.
We've been developing our plugins against a target platform that is
essentially the Ganymede 3.4.1 JEE package. In that distro, I have the
feature org.eclipse.jpt.feature, version 2.0.102.
However, it appears that this version of JPT is not available on the
Ganymede update site; currently it only includes
org.eclipse.jpt.feature_2.0.101.v200809030200-793DuCYQCD4D2D UEKHL

2.0.102 is, however, included in the WTP update site.

Was the 2.0.102 release of org.eclipse.jpt.feature supposed to be in
Ganymede 3.4.1? If so, is it a bug that it is not included in the
Ganymede update site?

Eric
Re: [JPT] Recent history of org.eclipse.jpt.feature [message #226624 is a reply to message #226618] Wed, 14 January 2009 15:40 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

It looks like the same question arises about wst: my Ganymede 3.4.1 has
WST 3.0.3 but the Ganymede update site only includes 3.0.2


On 1/14/2009 10:26 AM, Eric Rizzo wrote:
> In trying to debug a feature installation problem, I think I've found
> the root cause but it confuses me.
> We've been developing our plugins against a target platform that is
> essentially the Ganymede 3.4.1 JEE package. In that distro, I have the
> feature org.eclipse.jpt.feature, version 2.0.102.
> However, it appears that this version of JPT is not available on the
> Ganymede update site; currently it only includes
> org.eclipse.jpt.feature_2.0.101.v200809030200-793DuCYQCD4D2D UEKHL
>
> 2.0.102 is, however, included in the WTP update site.
>
> Was the 2.0.102 release of org.eclipse.jpt.feature supposed to be in
> Ganymede 3.4.1? If so, is it a bug that it is not included in the
> Ganymede update site?
>
> Eric
Re: [JPT] Recent history of org.eclipse.jpt.feature [message #226674 is a reply to message #226618] Wed, 14 January 2009 17:43 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dcarver.starstandard.org

Is there a particular reason you are including such a specific version
dependency? I would think specifying a minimum version of for the
feature of 2.0 would be enough.

Dave

Eric Rizzo wrote:
> In trying to debug a feature installation problem, I think I've found
> the root cause but it confuses me.
> We've been developing our plugins against a target platform that is
> essentially the Ganymede 3.4.1 JEE package. In that distro, I have the
> feature org.eclipse.jpt.feature, version 2.0.102.
> However, it appears that this version of JPT is not available on the
> Ganymede update site; currently it only includes
> org.eclipse.jpt.feature_2.0.101.v200809030200-793DuCYQCD4D2D UEKHL
>
> 2.0.102 is, however, included in the WTP update site.
>
> Was the 2.0.102 release of org.eclipse.jpt.feature supposed to be in
> Ganymede 3.4.1? If so, is it a bug that it is not included in the
> Ganymede update site?
>
> Eric
Re: [JPT] Recent history of org.eclipse.jpt.feature [message #226702 is a reply to message #226674] Wed, 14 January 2009 22:53 Go to previous message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

On 1/14/2009 12:43 PM, David Carver wrote:
> Is there a particular reason you are including such a specific version
> dependency? I would think specifying a minimum version of for the
> feature of 2.0 would be enough.

I am dealing with a bunch of plugins, some of which I was not intimately
involved in the development of, and which sometimes have very specific
version requirements specified in their manifests.
I've relaxed the version number and match rule for org.eclipse.jpt in
the feature and it seems to get past that (although now there are other
conflicting dependencies p2 is reporting that keep me from actually
installing and testing).



> Eric Rizzo wrote:
>> In trying to debug a feature installation problem, I think I've found
>> the root cause but it confuses me.
>> We've been developing our plugins against a target platform that is
>> essentially the Ganymede 3.4.1 JEE package. In that distro, I have the
>> feature org.eclipse.jpt.feature, version 2.0.102.
>> However, it appears that this version of JPT is not available on the
>> Ganymede update site; currently it only includes
>> org.eclipse.jpt.feature_2.0.101.v200809030200-793DuCYQCD4D2D UEKHL
>>
>> 2.0.102 is, however, included in the WTP update site.
>>
>> Was the 2.0.102 release of org.eclipse.jpt.feature supposed to be in
>> Ganymede 3.4.1? If so, is it a bug that it is not included in the
>> Ganymede update site?
>>
>> Eric
Previous Topic:double return integer
Next Topic:Re: Bug life cycle ?
Goto Forum:
  


Current Time: Sun Dec 21 13:36:49 GMT 2014

Powered by FUDForum. Page generated in 0.01734 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software