Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » JBoss 5 Startup from Eclipse Ganymede
JBoss 5 Startup from Eclipse Ganymede [message #226100] Wed, 07 January 2009 01:01 Go to next message
Eclipse User
Originally posted by: anf4.cornell.edu

I'm having some trouble starting up JBoss 5 from Eclipse. I am able to startup
JBoss from the command line without a problem:

C:\Program Files\jboss-5.0.0.GA\bin>run.bat
============================================================ ===================

JBoss Bootstrap Environment

JBOSS_HOME: C:\Program Files\jboss-5.0.0.GA

JAVA: C:\Program Files\Java\jdk1.5.0_17\bin\java

JAVA_OPTS: -Dprogram.name=run.bat -server -Xms128m -Xmx512m -XX:MaxPermSize=256m
-Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3
600000 -Dsun.rmi.dgc.server.gcInterval=3600000

CLASSPATH: C:\Program Files\jboss-5.0.0.GA\bin\run.jar

============================================================ ===================

19:53:51,000 INFO [ServerImpl] Starting JBoss (Microcontainer)...
19:53:51,125 INFO [ServerImpl] Release ID: JBoss [Morpheus] 5.0.0.GA (build:
SVNTag=JBoss_5_0_0_GA date=200812041714)
19:53:51,125 INFO [ServerImpl] Bootstrap URL: null
19:53:51,125 INFO [ServerImpl] Home Dir: C:\Program Files\jboss-5.0.0.GA
19:53:51,125 INFO [ServerImpl] Home URL: file:/C:/Program%20Files/jboss-5.0.0.GA/
19:53:51,125 INFO [ServerImpl] Library URL: file:/C:/Program%20Files/jboss-5.0.0.GA/lib/
19:53:51,125 INFO [ServerImpl] Patch URL: null
19:53:51,140 INFO [ServerImpl] Common Base URL: file:/C:/Program%20Files/jboss-5.0.0.GA/common/
19:53:51,140 INFO [ServerImpl] Common Library URL: file:/C:/Program%20Files/jboss-5.0.0.GA/common/lib/
19:53:51,140 INFO [ServerImpl] Server Name: default
19:53:51,140 INFO [ServerImpl] Server Base Dir: C:\Program Files\jboss-5.0.0.GA\server
19:53:51,140 INFO [ServerImpl] Server Base URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/
19:53:51,140 INFO [ServerImpl] Server Config URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/default/conf/
19:53:51,140 INFO [ServerImpl] Server Home Dir: C:\Program Files\jboss-5.0.0.GA\server\default
19:53:51,140 INFO [ServerImpl] Server Home URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/default/
19:53:51,140 INFO [ServerImpl] Server Data Dir: C:\Program Files\jboss-5.0.0.GA\server\default\data
19:53:51,140 INFO [ServerImpl] Server Library URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/default/lib/
19:53:51,140 INFO [ServerImpl] Server Log Dir: C:\Program Files\jboss-5.0.0.GA\server\default\log
19:53:51,140 INFO [ServerImpl] Server Native Dir: C:\Program Files\jboss-5.0.0.GA\server\default\tmp\native
19:53:51,140 INFO [ServerImpl] Server Temp Dir: C:\Program Files\jboss-5.0.0.GA\server\default\tmp
19:53:51,140 INFO [ServerImpl] Server Temp Deploy Dir: C:\Program Files\jboss-5.0.0.GA\server\default\tmp\deploy
19:53:52,390 INFO [ServerImpl] Starting Microcontainer, bootstrapURL=file:/C:/Program%20Files/jboss-5.0.0.GA/server/ default/conf/bootstrap.xml
19:53:53,406 INFO [VFSCacheFactory] Initializing VFSCache [org.jboss.virtual.plugins.cache.IterableTimedVFSCache]
19:53:53,421 INFO [VFSCacheFactory] Using VFSCache [IterableTimedVFSCache{lifetime=1800,
resolution=60}]
19:53:54,312 INFO [CopyMechanism] VFS temp dir: C:\Program Files\jboss-5.0.0.GA\server\default\tmp
19:53:54,328 INFO [ZipEntryContext] VFS force nested jars copy-mode is enabled.
19:53:56,531 INFO [ServerInfo] Java version: 1.5.0_17,Sun Microsystems Inc.
19:53:56,546 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_17-b04,Sun
Microsystems Inc.
19:53:56,546 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
19:53:56,593 INFO [JMXKernel] Legacy JMX core initialized
19:54:00,625 INFO [ProfileServiceImpl] Loading profile: default from: org.jboss.system.server.profileservice.repository.Serializab leDeploymentRepository @7d2796(root=C:\Program
Files\jboss-5.0.0.GA\server, key=org.jboss.profileservice.spi.ProfileKey@143b82c3[domain=default,server=default,name=default])
19:54:00,625 INFO [ProfileImpl] Using repository: org.jboss.system.server.profileservice.repository.Serializab leDeploymentRepository @7d2796(root=C:\Program
Files\jboss-5.0.0.GA\server, key=org.jboss.profileservice.spi.ProfileKey@143b82c3[domain=default,server=default,name=default])
19:54:00,625 INFO [ProfileServiceImpl] Loaded profile: ProfileImpl@ee558f{key=org.jboss.profileservice.spi.ProfileKey@143b82c3[domain=default,server=default,name=default]}
19:54:06,328 INFO [WebService] Using RMI server codebase: http://127.0.0.1:8083/
19:54:17,015 INFO [NativeServerConfig] JBoss Web Services - Stack Native
Core
19:54:17,015 INFO [NativeServerConfig] 3.0.4.SP1
19:54:49,031 INFO [JMXConnectorServerService] JMX Connector server: service:jmx:rmi://127.0.0.1/jndi/rmi://127.0.0.1:1090/jmxcon nector
19:54:49,421 INFO [MailService] Mail Service bound to java:/Mail
19:54:51,953 WARN [JBossASSecurityMetadataStore] WARNING! POTENTIAL SECURITY
RISK. It has been detected that the MessageSucker component which sucks messages
from one node to another has not had its password changed from the installation
default. Please see the JBoss Messaging user guide for instructions on how
to do this.
19:54:52,000 WARN [AnnotationCreator] No ClassLoader provided, using TCCL:
org.jboss.managed.api.annotation.ManagementComponent
19:54:52,312 INFO [TransactionManagerService] JBossTS Transaction Service
(JTA version) - JBoss Inc.
19:54:52,312 INFO [TransactionManagerService] Setting up property manager
MBean and JMX layer
19:54:53,062 INFO [TransactionManagerService] Initializing recovery manager
19:54:53,312 INFO [TransactionManagerService] Recovery manager configured
19:54:53,312 INFO [TransactionManagerService] Binding TransactionManager
JNDI Reference
19:54:53,359 INFO [TransactionManagerService] Starting transaction recovery
manager
19:54:54,828 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-127.0.0.1-8080
19:54:54,828 INFO [AjpProtocol] Initializing Coyote AJP/1.3 on ajp-127.0.0.1-8009
19:54:54,843 INFO [StandardService] Starting service jboss.web
19:54:54,843 INFO [StandardEngine] Starting Servlet Engine: JBoss Web/2.1.1.GA
19:54:54,921 INFO [Catalina] Server startup in 471 ms
19:54:54,953 INFO [TomcatDeployment] deploy, ctxPath=/invoker, vfsUrl=http-invoker.sar/invoker.war
19:54:56,000 INFO [TomcatDeployment] deploy, ctxPath=/jbossws, vfsUrl=jbossws.sar/jbossws-management.war
19:54:56,562 INFO [TomcatDeployment] deploy, ctxPath=/web-console, vfsUrl=management/console-mgr.sar/web-console.war
19:54:57,281 INFO [RARDeployment] Required license terms exist, view vfszip:/C:/Program
Files/jboss-5.0.0.GA/server/default/deploy/jboss-local-jdbc. rar/META-INF/ra.xml
19:54:57,328 INFO [RARDeployment] Required license terms exist, view vfszip:/C:/Program
Files/jboss-5.0.0.GA/server/default/deploy/jboss-xa-jdbc.rar /META-INF/ra.xml
19:54:57,406 INFO [RARDeployment] Required license terms exist, view vfszip:/C:/Program
Files/jboss-5.0.0.GA/server/default/deploy/jms-ra.rar/META-I NF/ra.xml
19:54:57,453 INFO [RARDeployment] Required license terms exist, view vfszip:/C:/Program
Files/jboss-5.0.0.GA/server/default/deploy/mail-ra.rar/META- INF/ra.xml
19:54:57,531 INFO [RARDeployment] Required license terms exist, view vfszip:/C:/Program
Files/jboss-5.0.0.GA/server/default/deploy/quartz-ra.rar/MET A-INF/ra.xml
19:54:58,250 INFO [SimpleThreadPool] Job execution threads will use class
loader of thread: main
19:54:58,312 INFO [QuartzScheduler] Quartz Scheduler v.1.5.2 created.
19:54:58,312 INFO [RAMJobStore] RAMJobStore initialized.
19:54:58,312 INFO [StdSchedulerFactory] Quartz scheduler 'DefaultQuartzScheduler'
initialized from default resource file in Quartz package: 'quartz.properties'
19:54:58,312 INFO [StdSchedulerFactory] Quartz scheduler version: 1.5.2
19:54:58,312 INFO [QuartzScheduler] Scheduler DefaultQuartzScheduler_$_NON_CLUSTERED
started.
19:54:59,906 INFO [ConnectionFactoryBindingService] Bound ConnectionManager
'jboss.jca:service=DataSourceBinding,name=DefaultDS' to JNDI name 'java:DefaultDS'
19:55:00,562 WARN [QuartzTimerServiceFactory] sql failed: CREATE TABLE QRTZ_JOB_DETAILS(JOB_NAME
VARCHAR(80) NOT NULL, JOB_GROUP VARCHAR(80) NOT NULL, DESCRIPTION VARCHAR(120)
NULL, JOB_CLASS_NAME VARCHAR(128) NOT NULL, IS_DURABLE VARCHAR(1) NOT NULL,
IS_VOLATILE VARCHAR(1) NOT NULL, IS_STATEFUL VARCHAR(1) NOT NULL, REQUESTS_RECOVERY
VARCHAR(1) NOT NULL, JOB_DATA BINARY NULL, PRIMARY KEY (JOB_NAME,JOB_GROUP))
19:55:00,734 INFO [SimpleThreadPool] Job execution threads will use class
loader of thread: main
19:55:00,734 INFO [QuartzScheduler] Quartz Scheduler v.1.5.2 created.
19:55:00,734 INFO [JobStoreCMT] Using db table-based data access locking
(synchronization).
19:55:00,750 INFO [JobStoreCMT] Removed 0 Volatile Trigger(s).
19:55:00,750 INFO [JobStoreCMT] Removed 0 Volatile Job(s).
19:55:00,750 INFO [JobStoreCMT] JobStoreCMT initialized.
19:55:00,750 INFO [StdSchedulerFactory] Quartz scheduler 'JBossEJB3QuartzScheduler'
initialized from an externally provided properties instance.
19:55:00,750 INFO [StdSchedulerFactory] Quartz scheduler version: 1.5.2
19:55:00,750 INFO [JobStoreCMT] Freed 0 triggers from 'acquired' / 'blocked'
state.
19:55:00,765 INFO [JobStoreCMT] Recovering 0 jobs that were in-progress
at the time of the last shut-down.
19:55:00,765 INFO [JobStoreCMT] Recovery complete.
19:55:00,765 INFO [JobStoreCMT] Removed 0 'complete' triggers.
19:55:00,765 INFO [JobStoreCMT] Removed 0 stale fired job entries.
19:55:00,765 INFO [QuartzScheduler] Scheduler JBossEJB3QuartzScheduler_$_NON_CLUSTERED
started.
19:55:01,015 INFO [ServerPeer] JBoss Messaging 1.4.1.GA server [0] started
19:55:01,281 INFO [ConnectionFactory] Connector bisocket://127.0.0.1:4457
has leasing enabled, lease period 10000 milliseconds
19:55:01,281 INFO [ConnectionFactory] org.jboss.jms.server.connectionfactory.ConnectionFactory@6fe5d3
started
19:55:01,296 WARN [ConnectionFactoryJNDIMapper] supportsFailover attribute
is true on connection factory: jboss.messaging.connectionfactory:service=ClusteredConnectio nFactory
but post office is non clustered. So connection factory will *not* support
failover
19:55:01,296 WARN [ConnectionFactoryJNDIMapper] supportsLoadBalancing attribute
is true on connection factory: jboss.messaging.connectionfactory:service=ClusteredConnectio nFactory
but post office is non clustered. So connection factory will *not* support
load balancing
19:55:01,296 INFO [ConnectionFactory] Connector bisocket://127.0.0.1:4457
has leasing enabled, lease period 10000 milliseconds
19:55:01,296 INFO [ConnectionFactory] org.jboss.jms.server.connectionfactory.ConnectionFactory@d9278f
started
19:55:01,328 INFO [QueueService] Queue[/queue/ExpiryQueue] started, fullSize=200000,
pageSize=2000, downCacheSize=2000
19:55:01,328 INFO [ConnectionFactory] Connector bisocket://127.0.0.1:4457
has leasing enabled, lease period 10000 milliseconds
19:55:01,328 INFO [ConnectionFactory] org.jboss.jms.server.connectionfactory.ConnectionFactory@aad730
started
19:55:01,328 INFO [QueueService] Queue[/queue/DLQ] started, fullSize=200000,
pageSize=2000, downCacheSize=2000
19:55:02,390 INFO [ConnectionFactoryBindingService] Bound ConnectionManager
'jboss.jca:service=ConnectionFactoryBinding,name=JmsXA' to JNDI name 'java:JmsXA'
19:55:02,421 INFO [TomcatDeployment] deploy, ctxPath=/, vfsUrl=ROOT.war
19:55:02,609 INFO [TomcatDeployment] deploy, ctxPath=/jmx-console, vfsUrl=jmx-console.war
19:55:02,875 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-127.0.0.1-8080
19:55:02,921 INFO [AjpProtocol] Starting Coyote AJP/1.3 on ajp-127.0.0.1-8009
19:55:02,937 INFO [ServerImpl] JBoss (Microcontainer) [5.0.0.GA (build:
SVNTag=JBoss_5_0_0_GA date=200812041714)] Started in 1m:11s:781ms

Unfortunately, when I do the same from Eclipse, I get an error:

19:58:23,796 INFO [ServerImpl] Starting JBoss (Microcontainer)...
19:58:23,796 INFO [ServerImpl] Release ID: JBoss [Morpheus] 5.0.0.GA (build:
SVNTag=JBoss_5_0_0_GA date=200812041714)
19:58:23,796 INFO [ServerImpl] Bootstrap URL: null
19:58:23,796 INFO [ServerImpl] Home Dir: C:\Program Files\jboss-5.0.0.GA
19:58:23,796 INFO [ServerImpl] Home URL: file:/C:/Program%20Files/jboss-5.0.0.GA/
19:58:23,796 INFO [ServerImpl] Library URL: file:/C:/Program%20Files/jboss-5.0.0.GA/lib/
19:58:23,796 INFO [ServerImpl] Patch URL: null
19:58:23,796 INFO [ServerImpl] Common Base URL: file:/C:/Program%20Files/jboss-5.0.0.GA/common/
19:58:23,796 INFO [ServerImpl] Common Library URL: file:/C:/Program%20Files/jboss-5.0.0.GA/common/lib/
19:58:23,796 INFO [ServerImpl] Server Name: default
19:58:23,796 INFO [ServerImpl] Server Base Dir: C:\Program Files\jboss-5.0.0.GA\server
19:58:23,796 INFO [ServerImpl] Server Base URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/
19:58:23,796 INFO [ServerImpl] Server Config URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/default/conf/
19:58:23,796 INFO [ServerImpl] Server Home Dir: C:\Program Files\jboss-5.0.0.GA\server\default
19:58:23,796 INFO [ServerImpl] Server Home URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/default/
19:58:23,796 INFO [ServerImpl] Server Data Dir: C:\Program Files\jboss-5.0.0.GA\server\default\data
19:58:23,796 INFO [ServerImpl] Server Library URL: file:/C:/Program%20Files/jboss-5.0.0.GA/server/default/lib/
19:58:23,796 INFO [ServerImpl] Server Log Dir: C:\Program Files\jboss-5.0.0.GA\server\default\log
19:58:23,796 INFO [ServerImpl] Server Native Dir: C:\Program Files\jboss-5.0.0.GA\server\default\tmp\native
19:58:23,796 INFO [ServerImpl] Server Temp Dir: C:\Program Files\jboss-5.0.0.GA\server\default\tmp
19:58:23,812 INFO [ServerImpl] Server Temp Deploy Dir: C:\Program Files\jboss-5.0.0.GA\server\default\tmp\deploy
19:58:24,468 INFO [ServerImpl] Starting Microcontainer, bootstrapURL=file:/C:/Program%20Files/jboss-5.0.0.GA/server/ default/conf/bootstrap.xml
Failed to boot JBoss:
org.jboss.xb.binding.JBossXBException: Failed to parse source: file:/C:/Program%20Files/jboss-5.0.0.GA/server/default/conf/ bootstrap/vfs.xml@5,49
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJB ossXBParser.java:177)
at org.jboss.xb.binding.UnmarshallerImpl.unmarshal(Unmarshaller Impl.java:147)
at org.jboss.bootstrap.microcontainer.TempBasicXMLDeployer.depl oy(TempBasicXMLDeployer.java:150)
at org.jboss.bootstrap.microcontainer.ServerImpl.doStart(Server Impl.java:144)
at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerI mpl.java:394)
at org.jboss.Main.boot(Main.java:209)
at org.jboss.Main$1.run(Main.java:547)
at java.lang.Thread.run(Thread.java:595)
Caused by: java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlNsForm
at org.jboss.xb.builder.JBossXBNoSchemaBuilder.<init>(JBossXBNoSchemaBuilder.java:161)
at org.jboss.xb.builder.JBossXBBuilder.build(JBossXBBuilder.jav a:117)
at org.jboss.xb.binding.sunday.unmarshalling.DefaultSchemaResol ver.resolve(DefaultSchemaResolver.java:308)
at org.jboss.xb.binding.sunday.unmarshalling.SundayContentHandl er.startElement(SundayContentHandler.java:306)
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser$DelegatingC ontentHandler.startElement(SaxJBossXBParser.java:401)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser .startElement(AbstractSAXParser.java:533)
at com.sun.org.apache.xerces.internal.xinclude.XIncludeHandler. startElement(XIncludeHandler.java:715)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScanner Impl.scanStartElement(XMLNSDocumentScannerImpl.java:330)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScanner Impl$NSContentDispatcher.scanRootElementHook(XMLNSDocumentSc annerImpl.java:779)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentS cannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFra gmentScannerImpl.java:1794)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentS cannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java: 368)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuratio n.parse(XML11Configuration.java:834)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuratio n.parse(XML11Configuration.java:764)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(X MLParser.java:148)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser .parse(AbstractSAXParser.java:1168)
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJB ossXBParser.java:173)
... 7 more
19:58:24,687 INFO [ServerImpl] Runtime shutdown hook called, forceHalt: true
19:58:24,703 INFO [ServerImpl] Shutdown complete
Shutdown complete
Halting VM

Any help would be greatly appreciated!

Regards,
Anthony Frasso
Re: JBoss 5 Startup from Eclipse Ganymede [message #226129 is a reply to message #226100] Wed, 07 January 2009 13:49 Go to previous messageGo to next message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

Hi Anthony,

I don't see a reason for this, my JBoss 5 runs without problems.

Did you modify the JBoss installation? Or does your app include XML related
JARs, which confuse JBoss? You probably picked to Java 1.5 version of JBoss, not
the 1.6 one?

Also WTP 3.0.3 does not support JBoss5GA by default, so that you have to do some
modifications to the server plugin (see
https://bugs.eclipse.org/bugs/show_bug.cgi?id=257823). Did you follow those
instructions, or did you do something else to make it running?

And juest a final guess: did you unzip JBoss over an existing previous version?

Hope this helps

Wolfgang


Anthony Frasso schrieb:
> I'm having some trouble starting up JBoss 5 from Eclipse. I am able to
> startup JBoss from the command line without a problem:
>
> Unfortunately, when I do the same from Eclipse, I get an error:
>
> Any help would be greatly appreciated!
>
> Regards,
> Anthony Frasso
>
>
Re: JBoss 5 Startup from Eclipse Ganymede [message #226153 is a reply to message #226129] Wed, 07 January 2009 16:05 Go to previous messageGo to next message
Eclipse User
Originally posted by: anf4.cornell.edu

Hi Wolfgang,

I am using the Java 1.5 version of JBoss 5... is this a problem? Should
I use the 1.6 version?

As far as the app goes, I am not deploying an app at all; just trying to
start the server from Eclipse (I was trying to isolate the problem).

I also did follow the instructions in the bug below.

Regards,
Anthony Frasso

> Hi Anthony,
>
> I don't see a reason for this, my JBoss 5 runs without problems.
>
> Did you modify the JBoss installation? Or does your app include XML
> related JARs, which confuse JBoss? You probably picked to Java 1.5
> version of JBoss, not the 1.6 one?
>
> Also WTP 3.0.3 does not support JBoss5GA by default, so that you have
> to do some modifications to the server plugin (see
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=257823). Did you follow
> those instructions, or did you do something else to make it running?
>
> And juest a final guess: did you unzip JBoss over an existing previous
> version?
>
> Hope this helps
>
> Wolfgang
>
> Anthony Frasso schrieb:
>
>> I'm having some trouble starting up JBoss 5 from Eclipse. I am able
>> to startup JBoss from the command line without a problem:
>>
>> Unfortunately, when I do the same from Eclipse, I get an error:
>>
>> Any help would be greatly appreciated!
>>
>> Regards,
>> Anthony Frasso
Re: JBoss 5 Startup from Eclipse Ganymede [message #226204 is a reply to message #226153] Thu, 08 January 2009 09:58 Go to previous messageGo to next message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

Hi Anthony,

as JBoss starts by console, I don't think there is a general problem with Java 1.5.

But: I saw that your path to JBoss contains spaces ("c:\Program Files"). This
might cause problems. Please try to unzip JBoss it to a directory without
spaces. If this works, then there is maybe a problem in the eclipse plugin,
which should be filed in bugzilla.

And one final idea: does eclipse use JDK or JRE for the server startup? I don't
see this information in your console output. If JRE: try to use a JDK.

Hope this helps

Wolfgang


Anthony Frasso schrieb:
> Hi Wolfgang,
>
> I am using the Java 1.5 version of JBoss 5... is this a problem? Should
> I use the 1.6 version?
>
> As far as the app goes, I am not deploying an app at all; just trying to
> start the server from Eclipse (I was trying to isolate the problem).
>
> I also did follow the instructions in the bug below.
>
> Regards,
> Anthony Frasso
>
Re: JBoss 5 Startup from Eclipse Ganymede [message #228771 is a reply to message #226204] Wed, 11 March 2009 10:02 Go to previous messageGo to next message
Elvis Dominguez is currently offline Elvis Dominguez
Messages: 52
Registered: July 2009
Location: Switzerland
Member
Hi just to inform you that I had similar problems starting jboss from
eclipse under Windows.
After Wolfgang's tip (spaces in jboss home path) i have tried to mov
JBoss in a location as C:\JBoss and now everything works fine.

Thank you all
+1 to Wolfgang

kindly

--
Elvis Dominguez
Re: JBoss 5 Startup from Eclipse Ganymede [message #229047 is a reply to message #226153] Mon, 16 March 2009 20:59 Go to previous message
Deepak Sharma is currently offline Deepak Sharma
Messages: 2
Registered: July 2009
Junior Member
Hi Anthony,

Ypur guess is correct you need to use Java 1.6 to fix the issue. I was
having the same issue and my default JRE in Eclipse was set toJRE 1.5. I
created a new JRE for 1.6 and used that as default. Issue is gone now.

Thanks,
Deepak
Previous Topic:How to build a web service with webtool, or fix invocationTargetException
Next Topic:JBoss startup error - Cound not start server in 50 seconds
Goto Forum:
  


Current Time: Thu Oct 02 16:39:18 GMT 2014

Powered by FUDForum. Page generated in 0.02088 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software