Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Can't get the XML editor to work
Can't get the XML editor to work [message #225370] Wed, 17 December 2008 23:58 Go to next message
Arne Skjærholt is currently offline Arne SkjærholtFriend
Messages: 3
Registered: July 2009
Junior Member
Hi,
I've unpacked a fresh a pretty recent J2EE package of Eclipse Ganymede
(The about dialog says version 3.4.1 id M20080911-1700), and I've
installed the WTP from the update site. The main reason I installed the
WTP was to get the lovely XML editor, which I can't get to work
unfortunately. I've tried installing various other plugins and so on,
without any success.

Whenever I open an XML file all I get is the default Eclipse structured
file editor (which is kind of weird, I have to admit), but when I look
through the various preferences it looks like the XML editor installed
seeing how I can select all kinds of preferences for syntax highlighting
and so on, I just can't seem to get the actual editor to work (or maybe I
just haven't found the right place to go to in order to open it?).

Can anyone help me with this?

Thanks,
Arne
:wq
Re: Can't get the XML editor to work [message #225378 is a reply to message #225370] Thu, 18 December 2008 00:29 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dcarver.starstandard.org

Make sure that you have a Java 1.5 or 1.6 jre installed.

Dave

Arne Skjærholt wrote:
> Hi,
> I've unpacked a fresh a pretty recent J2EE package of Eclipse Ganymede
> (The about dialog says version 3.4.1 id M20080911-1700), and I've
> installed the WTP from the update site. The main reason I installed the
> WTP was to get the lovely XML editor, which I can't get to work
> unfortunately. I've tried installing various other plugins and so on,
> without any success.
>
> Whenever I open an XML file all I get is the default Eclipse structured
> file editor (which is kind of weird, I have to admit), but when I look
> through the various preferences it looks like the XML editor installed
> seeing how I can select all kinds of preferences for syntax highlighting
> and so on, I just can't seem to get the actual editor to work (or maybe
> I just haven't found the right place to go to in order to open it?).
>
> Can anyone help me with this?
>
> Thanks,
> Arne
> :wq
>
Re: Can't get the XML editor to work [message #225386 is a reply to message #225370] Thu, 18 December 2008 00:30 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dcarver.starstandard.org

Also, what OS are you running this on?

Dave

Arne Skjærholt wrote:
> Hi,
> I've unpacked a fresh a pretty recent J2EE package of Eclipse Ganymede
> (The about dialog says version 3.4.1 id M20080911-1700), and I've
> installed the WTP from the update site. The main reason I installed the
> WTP was to get the lovely XML editor, which I can't get to work
> unfortunately. I've tried installing various other plugins and so on,
> without any success.
>
> Whenever I open an XML file all I get is the default Eclipse structured
> file editor (which is kind of weird, I have to admit), but when I look
> through the various preferences it looks like the XML editor installed
> seeing how I can select all kinds of preferences for syntax highlighting
> and so on, I just can't seem to get the actual editor to work (or maybe
> I just haven't found the right place to go to in order to open it?).
>
> Can anyone help me with this?
>
> Thanks,
> Arne
> :wq
>
Re: Can't get the XML editor to work [message #225393 is a reply to message #225378] Thu, 18 December 2008 05:23 Go to previous messageGo to next message
Arne Skjærholt is currently offline Arne SkjærholtFriend
Messages: 3
Registered: July 2009
Junior Member
Yeah, I should've remembered to add that. I've got JRE 1.6.0_07, running
on Windows XP.

Arne
:wq
Re: Can't get the XML editor to work [message #225401 is a reply to message #225370] Thu, 18 December 2008 09:12 Go to previous messageGo to next message
Owen Rees is currently offline Owen ReesFriend
Messages: 41
Registered: July 2009
Member
arnsholt@gmail.com (Arne Skjærholt) writes:

> Whenever I open an XML file all I get is the default Eclipse
> structured file editor (which is kind of weird, I have to admit), but
> when I look through the various preferences it looks like the XML
> editor installed seeing how I can select all kinds of preferences for
> syntax highlighting and so on, I just can't seem to get the actual
> editor to work (or maybe I just haven't found the right place to go to
> in order to open it?).

Are you looking for the tabs at the bottom of the edit window?

--
Owen Rees; speaking personally, and not on behalf of HP.
========================================================
Hewlett-Packard Limited. Registered No: 690597 England
Registered Office: Cain Road, Bracknell, Berks RG12 1HN
Re: Can't get the XML editor to work [message #225417 is a reply to message #225370] Thu, 18 December 2008 17:09 Go to previous messageGo to next message
Mark Hutchinson is currently offline Mark HutchinsonFriend
Messages: 53
Registered: July 2009
Member
If you right click on an xml file, can you see "Open With" then "XML
editor"?

Arne Skjærholt wrote:
> Hi,
> I've unpacked a fresh a pretty recent J2EE package of Eclipse Ganymede
> (The about dialog says version 3.4.1 id M20080911-1700), and I've
> installed the WTP from the update site. The main reason I installed the
> WTP was to get the lovely XML editor, which I can't get to work
> unfortunately. I've tried installing various other plugins and so on,
> without any success.
>
> Whenever I open an XML file all I get is the default Eclipse structured
> file editor (which is kind of weird, I have to admit), but when I look
> through the various preferences it looks like the XML editor installed
> seeing how I can select all kinds of preferences for syntax highlighting
> and so on, I just can't seem to get the actual editor to work (or maybe
> I just haven't found the right place to go to in order to open it?).
>
> Can anyone help me with this?
>
> Thanks,
> Arne
> :wq
>
Re: Can't get the XML editor to work [message #225463 is a reply to message #225401] Thu, 18 December 2008 22:52 Go to previous message
Arne Skjærholt is currently offline Arne SkjærholtFriend
Messages: 3
Registered: July 2009
Junior Member
That's the bunny. I cannot believe I didn't see that. Thank you so much
for realising that it was a real PEBKAC-type problem.

Now, I'm just gonna sit in a corner and be ashamed of myself for a bit.

Thanks again!

Arne
:wq
Previous Topic:The Outline view and XML Editor are not kept in sync
Next Topic:no XML object
Goto Forum:
  


Current Time: Fri Dec 19 00:34:16 GMT 2014

Powered by FUDForum. Page generated in 0.01953 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software