Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » how to set default server and runtime for web service in config.ini
how to set default server and runtime for web service in config.ini [message #224042] Thu, 20 November 2008 09:16 Go to next message
grid.qian  is currently offline grid.qian
Messages: 47
Registered: July 2009
Member
Hi guys,
I have a question.
I am using eclipse3.4 and jboss tools3.0. I want to set a default server
and runtime for web service in the preference page:
windows->preferences->web services-> server and runtime. I want to set the
default values of the server and runtime(server=jboss42,runtime=jbossWS) in
eclipse's config.ini file.
Now I addd two lines as below in config.ini:
org.eclipse.jst.ws.consumption.ui.serviceServer=org.eclipse. jst.server.generic.jboss42
org.eclipse.jst.ws.consumption.ui.serviceRuntime=org.jboss.t ools.ws.creation.jbossWebServiceRT

But I can not get the result that I wanted.
Who can help me for this?
Re: how to set default server and runtime for web service in config.ini [message #224080 is a reply to message #224042] Fri, 21 November 2008 04:19 Go to previous messageGo to next message
Kathy Chan is currently offline Kathy Chan
Messages: 93
Registered: July 2009
Member
Hi,

First of all, the lines to set are:

org.eclipse.jst.ws.consumption.ui/PREFERENCE_SERVER=org.ecli pse.jst.server.generic.jboss42
org.eclipse.jst.ws.consumption.ui/PREFERENCE_RUNTIME=org.jbo ss.tools.ws.creation.jbossWebServiceRT

Secondly, you should put the above 2 lines in a plugin_customization.ini
file and then invoke Eclipse with:

eclipse -data workspace -clean -pluginCustomization
plugin_customization.ini

You'll noticed that the Web services Server and runtime preference is
updated to the server and runtime you set in the above lines.

Please give it a try. I just tried setting the default server and runtime
using the above method with WTP 3.0.3 and was able to change those defaults
in the preference.

Regards,
Kathy Chan

"grid.qian " <grid.qian@gmail.com> wrote in message
news:8148e5c175ba128df5e259172fd908a9$1@www.eclipse.org...
> Hi guys,
> I have a question.
> I am using eclipse3.4 and jboss tools3.0. I want to set a default server
> and runtime for web service in the preference page:
> windows->preferences->web services-> server and runtime. I want to set the
> default values of the server and runtime(server=jboss42,runtime=jbossWS)
> in eclipse's config.ini file.
> Now I addd two lines as below in config.ini:
> org.eclipse.jst.ws.consumption.ui.serviceServer=org.eclipse. jst.server.generic.jboss42
> org.eclipse.jst.ws.consumption.ui.serviceRuntime=org.jboss.t ools.ws.creation.jbossWebServiceRT
>
> But I can not get the result that I wanted.
> Who can help me for this?
>
>
Re: how to set default server and runtime for web service in config.ini [message #224393 is a reply to message #224080] Wed, 26 November 2008 05:16 Go to previous message
grid.qian  is currently offline grid.qian
Messages: 47
Registered: July 2009
Member
Thank you very much!
I have test it on eclipse 3.4. It's OK.
Previous Topic:Changing the port that Tomcat uses?
Next Topic:Programmatic use of XMLCorePlugin and ICatalog APIs
Goto Forum:
  


Current Time: Thu Oct 23 05:10:58 GMT 2014

Powered by FUDForum. Page generated in 0.25697 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software