Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » obtain webtools sourcecode - HOW ? cvs does not work ?
obtain webtools sourcecode - HOW ? cvs does not work ? [message #223169] Tue, 28 October 2008 04:50 Go to next message
Eclipse User
Originally posted by: aaa.aa.aaa

I want to download webtools sourcecode

I have not found the package with source of builds in downlod section
(eclipse.otg) :-(
I have found only one way - CVS as in document
http://wiki.eclipse.org/index.php/CVS_Howto

unfortunately :-( get:

c:\cvs>cvs -d :pserver:anonymous@dev.eclipse.org:80/cvsroot/eclipse login
Logging in to :pserver:anonymous@dev.eclipse.org:80/cvsroot/eclipse
CVS password:
cvs [login aborted]: unrecognized auth response from dev.eclipse.org:
HTTP/1.1 400 Bad Request ( The data is invalid. )


I need this sources, is there any way to get them ?

best regards
kris
Re: obtain webtools sourcecode - HOW ? cvs does not work ? [message #223185 is a reply to message #223169] Tue, 28 October 2008 08:38 Go to previous messageGo to next message
Eclipse User
Originally posted by: dcarver.starstandard.org

You can also get the source by installing the SDK version of the tools.
The source is included there.

Also the webtools source repository is in /cvsroot/webtools

And try using the standard port for cvs which is 2401 not port 80.

Dave



aaa wrote:
> I want to download webtools sourcecode
>
> I have not found the package with source of builds in downlod section
> (eclipse.otg) :-(
> I have found only one way - CVS as in document
> http://wiki.eclipse.org/index.php/CVS_Howto
>
> unfortunately :-( get:
>
> c:\cvs>cvs -d :pserver:anonymous@dev.eclipse.org:80/cvsroot/eclipse login
> Logging in to :pserver:anonymous@dev.eclipse.org:80/cvsroot/eclipse
> CVS password:
> cvs [login aborted]: unrecognized auth response from dev.eclipse.org:
> HTTP/1.1 400 Bad Request ( The data is invalid. )
>
>
> I need this sources, is there any way to get them ?
>
> best regards
> kris
>
>
Re: obtain webtools sourcecode - HOW ? cvs does not work ? [message #223193 is a reply to message #223185] Tue, 28 October 2008 08:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: aaa.aa.aaa

> You can also get the source by installing the SDK version of the tools.

Thank you! Exactly what I was looking for

> And try using the standard port for cvs which is 2401 not port 80.
>

I get Connection refused, however this may be caused by LAN.
According to http://wiki.eclipse.org/index.php/CVS_Howto
This should work on port 80 anyway. If you know where to raport this
let me know...

best regards
kris
Re: obtain webtools sourcecode - HOW ? cvs does not work ? [message #223201 is a reply to message #223169] Tue, 28 October 2008 10:33 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1305
Registered: July 2009
Senior Member
aaa wrote:
> I want to download webtools sourcecode
>
> I have not found the package with source of builds in downlod section
> (eclipse.otg) :-(
> I have found only one way - CVS as in document
> http://wiki.eclipse.org/index.php/CVS_Howto
>
> unfortunately :-( get:
>
> c:\cvs>cvs -d :pserver:anonymous@dev.eclipse.org:80/cvsroot/eclipse login
> Logging in to :pserver:anonymous@dev.eclipse.org:80/cvsroot/eclipse
> CVS password:
> cvs [login aborted]: unrecognized auth response from dev.eclipse.org:
> HTTP/1.1 400 Bad Request ( The data is invalid. )
>
>
> I need this sources, is there any way to get them ?
>
> best regards
> kris
>
>

If it helps, according to the document, proxy.eclipse.org is on port 80,
not dev.eclipse.org. I believe you would leave the port off for
dev.eclipse.org and include port 80 if you are using proxy.eclipse.org.

Cheers,
Larry
Previous Topic:how to change the filesystem location of a wtp server?
Next Topic:Problem setting up web application
Goto Forum:
  


Current Time: Sun Aug 31 06:25:39 EDT 2014

Powered by FUDForum. Page generated in 0.02411 seconds