Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » XML Schema Definition (XSD) » Empty Closed Element(Eclipse - XML Editor - How to get Empty Closed Element)
Empty Closed Element [message #1310228] Wed, 23 April 2014 04:39 Go to next message
Karthikeyan Rajendran is currently offline Karthikeyan RajendranFriend
Messages: 2
Registered: April 2014
Junior Member
Am pretty new to Eclipse and XSDs. I have couple of questions

1. When I add an Element in Design view while creating an XSD, I need to have empty Closed Element rather than Non-Empty Closed element by Default. Any clue on where to change the setting in Eclipse to accomplish this?For example am getting the below source when I add an element in Design view
<xs:element name="NewElement" type="xs:string"></xs:element>
However I want it be like
<xs:element name="NewElement" type="xs:string" />

2. When I add multiple elements into a Type via Design view, the code is getting generated on the same line continuously without a line break. Am getting like this
<xs:complexType name="RootElementType"><xs:sequence><xs:element name="Element1" type="commonids:Element1Type" maxOccurs="1" minOccurs="0"></xs:element>
but I need it to be like
<xs:complexType name="RootElementType">
<xs:sequence>
<xs:element name="Element1" type="commonids:Element1Type" maxOccurs="1" minOccurs="0" />

I appreciate any help on the above.

Thanks
Karthik
Re: Empty Closed Element [message #1310940 is a reply to message #1310228] Wed, 23 April 2014 13:48 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 26215
Registered: July 2009
Senior Member
Karthik,

You should direct questions about the XML Schema editor to the Web Tools
newsgroup.

On 23/04/2014 3:23 PM, Karthikeyan Rajendran wrote:
> Am pretty new to Eclipse and XSDs. I have couple of questions
> 1. When I add an Element in Design view while creating an XSD, I need
> to have empty Closed Element rather than Non-Empty Closed element by
> Default. Any clue on where to change the setting in Eclipse to
> accomplish this?For example am getting the below source when I add an
> element in Design view
> <xs:element name="NewElement" type="xs:string"></xs:element>
> However I want it be like
> <xs:element name="NewElement" type="xs:string" />
> 2. When I add multiple elements into a Type via Design view, the code
> is getting generated on the same line continuously without a line
> break. Am getting like this
> <xs:complexType name="RootElementType"><xs:sequence><xs:element
> name="Element1" type="commonids:Element1Type" maxOccurs="1"
> minOccurs="0"></xs:element>
> but I need it to be like
> <xs:complexType name="RootElementType">
> <xs:sequence>
> <xs:element name="Element1" type="commonids:Element1Type"
> maxOccurs="1" minOccurs="0" />
>
> I appreciate any help on the above.
>
> Thanks
> Karthik
Previous Topic:XSD Help
Next Topic:A diagram of XMI
Goto Forum:
  


Current Time: Fri Nov 21 18:17:51 GMT 2014

Powered by FUDForum. Page generated in 0.01599 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software