Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Problems installing and using Hudson 3.1.2
Problems installing and using Hudson 3.1.2 [message #1307106] Mon, 21 April 2014 06:42 Go to next message
ops incybr is currently offline ops incybr
Messages: 2
Registered: April 2014
Junior Member
While the hudson-3.1.2.war works fine with Tomcat 7.0.53 it does not work with Tomcat 8.0.5

The war deploys successfully but throws the following error message in the Tomcat Web Application Manager when attempting to start the app.

FAIL - Application at context path /hudson-3.1.2 could not be started
FAIL - Encountered exception org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/hudson-3.1.2]]

Of greater concern is the inability to install the Hudson-Eclipse integration from Sonatype to Eclipse (Kepler).

Attempting the Help -> Install New Software .. procedure as detailed in "The Hudson Book" in Eclipse (Kepler) throws the error

Cannot complete the install because one or more required items could not be found.
Software being installed: Hudson Integration for M2Eclipse 0.13.0.20111015-0033 (org.sonatype.m2e.hudson.feature.feature.group 0.13.0.20111015-0033)
Missing requirement: org.maven.ide.eclipse.ui.tests.common 1.1.7.201105091728 (org.maven.ide.eclipse.ui.tests.common 1.1.7.201105091728) requires 'bundle org.junit4 0.0.0' but it could not be found
Cannot satisfy dependency:
From: UI Commons 1.1.7.201105091728 (org.maven.ide.eclipse.commons.feature.feature.group 1.1.7.201105091728)
To: org.maven.ide.eclipse.ui.tests.common [1.1.7.201105091728]
Cannot satisfy dependency:
From: Hudson Integration for M2Eclipse 0.13.0.20111015-0033 (org.sonatype.m2e.hudson.feature.feature.group 0.13.0.20111015-0033)
To: org.maven.ide.eclipse.commons.feature.feature.group [1.1.7.201105091728]

The procedure does however work flawlessly with Eclipse (Juno).

Googling the error suggests that a number of plugins have encountered this error. Unfortunately none of the workarounds detailed (e.g. placing the missing jar files in the Kepler plugins directory) seem effective in this case ?

Any alternative sources, workarounds or indication as to if and when Sonatype will address this issue?
Re: Problems installing and using Hudson 3.1.2 [message #1317398 is a reply to message #1307106] Sat, 26 April 2014 23:13 Go to previous messageGo to next message
ops incybr is currently offline ops incybr
Messages: 2
Registered: April 2014
Junior Member
OTOH, upon further investigation prompted by massive o.p. views with no responses, this naive newbie wannabe developer who really shouldn't be messing with such "advanced" tools finds that Jenkins 1.560 works fine with Tomcat 8.05, installs as a windows service (a procedure mentioned but undocumented by the Hudson project) and that by dropping the dk.contix.hudson_1.0.9.jar file into the plugins directory seems to integrate just fine with Eclipse (Kepler).
Re: Problems installing and using Hudson 3.1.2 [message #1320313 is a reply to message #1317398] Mon, 28 April 2014 14:21 Go to previous message
Winston Prakash is currently offline Winston Prakash
Messages: 391
Registered: August 2011
Location: Fremont, CA USA
Senior Member
Sorry, I couldn't help because I don't know much about Hudson-Eclipse integration from Sonatype to Eclipse. What is dk.contix.hudson_1.0.9.jar?

Winston Prakash
Eclipse Hudson team
Previous Topic:Plugin NoClassDefFoundError
Next Topic:Build Publisher 1.11
Goto Forum:
  


Current Time: Tue Jul 29 09:02:52 EDT 2014

Powered by FUDForum. Page generated in 0.01913 seconds