Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Can't startup the OSGI fr
Can't startup the OSGI fr [message #220478] Thu, 22 February 2007 16:23 Go to next message
Gabriele is currently offline Gabriele
Messages: 19
Registered: July 2009
Junior Member
Hi all,
- I installed the ReportEngine under
C:\Devel\birt-runtime-2_1_1\ReportEngine
- I set BIRT_HOME to C:\Devel\birt-runtime-2_1_1\ReportEngine\
- I added itext-1.3.jar under
C:\Devel\birt-runtime-2_1_1\ReportEngine\plugins\com.lowagie .itext\lib

I'm using eclipse, I created a test project with a main class that call a
method that tries to convert a report to pdf format but I have the
following exception:

org.eclipse.birt.core.exception.BirtException: $NO-RB$ Can't startup the
OSGI framework
at org.eclipse.birt.core.framework.Platform.startup(Platform.ja va:90)
at hplus.webapp.birt.Exporting.export(Exporting.java:36)
at hplus.webapp.birt.Exporting.main(Exporting.java:23)
Caused by: org.eclipse.birt.core.exception.BirtException: $NO-RB$ Could
not start the Framework - {0}C:\Develirt-runtime-2_1_1\ReportEngine\
at
org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OS GILauncher.java:44)
at org.eclipse.birt.core.framework.Platform.startup(Platform.ja va:78)
... 2 more

I've red a lot of posts of many peoples with the same problems but i
couldn't solve the problem. Can you help me? Tnx in advance.

Ciao Gabriele
Re: Can't startup the OSGI fr [message #220487 is a reply to message #220478] Thu, 22 February 2007 16:29 Go to previous messageGo to next message
Gabriele is currently offline Gabriele
Messages: 19
Registered: July 2009
Junior Member
sorry for the double post
Re: Can't startup the OSGI fr [message #220492 is a reply to message #220478] Thu, 22 February 2007 16:47 Go to previous messageGo to next message
Eclipse User
Originally posted by: martin.tauber.t-online.de

Gabriele,

do you have all the jars from the reportengine/lib directory in your
classpath?

Regards
Martin

P.S. If your using eclipse select the "run ..." action goto your java
application and select the classpath tab. then press add external jars
and navigate to the reportengine/lib directory and select all the jars
in that directory.


Gabriele schrieb:
> Hi all, - I installed the ReportEngine under
> C:\Devel\birt-runtime-2_1_1\ReportEngine
> - I set BIRT_HOME to C:\Devel\birt-runtime-2_1_1\ReportEngine\
> - I added itext-1.3.jar under
> C:\Devel\birt-runtime-2_1_1\ReportEngine\plugins\com.lowagie .itext\lib
>
> I'm using eclipse, I created a test project with a main class that call
> a method that tries to convert a report to pdf format but I have the
> following exception:
>
> org.eclipse.birt.core.exception.BirtException: $NO-RB$ Can't startup the
> OSGI framework
> at org.eclipse.birt.core.framework.Platform.startup(Platform.ja va:90)
> at hplus.webapp.birt.Exporting.export(Exporting.java:36)
> at hplus.webapp.birt.Exporting.main(Exporting.java:23)
> Caused by: org.eclipse.birt.core.exception.BirtException: $NO-RB$ Could
> not start the Framework - {0}C:\Develirt-runtime-2_1_1\ReportEngine\
> at
> org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OS GILauncher.java:44)
>
> at org.eclipse.birt.core.framework.Platform.startup(Platform.ja va:78)
> ... 2 more
>
> I've red a lot of posts of many peoples with the same problems but i
> couldn't solve the problem. Can you help me? Tnx in advance.
>
> Ciao Gabriele
>
>
>
Re: Can't startup the OSGI fr [message #220510 is a reply to message #220478] Thu, 22 February 2007 18:31 Go to previous messageGo to next message
Eclipse User
Originally posted by: home4slc.pacbell.net

Hi Gabriele,

This may just be a cut and paste error, but it appears that the value
you think you have BIRT_HOME set to and what it is actually set to
according to the stack trace are different.

It looks like there is a missing '\b' in the BIRT_HOME path.

Regards,

Susan

Gabriele wrote:
> Hi all, - I installed the ReportEngine under
> C:\Devel\birt-runtime-2_1_1\ReportEngine
> - I set BIRT_HOME to C:\Devel\birt-runtime-2_1_1\ReportEngine\
> - I added itext-1.3.jar under
> C:\Devel\birt-runtime-2_1_1\ReportEngine\plugins\com.lowagie .itext\lib
>
> I'm using eclipse, I created a test project with a main class that call
> a method that tries to convert a report to pdf format but I have the
> following exception:
>
> org.eclipse.birt.core.exception.BirtException: $NO-RB$ Can't startup the
> OSGI framework
> at org.eclipse.birt.core.framework.Platform.startup(Platform.ja va:90)
> at hplus.webapp.birt.Exporting.export(Exporting.java:36)
> at hplus.webapp.birt.Exporting.main(Exporting.java:23)
> Caused by: org.eclipse.birt.core.exception.BirtException: $NO-RB$ Could
> not start the Framework - {0}C:\Develirt-runtime-2_1_1\ReportEngine\
> at
> org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OS GILauncher.java:44)
>
> at org.eclipse.birt.core.framework.Platform.startup(Platform.ja va:78)
> ... 2 more
>
> I've red a lot of posts of many peoples with the same problems but i
> couldn't solve the problem. Can you help me? Tnx in advance.
>
> Ciao Gabriele
>
>
>
Re: Can't startup the OSGI fr [message #220657 is a reply to message #220510] Fri, 23 February 2007 09:15 Go to previous messageGo to next message
Gabriele is currently offline Gabriele
Messages: 19
Registered: July 2009
Junior Member
Hi Susan, hi Martin. At first thanks a lot for your answers, but I didn't
solve the problem.

In the Java Build Path of my projects I added all the external jars from
the lib "C:\Devel\birt-runtime-2_1_1\ReportEngine\lib" do I have to do
something more Martin?

Moreover I set the EV to, is that right Susan?

BIRT_HOME = C:\Devel\birt-runtime-2_1_1\ReportEngine

BIRT_LIB = %BIRT_HOME%\lib

BIRTCLASSPATH =
%BIRT_LIB%\com.ibm.icu_3.4.4.1.jar;%BIRT_LIB%\commons-cli-1. 0.jar;%BIRT_LIB%\commons-codec-1.3.jar;%BIRT_LIB%\coreapi.ja r;%BIRT_LIB%\dataadapterapi.jar;%BIRT_LIB%\dteapi.jar;%BIRT_ LIB%\engineapi.jar;%BIRT_LIB%\flute.jar;%BIRT_LIB%\js.jar;%B IRT_LIB%\modelapi.jar;%BIRT_LIB%\org.eclipse.emf.common_2.2. 0.v200606051102.jar;%BIRT_LIB%\org.eclipse.emf.ecore.xmi_2.2 .0.v200606051102.jar;%BIRT_LIB%\org.eclipse.emf.ecore_2.2.0. v200606051102.jar;%BIRT_LIB%\sac.jar;%BIRT_LIB%\scriptapi.ja r

CLASSPATH = %BIRTCLASSPATH% (and all the other dirs)

PATH = %BIRT_HOME% (and all the other dirs)
Re: Can't startup the OSGI fr [message #798976 is a reply to message #220657] Wed, 15 February 2012 09:47 Go to previous messageGo to next message
suganya govindaraj is currently offline suganya govindaraj
Messages: 8
Registered: February 2012
Junior Member
Hi friends,
Am also having this issue. Please someone help me to solve this issue.
I'm new to eclipse BIRT.

The project is configured successfully. And i can view the index page also.
But when i hit ".../run?__report=report/demoReport.rptdesign"
it showing
"+ Cant startup the OSGI framework" ..

Please some one help me to resolve this issue.

Thanks in Advance.

[Updated on: Wed, 15 February 2012 12:09]

Report message to a moderator

Re: Can't startup the OSGI fr [message #799272 is a reply to message #798976] Wed, 15 February 2012 17:20 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

What version of BIRT are you using? How do you want to deploy it (
using the viewer or report engine API)?

Jason


On 2/15/2012 4:47 AM, suganya govindaraj wrote:
> Hi friends,
> Am also having this issue. Please someone help me to solve this issue.
> I'm new to eclipse BIRT. I don't know how to include
> "birt-runtime/ReportEngine/lib" into my project.
>
> When i try to run my project, It showing SEVERE Error listenerStart in
> tomcat. In web.xml, <context-param>
> <param-name>BIRT_VIEWER_CONFIG_FILE</param-name>
> <param-value>/WEB-INF/viewer.properties</param-value>
> </context-param>
>
> <listener>
> <listener-class>org.eclipse.birt.report.listener.ViewerServletContextListener</listener-class>
>
> </listener>
>
> I included these lines. So that only am getting error likewise...
>
> If i stop tomcat. And copied the "jar" files from
> birt-runtime/WebViewerExample/WEB-INF/lib into
> tomcat/webapps/sampleProject/WEB-INF/lib
> The project is configured successfully. And i can view the index page also.
> But when i hit ".../run?__report=report/demoReport.rptdesign" it showing
> "+ Cant startup the OSGI framework" ..
>
> Please some one help me to resolve this issue.
>
> Thanks in Advance.
Re: Can't startup the OSGI fr [message #799916 is a reply to message #799272] Thu, 16 February 2012 13:17 Go to previous messageGo to next message
suganya govindaraj is currently offline suganya govindaraj
Messages: 8
Registered: February 2012
Junior Member
Hi,
At first, thanks for your reply.

Am using BIRT version 2.6.2..
Actually I want to view my BIRT report in jsp file.

But it showing "+ Cant startup the OSGI framework" ..

My jsp file is
---------------


<%@ taglib uri="/WEB-INF/birt.tld" prefix="birt" %>

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
</head>
<body>

<birt:viewer id="birtViewer"
reportDesign="sample.rptdesign"
pattern="frameset"
height="600"
width="800"
format="html"
title="My Viewer Tag"
showTitle="true"
showToolBar="true"
showNavigationBar="true">
</birt:viewer>
</body>
</html>


Why am getting Can't startup the OSGI framework error.
Re: Can't startup the OSGI fr [message #800189 is a reply to message #799916] Thu, 16 February 2012 19:56 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Try copying the WebViewerExample folder to your app server. For example
with tomcat put it in the webapps directory. Rename it to birt.
Then copy the jsp file you created to the birt directory.
Start app server and enter the url
http://localhost:8080/birt/yourjsppage.jsp

Jason

On 2/16/2012 8:17 AM, suganya govindaraj wrote:
> Hi,
> At first, thanks for your reply.
>
> Am using BIRT version 2.6.2..
> Actually I want to view my BIRT report in jsp file.
>
> But it showing "+ Cant startup the OSGI framework" ..
>
> My jsp file is
> ---------------
>
>
> <%@ taglib uri="/WEB-INF/birt.tld" prefix="birt" %>
>
> <html>
> <head>
> <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
> </head>
> <body>
>
> <birt:viewer id="birtViewer"
> reportDesign="sample.rptdesign"
> pattern="frameset"
> height="600"
> width="800"
> format="html"
> title="My Viewer Tag"
> showTitle="true"
> showToolBar="true"
> showNavigationBar="true">
> </birt:viewer>
> </body>
> </html>
>
>
> Why am getting Can't startup the OSGI framework error.
Re: Can't startup the OSGI fr [message #804179 is a reply to message #800189] Wed, 22 February 2012 09:43 Go to previous messageGo to next message
suganya govindaraj is currently offline suganya govindaraj
Messages: 8
Registered: February 2012
Junior Member
Ya I copied WebViewerExample folder and renamed as birt in my webapps. Within that i copied my jsp file and rptdesign file both are working fine.

But I created a new Project(birtdemo) in Eclipse. When i executing that,
http://localhost:8080/birtdemo/sample.jsp
It showing
Can't startup the OSGI framework

And when i try to hit
http://localhost:8080/birtdemo/report/sample.rptdesign
It showing
HTTP Status 404 - Not Found Network Error

I don't know where was the problem..

[Updated on: Wed, 22 February 2012 09:45]

Report message to a moderator

Re: Can't startup the OSGI fr [message #804406 is a reply to message #804179] Wed, 22 February 2012 15:32 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

You might want to look at using the WTP Integration package for BIRT.
It is located on the full downloads page:
http://download.eclipse.org/birt/downloads/build.php?build=R-R1-3_7_1-201109131734
Look for BIRT Web Tools Integration. Download the zip and extract into
your Eclipse install. This will make a Configuration available under
new web project named BIRT Reporting Web Project. Take a look at the
screen shots in this post:
http://www.birt-exchange.org/org/forum/index.php/topic/18337-installing-birt-wtp-integration-sdk-2-5-1-in-eclipse-reporting-galileo-2-5-1/page__s__4fa567b4dd6fd90f6987b617252b7b72

Jason

On 2/22/2012 4:43 AM, Amunatha Sree wrote:
> Try copying the WebViewerExample folder to your app server. For example
> with tomcat put it in the webapps directory. Rename it to birt.
> Then copy the jsp file you created to the birt directory.
> Start app server and enter the url
> http://localhost:8080/birt/yourjsppage.jsp
>
> Jason
>
> Ya I copied WebViewerExample folder and renamed as birt in my webapps.
> Within that i copied my jsp file and rptdesign file both are working fine.
>
> But I created a new Project(birtdemo) in Eclipse. When i executing that,
> http://localhost:8080/birtdemo/sample.jsp
> It showing Can't startup the OSGI framework
> And when i try to hit
> http://localhost:8080/birtdemo/report/sample.rptdesign
> It showing
> HTTP Status 404 - Not Found Network Erro
>
> I dont know where was the problem..
Re: Can't startup the OSGI fr [message #804902 is a reply to message #804406] Thu, 23 February 2012 05:53 Go to previous messageGo to next message
suganya govindaraj is currently offline suganya govindaraj
Messages: 8
Registered: February 2012
Junior Member
Hi Jason,

I downloaded "birt-wtp-integration-sdk-3_7_1.zip", copied into eclipse. and extracted into the eclipse (installed location. In my case D:\Progs\eclipse)..
And I created new dynamic web project http://www.birt-exchange.org/org/forum/index.php/topic/18337-installing-birt-wtp-integration-sdk-2-5-1-in-eclipse-reporting-galileo-2-5-1/page__s__4fa567b4dd6fd90f6987b617252b7b72 as you mentioned in this post. Then copied my "old source" into this new project.

But the Exception is not cleared. It still showing "Can't startup OSGI framework".

My Tomcat exception is,
org.eclipse.birt.core.exception.BirtException: Can't startup the OSGI framework
at org.eclipse.birt.core.framework.Platform.startup(Platform.java:91)
at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(
ReportEngineService.java:320)
at org.eclipse.birt.report.service.BirtViewerReportService.setContext(Bi
rtViewerReportService.java:1022)
at org.eclipse.birt.report.servlet.ViewerServlet.__getContext(ViewerServ
let.java:148)
at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.doPo
st(BirtSoapMessageDispatcherServlet.java:243)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBas
e.java:327)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.serv
ice(BirtSoapMessageDispatcherServlet.java:122)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:206)
at org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.jav
a:68)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
alve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
alve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
ava:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
ava:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
ve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
a:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
:849)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
ss(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:45
4)
at java.lang.Thread.run(Thread.java:662)
Caused by: org.eclipse.birt.core.exception.CoreException
at org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OSGILaunche
r.java:90)
at org.eclipse.birt.core.framework.Platform.startup(Platform.java:79)
... 23 more


And I'm having one more doubt. "platform" folder is required within ...\webapps\(mysampleproject)\WEB-INF\....
Re: Can't startup the OSGI fr [message #805435 is a reply to message #804902] Thu, 23 February 2012 19:14 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

If you are using BIRT 3.7 or greater you should not have a platform
directory underneath WEB-INF. Without your customizations does the
default birt web project run?

Jason

On 2/23/2012 12:53 AM, suganya govindaraj wrote:
> Hi Jason,
>
> I downloaded "birt-wtp-integration-sdk-3_7_1.zip", copied into eclipse.
> and extracted into the eclipse (installed location. In my case
> D:\Progs\eclipse)..
> And I created new dynamic web project
> http://www.birt-exchange.org/org/forum/index.php/topic/18337-installing-birt-wtp-integration-sdk-2-5-1-in-eclipse-reporting-galileo-2-5-1/page__s__4fa567b4dd6fd90f6987b617252b7b72
> as you mentioned in this post. Then copied my "old source" into this new
> project.
>
> But the Exception is not cleared. It still showing "Can't startup OSGI
> framework".
>
> My Tomcat exception is,
> org.eclipse.birt.core.exception.BirtException: Can't startup the OSGI
> framework
> at org.eclipse.birt.core.framework.Platform.startup(Platform.java:91)
> at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(
> ReportEngineService.java:320)
> at org.eclipse.birt.report.service.BirtViewerReportService.setContext(Bi
> rtViewerReportService.java:1022)
> at org.eclipse.birt.report.servlet.ViewerServlet.__getContext(ViewerServ
> let.java:148)
> at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.doPo
> st(BirtSoapMessageDispatcherServlet.java:243)
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
> at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBas
> e.java:327)
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
> at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.serv
> ice(BirtSoapMessageDispatcherServlet.java:122)
> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
> icationFilterChain.java:290)
> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
> ilterChain.java:206)
> at org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.jav
> a:68)
> at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
> icationFilterChain.java:235)
> at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
> ilterChain.java:206)
> at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
> alve.java:233)
> at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
> alve.java:191)
> at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
> ava:128)
> at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
> ava:102)
> at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
> ve.java:109)
> at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
> a:293)
> at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
> :849)
> at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
> ss(Http11Protocol.java:583)
> at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:45
> 4)
> at java.lang.Thread.run(Thread.java:662)
> Caused by: org.eclipse.birt.core.exception.CoreException
> at org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OSGILaunche
> r.java:90)
> at org.eclipse.birt.core.framework.Platform.startup(Platform.java:79)
> ... 23 more
>
>
> And I'm having one more doubt. "platform" folder is required within
> ...\webapps\(mysampleproject)\WEB-INF\....
Re: Can't startup the OSGI fr [message #805744 is a reply to message #805435] Fri, 24 February 2012 04:48 Go to previous message
suganya govindaraj is currently offline suganya govindaraj
Messages: 8
Registered: February 2012
Junior Member
No, It showing exception.
org.eclipse.birt.core.exception.BirtException: Can't startup the OSGI framework.
I have a platform directory underneath WEB-INF. If i deleted means also it showing this exception.

Suganya
Previous Topic:Dynamic Parameter with Scripted Data Set
Next Topic:How to Make Reports Attractive
Goto Forum:
  


Current Time: Tue Sep 23 04:31:47 GMT 2014

Powered by FUDForum. Page generated in 0.02328 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software