Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Unhandled event loop exception
Unhandled event loop exception [message #21348] Mon, 09 June 2008 19:44 Go to next message
Eclipse UserFriend
Originally posted by: tcelvis.gmail.com

Hi,

I am trying to follow the guidelines in the IMP users guide (May 2008).

I have sucessfully created an IMP project, but I get an error "Unhandled
event loop exception" when I attempt to use the Language description
wizard.

==========================================================
Error details:
==========================================================
eclipse.buildId=M20071023-1652
java.version=1.6.0_10-beta
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=da_DK
Command-line arguments: -os win32 -ws win32 -arch x86
This is a continuation of log file K:\Eclipse RCP
Workspace\.metadata\.bak_0.log
Created Time: 2008-04-26 00:33:58.718

Error
Mon Jun 09 21:42:26 CEST 2008
Unhandled event loop exception

java.lang.NoSuchMethodError:
org.eclipse.pde.internal.core.PluginModelManager.getAllPlugi ns()[Lorg/eclipse/pde/core/plugin/IPluginModelBase;
at
org.eclipse.imp.wizards.IMPWizardPage.getPluginModel(IMPWiza rdPage.java:694)
at
org.eclipse.imp.wizards.CodeServiceWizard.getStandardSubstit utions(CodeServiceWizard.java:311)
at
org.eclipse.imp.wizards.CodeServiceWizard.getStandardSubstit utions(CodeServiceWizard.java:287)
at org.eclipse.imp.wizards.NewLanguage.performFinish(NewLanguag e.java:189)
at
org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDi alog.java:742)
at
org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDi alog.java:373)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.jav a:616)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:227)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3682)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3293)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:820 )
at org.eclipse.jface.window.Window.open(Window.java:796)
at org.eclipse.ui.actions.NewWizardAction.run(NewWizardAction.j ava:182)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498 )
at
org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:546)
at
org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:490)
at
org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:402)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3682)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3293)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2389)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 19)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:289)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:461)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:106)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:169)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:76)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:363)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)

==========================================================

Any hints on what I need to do to resolve this ?

Regards
Thomas Christensen
Re: Unhandled event loop exception [message #21381 is a reply to message #21348] Tue, 10 June 2008 07:33 Go to previous messageGo to next message
Jin Missing name is currently offline Jin Missing nameFriend
Messages: 100
Registered: July 2009
Senior Member
Thomas Christensen:

java.lang.NoSuchMethodError:
org.eclipse.pde.internal.core.PluginModelManager.getAllPlugi ns()
....

seem a API-compatibility problem?

there are no problem in my 3.4RC3.

jin
Re: Unhandled event loop exception [message #21429 is a reply to message #21348] Wed, 11 June 2008 17:51 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. FuhrerFriend
Messages: 294
Registered: July 2009
Senior Member
Thomas Christensen wrote:
> Hi,
> I am trying to follow the guidelines in the IMP users guide (May 2008).
>
> I have sucessfully created an IMP project, but I get an error "Unhandled
> event loop exception" when I attempt to use the Language description
> wizard.
>
> ==========================================================
> Error details:
> ==========================================================
> eclipse.buildId=M20071023-1652
> java.version=1.6.0_10-beta
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=da_DK
> Command-line arguments: -os win32 -ws win32 -arch x86
> This is a continuation of log file K:\Eclipse RCP
> Workspace\.metadata\.bak_0.log
> Created Time: 2008-04-26 00:33:58.718
>
> Error
> Mon Jun 09 21:42:26 CEST 2008
> Unhandled event loop exception
>
> java.lang.NoSuchMethodError:
> org.eclipse.pde.internal.core.PluginModelManager.getAllPlugi ns()[Lorg/eclipse/pde/core/plugin/IPluginModelBase;

Is this 3.2, 3.3, or 3.4? (I can't quite tell from the build ID.)

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IMP Team Lead (http://www.eclipse.org/imp)
X10: Productivity for High-Performance Parallel Programming (http://x10.sf.net)
Re: Unhandled event loop exception [message #21444 is a reply to message #21429] Wed, 11 June 2008 20:41 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tcelvis.gmail.com

Hi Robert,

It was on:
Eclipse RCP
Version: 3.3.1.1
Build id: M20071023-1652

I have swtched to:
Eclipse
Version: 3.2.1
Build id: M20060921-0945

Using 3.2, I have managed to get as far as using the
“New LPG Grammar with Parser Wrapper for IMP” wizard
sucessfully, and created a lexer and parser with the
sample grammar.

So I guess it seems to be working :-)

Regards
Thomas
Re: Unhandled event loop exception [message #21451 is a reply to message #21444] Wed, 11 June 2008 23:00 Go to previous messageGo to next message
Stan Sutton is currently offline Stan SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
Hi Thomas,

Really you shouldn't have to move backward in your Eclipse version to
get things working (although I applaud your determination). I've been
able to run through our whole demo (multiple wizards) on Eclipse 3.3.1.1
without problems. I have an SDK installation but it has the same build
id as your RCP version.

My recollection is a bit hazy, but I believe that the method at the top
of the stack trace that you provided is one of the ones where there were
differences between 3.2 and 3.3/3.4. But those differences were
something that I thought we had reconciled.

So I guess the next question is, what version of IMP plug-ins do you
have? I'm running with 0.1.74.

Regards,

Stan

Thomas Christensen wrote:
> Hi Robert,
> It was on: Eclipse RCP Version: 3.3.1.1
> Build id: M20071023-1652
>
> I have swtched to:
> Eclipse
> Version: 3.2.1
> Build id: M20060921-0945
>
> Using 3.2, I have managed to get as far as using the
> �New LPG Grammar with Parser Wrapper for IMP� wizard
> sucessfully, and created a lexer and parser with the
> sample grammar.
>
> So I guess it seems to be working :-)
>
> Regards
> Thomas
>
Re: Unhandled event loop exception [message #21459 is a reply to message #21451] Fri, 13 June 2008 17:37 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tcelvis.gmail.com

My IMP-related plugins in my Eclipse RCP are a mix of versions 1.0.72,
1.0.73 and 3.2.72.

The IMP-plugins in my Eclipse 3.2 are versions 0.1.73 and 0.1.74
Re: Unhandled event loop exception [message #21475 is a reply to message #21459] Sat, 14 June 2008 13:18 Go to previous message
Stan Sutton is currently offline Stan SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
Hello Thomas,

I believe that the problem that you saw on Eclipse 3.3 was due to the
use of the 3.2.72 feature. I believe that the exception that you saw
originally is due to changes in plug-in model management between 3.2 and
3.3; we had not yet addressed those in the 3.2.* releases.

I am running on both Eclipse 3.3 and 3.4 with IMP releases 0.1.73 and
0.1.74 without seeing this exception. If you can try that I think you
should get much farther than before.

Of course, I cannot guarantee that you won't run into a later exception
:-), but at least it shouldn't be of the same type.

Regards,

Stan


Thomas Christensen wrote:
> My IMP-related plugins in my Eclipse RCP are a mix of versions 1.0.72,
> 1.0.73 and 3.2.72.
>
> The IMP-plugins in my Eclipse 3.2 are versions 0.1.73 and 0.1.74
>
>
Re: Unhandled event loop exception [message #571034 is a reply to message #21348] Tue, 10 June 2008 07:33 Go to previous message
Jin Missing name is currently offline Jin Missing nameFriend
Messages: 100
Registered: July 2009
Senior Member
Thomas Christensen:

java.lang.NoSuchMethodError:
org.eclipse.pde.internal.core.PluginModelManager.getAllPlugi ns()
....

seem a API-compatibility problem?

there are no problem in my 3.4RC3.

jin
Re: Unhandled event loop exception [message #571167 is a reply to message #21348] Wed, 11 June 2008 17:51 Go to previous message
Robert M. Fuhrer is currently offline Robert M. FuhrerFriend
Messages: 294
Registered: July 2009
Senior Member
Thomas Christensen wrote:
> Hi,
> I am trying to follow the guidelines in the IMP users guide (May 2008).
>
> I have sucessfully created an IMP project, but I get an error "Unhandled
> event loop exception" when I attempt to use the Language description
> wizard.
>
> ==========================================================
> Error details:
> ==========================================================
> eclipse.buildId=M20071023-1652
> java.version=1.6.0_10-beta
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=da_DK
> Command-line arguments: -os win32 -ws win32 -arch x86
> This is a continuation of log file K:\Eclipse RCP
> Workspace\.metadata\.bak_0.log
> Created Time: 2008-04-26 00:33:58.718
>
> Error
> Mon Jun 09 21:42:26 CEST 2008
> Unhandled event loop exception
>
> java.lang.NoSuchMethodError:
> org.eclipse.pde.internal.core.PluginModelManager.getAllPlugi ns()[Lorg/eclipse/pde/core/plugin/IPluginModelBase;

Is this 3.2, 3.3, or 3.4? (I can't quite tell from the build ID.)

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IMP Team Lead (http://www.eclipse.org/imp)
X10: Productivity for High-Performance Parallel Programming (http://x10.sf.net)
Re: Unhandled event loop exception [message #571255 is a reply to message #21429] Wed, 11 June 2008 20:41 Go to previous message
Thomas Christensen is currently offline Thomas ChristensenFriend
Messages: 11
Registered: July 2009
Junior Member
Hi Robert,

It was on:
Eclipse RCP
Version: 3.3.1.1
Build id: M20071023-1652

I have swtched to:
Eclipse
Version: 3.2.1
Build id: M20060921-0945

Using 3.2, I have managed to get as far as using the
“New LPG Grammar with Parser Wrapper for IMP” wizard
sucessfully, and created a lexer and parser with the
sample grammar.

So I guess it seems to be working :-)

Regards
Thomas
Re: Unhandled event loop exception [message #571277 is a reply to message #21444] Wed, 11 June 2008 23:00 Go to previous message
Stan Sutton is currently offline Stan SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
Hi Thomas,

Really you shouldn't have to move backward in your Eclipse version to
get things working (although I applaud your determination). I've been
able to run through our whole demo (multiple wizards) on Eclipse 3.3.1.1
without problems. I have an SDK installation but it has the same build
id as your RCP version.

My recollection is a bit hazy, but I believe that the method at the top
of the stack trace that you provided is one of the ones where there were
differences between 3.2 and 3.3/3.4. But those differences were
something that I thought we had reconciled.

So I guess the next question is, what version of IMP plug-ins do you
have? I'm running with 0.1.74.

Regards,

Stan

Thomas Christensen wrote:
> Hi Robert,
> It was on: Eclipse RCP Version: 3.3.1.1
> Build id: M20071023-1652
>
> I have swtched to:
> Eclipse
> Version: 3.2.1
> Build id: M20060921-0945
>
> Using 3.2, I have managed to get as far as using the
> �New LPG Grammar with Parser Wrapper for IMP� wizard
> sucessfully, and created a lexer and parser with the
> sample grammar.
>
> So I guess it seems to be working :-)
>
> Regards
> Thomas
>
Re: Unhandled event loop exception [message #571325 is a reply to message #21451] Fri, 13 June 2008 17:37 Go to previous message
Thomas Christensen is currently offline Thomas ChristensenFriend
Messages: 11
Registered: July 2009
Junior Member
My IMP-related plugins in my Eclipse RCP are a mix of versions 1.0.72,
1.0.73 and 3.2.72.

The IMP-plugins in my Eclipse 3.2 are versions 0.1.73 and 0.1.74
Re: Unhandled event loop exception [message #571428 is a reply to message #21459] Sat, 14 June 2008 13:18 Go to previous message
Stan Sutton is currently offline Stan SuttonFriend
Messages: 121
Registered: July 2009
Senior Member
Hello Thomas,

I believe that the problem that you saw on Eclipse 3.3 was due to the
use of the 3.2.72 feature. I believe that the exception that you saw
originally is due to changes in plug-in model management between 3.2 and
3.3; we had not yet addressed those in the 3.2.* releases.

I am running on both Eclipse 3.3 and 3.4 with IMP releases 0.1.73 and
0.1.74 without seeing this exception. If you can try that I think you
should get much farther than before.

Of course, I cannot guarantee that you won't run into a later exception
:-), but at least it shouldn't be of the same type.

Regards,

Stan


Thomas Christensen wrote:
> My IMP-related plugins in my Eclipse RCP are a mix of versions 1.0.72,
> 1.0.73 and 3.2.72.
>
> The IMP-plugins in my Eclipse 3.2 are versions 0.1.73 and 0.1.74
>
>
Previous Topic:Own parser
Next Topic:IMP error recovery
Goto Forum:
  


Current Time: Thu Nov 27 12:04:50 GMT 2014

Powered by FUDForum. Page generated in 0.02511 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software