Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Eclipse Ganymede doesn't automatically recompile
Eclipse Ganymede doesn't automatically recompile [message #219236] Tue, 12 August 2008 22:27
Eclipse UserFriend
Originally posted by: bill.damage.yahoo.com

I have several Eclipse projects which detect & rebuild the source on each
change. I find this really quick when running single unit tests from the
Junit panel as I don't even need to save the source first. The process of
edit | run | test again | edit is really productive. I have 1 project,
initialy created with AppFuse, for which I find this isn't happening. Yes,
I have Project | Build automatically on (for all these projects) and I
find I have to do a maven compile or maven integration-test to get the
sources to build, and only then do I see the changes reflected in the
junit tests. I can keep editing as much as I want but each time I run the
test its the state it was in when the last maven operation was run. In
case its relevant, I'm asked to save the edited file first, whereas I'mm
not asked this question in the non-Appfuse projects, but doing so makes no
difference. I'm not sure this is an AppFuse bug as now the project is set
up we are now dealing just with Eclipse settings. Can anyone spot whats
wrong please? Its a Spring/Hibernate/Struts2 archetype. Thanks.
Previous Topic:Creating a Dynamic Web project
Next Topic:Getting "error parsing site stream"
Goto Forum:
  


Current Time: Sun Dec 21 04:58:03 GMT 2014

Powered by FUDForum. Page generated in 0.01653 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software