Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Exporting an Acceleo 3.0 generator as an Eclipse Plugin
Exporting an Acceleo 3.0 generator as an Eclipse Plugin [message #1300400] Thu, 17 April 2014 14:47 Go to next message
tcl developer is currently offline tcl developerFriend
Messages: 4
Registered: April 2014
Junior Member
Hi there,

I have created a code generator based on Acceleo 3.0. I am trying now to deploy it as an Eclipse plugin in order to be able to install it on different instances, but I didn't succed.

I created a Feature project, then I added the generator projet to it then I exported as a deployable feature.

the exported feature project was installed. It contains the generator projet and the ui project (which adds a popmenu when you click right on the model to be transformed into code). When I click right on the model I want to transform , and I choose Acceleo Generate Code, The directory "src-gen" is being created, but the actual file that contains the generated code is not created.

Another detail, In the UI project there is :
IContainer target = model.getProject().getFolder("src-gen");
GenerateAll generator = new GenerateAll(modelURI, target, getArguments());
generator.doGenerate(monitor);

The directory src-gen is being created, this is why I believe the problem comes from the instruction right after it, which instanciate the generator.

Any help is appreciated.
thanks and have a nice day Smile

[Updated on: Thu, 17 April 2014 14:47]

Report message to a moderator

Re: Exporting an Acceleo 3.0 generator as an Eclipse Plugin [message #1301603 is a reply to message #1300400] Fri, 18 April 2014 07:32 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi

Firstly review this newsgroup since there have been a number of
discussions on this topic already.

If that doesn't help take a look at
https://wiki.eclipse.org/OCL/ForumNetiquette for some tips on asking a
question that might get answered.

Regards

Ed Willink

On 17/04/2014 15:47, tcl developer wrote:
> Hi there,
>
> I have created a code generator based on Acceleo 3.0. I am trying now
> to deploy it as an Eclipse plugin in order to be able to install it on
> different instances, but I didn't succed.
>
> I created a Feature project, then I added the generator projet to it
> then I exported as a deployable feature.
> the exported feature project was installed. It contains the generator
> projet and the ui project (which adds a popmenu when you click right
> on the model to be transformed into code). When I click right on the
> model I want to transform , and I choose Acceleo Generate Code, The
> directory "src-gen" is being created, but the actual file that
> contains the generated code is not created.
>
> Another detail, In the UI project there is : IContainer target =
> model.getProject().getFolder("src-gen"); GenerateAll generator = new
> GenerateAll(modelURI, target, getArguments());
> generator.doGenerate(monitor); The directory src-gen is being created,
> this is why I believe the problem comes from the instruction right
> after it, which instanciate the generator.
>
> Any help is appreciated.
> thanks and have a nice day :)
Re: Exporting an Acceleo 3.0 generator as an Eclipse Plugin [message #1301718 is a reply to message #1300400] Fri, 18 April 2014 09:02 Go to previous message
tcl developer is currently offline tcl developerFriend
Messages: 4
Registered: April 2014
Junior Member
Hi,
I read the other topics and none seems to match my problem. If you know about any particular topic in this forum that discuss this same problem, please let me know Smile.

I know that for Acceleo 2.x, you should setup an extension point if you want to export the generator as a plugin. Nevertheless, the extension point specified for Acceleo 2.x does no longer exists in Acceleo 3.x.

Also when I launch the generator with it's UI using a run configuration, it works well (the files are generated for model succesfully). But when I export those project (generator and UI ) using a Feature Project and then installed on eclipse, it just doesn't work : The directory src-gen (which is supposed to contain the generated files ) is created but the files are not.

Any help is much appreciated,

I hope the problem is clear enough.

thanks,
Previous Topic:[Acceleo] NullPointerException in org.eclipse.acceleo.ide.ui
Next Topic:[Xpand] MWE2 Workflow fails with package uri not found
Goto Forum:
  


Current Time: Thu Nov 27 12:03:10 GMT 2014

Powered by FUDForum. Page generated in 0.26656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software