Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » eclipse 3.3 Java EE patch patches to resolve NullPointerException
eclipse 3.3 Java EE patch patches to resolve NullPointerException [message #217955] Tue, 22 July 2008 13:09 Go to next message
Eclipse UserFriend
Originally posted by: pinaki29uk.gmail.com

Hi,


I was looking for patchs, which will resolve the following errors :


1. While starting the Jboss 4.2.2 GA server from within eclipse 3.3 Java
EE edition, I get the following error in the eclipse .log file:


!ENTRY org.eclipse.wst.server.core 4 0 2008-07-22 10:42:44.084
!MESSAGE Error calling delegate setupLaunchConfiguration() JBOSS 4.2
!STACK 0
java.lang.NullPointerException
at
org.eclipse.jst.server.generic.core.internal.GenericServerBe haviour.setupLaunchConfiguration(GenericServerBehaviour.java :365)
at
org.eclipse.wst.server.core.internal.Server.setupLaunchConfi guration(Server.java:1152)
at
org.eclipse.wst.server.core.internal.Server.getLaunchConfigu ration(Server.java:1195)
at org.eclipse.wst.server.core.internal.Server.start(Server.jav a:1262)
at
org.eclipse.wst.server.core.internal.Server.synchronousStart (Server.java:1662)
at
org.eclipse.wst.server.core.internal.StartServerJob.run(Star tServerJob.java:34)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

The java.net <http://java.net> forum
(http://forums.java.net/jive/thread.jspa?messageID=265371) talks about a
patch:


_http://download.eclipse.org/webtools/patches/drops/R2.0.2/P -P20080308085704-20080308085704/wtp-P-P20080308085704-200803 08085704.zip_

but this doesn't seem to exist.

============================================================ ==========

2. While trying to publish a web project I am getting the following error
in eclipse logfile (.log).


!ENTRY org.eclipse.wst.server.core 4 0 2008-07-22 12:14:19.505
!MESSAGE Could not publish to the server.
!STACK 0
java.lang.NullPointerException
at
org.eclipse.jst.server.generic.core.internal.publishers.AntP ublisher.runAnt(AntPublisher.java:299)
at
org.eclipse.jst.server.generic.core.internal.publishers.AntP ublisher.publish(AntPublisher.java:110)
at
org.eclipse.jst.server.generic.core.internal.GenericServerBe haviour.publishModule(GenericServerBehaviour.java:84)
at
org.eclipse.wst.server.core.model.ServerBehaviourDelegate.pu blishModule(ServerBehaviourDelegate.java:749)
at
org.eclipse.wst.server.core.model.ServerBehaviourDelegate.pu blishModules(ServerBehaviourDelegate.java:835)
at
org.eclipse.wst.server.core.model.ServerBehaviourDelegate.pu blish(ServerBehaviourDelegate.java:669)
at org.eclipse.wst.server.core.internal.Server.doPublish(Server .java:887)
at org.eclipse.wst.server.core.internal.Server.publish(Server.j ava:874)
at
org.eclipse.wst.server.core.internal.PublishServerJob.run(Pu blishServerJob.java:72)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Not sure which patch resolves it.


Any help will be greatly appreciated.


Thanks in advance

Pinaki
Re: eclipse 3.3 Java EE patch patches to resolve NullPointerException [message #217966 is a reply to message #217955] Tue, 22 July 2008 14:06 Go to previous message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1313
Registered: July 2009
Senior Member
The patch has been replaced by the WTP 2.0.3 maintenance release. Just
upgrade to 2.03 to get the patches. However, neither of the NPEs you
have listed match the NPE fixed by Bug 219627. I quick check of source
code shows that for both of your NPEs, the server configuration is
asking for the name of the associated JRE and is receiving null. It
looks like the JRE for this server has gotten corrupted or disconnected
in some fashion.

Cheers,
Larry

PINAKI wrote:
> Hi,
>
>
> I was looking for patchs, which will resolve the following errors :
>
>
> 1. While starting the Jboss 4.2.2 GA server from within eclipse 3.3 Java
> EE edition, I get the following error in the eclipse .log file:
>
>
> !ENTRY org.eclipse.wst.server.core 4 0 2008-07-22 10:42:44.084
> !MESSAGE Error calling delegate setupLaunchConfiguration() JBOSS 4.2
> !STACK 0
> java.lang.NullPointerException
> at
> org.eclipse.jst.server.generic.core.internal.GenericServerBe haviour.setupLaunchConfiguration(GenericServerBehaviour.java :365)
>
> at
> org.eclipse.wst.server.core.internal.Server.setupLaunchConfi guration(Server.java:1152)
>
> at
> org.eclipse.wst.server.core.internal.Server.getLaunchConfigu ration(Server.java:1195)
>
> at org.eclipse.wst.server.core.internal.Server.start(Server.jav a:1262)
> at
> org.eclipse.wst.server.core.internal.Server.synchronousStart (Server.java:1662)
>
> at
> org.eclipse.wst.server.core.internal.StartServerJob.run(Star tServerJob.java:34)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> The java.net <http://java.net> forum
> (http://forums.java.net/jive/thread.jspa?messageID=265371) talks about a
> patch:
>
>
> _http://download.eclipse.org/webtools/patches/drops/R2.0.2/P -P20080308085704-20080308085704/wtp-P-P20080308085704-200803 08085704.zip_
>
>
> but this doesn't seem to exist.
>
> ============================================================ ==========
>
> 2. While trying to publish a web project I am getting the following
> error in eclipse logfile (.log).
>
>
> !ENTRY org.eclipse.wst.server.core 4 0 2008-07-22 12:14:19.505
> !MESSAGE Could not publish to the server.
> !STACK 0
> java.lang.NullPointerException
> at
> org.eclipse.jst.server.generic.core.internal.publishers.AntP ublisher.runAnt(AntPublisher.java:299)
>
> at
> org.eclipse.jst.server.generic.core.internal.publishers.AntP ublisher.publish(AntPublisher.java:110)
>
> at
> org.eclipse.jst.server.generic.core.internal.GenericServerBe haviour.publishModule(GenericServerBehaviour.java:84)
>
> at
> org.eclipse.wst.server.core.model.ServerBehaviourDelegate.pu blishModule(ServerBehaviourDelegate.java:749)
>
> at
> org.eclipse.wst.server.core.model.ServerBehaviourDelegate.pu blishModules(ServerBehaviourDelegate.java:835)
>
> at
> org.eclipse.wst.server.core.model.ServerBehaviourDelegate.pu blish(ServerBehaviourDelegate.java:669)
>
> at org.eclipse.wst.server.core.internal.Server.doPublish(Server .java:887)
> at org.eclipse.wst.server.core.internal.Server.publish(Server.j ava:874)
> at
> org.eclipse.wst.server.core.internal.PublishServerJob.run(Pu blishServerJob.java:72)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> Not sure which patch resolves it.
>
>
> Any help will be greatly appreciated.
>
>
> Thanks in advance
>
> Pinaki
>
>
Previous Topic:Public api for org.eclipse.wst.server.core.internal.ModuleType.getModuleType
Next Topic:Seems too difficult to remove jars from web project library set?
Goto Forum:
  


Current Time: Sat Dec 20 18:09:29 GMT 2014

Powered by FUDForum. Page generated in 0.01850 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software