Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » org.apache.tools.ant.taskdefs.optional.net.FTP Not Found
org.apache.tools.ant.taskdefs.optional.net.FTP Not Found [message #217860] Sat, 19 July 2008 13:51 Go to next message
Eclipse User
Originally posted by: michael.riverwestgroup.com

On Mac OS X (10.4) using Eclipse 3.4. Java 1.5.0

I have a project originally on Eclipse 3.3 on Windows XP. I am using an
Ant build script to deploy the project to test and production servers.
The build script uses FTP to synchronize the files.

Under Windows the script runs without error (also Java 1.5). However,
when I try to run the script on Mac OS X I get the error message that
org.apache.tools.ant.taskdefs.optional.net.FTP is not found.

I have commons-net-1.4.1.jar and jakarta-oro-2.0.8.jar in my path.
Searching the newgroup et al, I can't find references to other libraries
beyond these two. What other dependency is missing? What further
diagnostic steps can I take?

thanks,
Michael
Re: org.apache.tools.ant.taskdefs.optional.net.FTP Not Found [message #217868 is a reply to message #217860] Sat, 19 July 2008 14:29 Go to previous messageGo to next message
Eclipse User
Originally posted by: michael.riverwestgroup.com

Additional information...

I just setup the project with Eclipse 3.3 on Linux OpenSUSE 10.3. I have
the same two jar files in the path. In this environment, the build works
fine.

Is there something specific to the Mac OS X environment? Is there
something specific to Ganymede? (On the Mac OS X environment, Eclipse is
version 3.4. My next test will be Eclipse 3.3 on the Macintosh.)

thanks,
Michael
Re: org.apache.tools.ant.taskdefs.optional.net.FTP Not Found [message #217876 is a reply to message #217868] Sat, 19 July 2008 21:49 Go to previous messageGo to next message
Eclipse User
Originally posted by: dcarver.starstandard.org

Michael Wohlstadter wrote:
> Additional information...
>
> I just setup the project with Eclipse 3.3 on Linux OpenSUSE 10.3. I
> have the same two jar files in the path. In this environment, the build
> works fine.
>
> Is there something specific to the Mac OS X environment? Is there
> something specific to Ganymede? (On the Mac OS X environment, Eclipse
> is version 3.4. My next test will be Eclipse 3.3 on the Macintosh.)
>

I had a similar problem on a MAC where it couldn't find the jars on the
classpath when running an ant build. I had to change the Ant instance
to launch using the Workbench's JRE instead of a separate JRE. Only had
to do this on a MAC though, haven't had to do it on any other system.

Dave
Re: org.apache.tools.ant.taskdefs.optional.net.FTP Not Found [message #217878 is a reply to message #217876] Sun, 20 July 2008 09:16 Go to previous message
Eclipse User
Originally posted by: michael.riverwestgroup.com

Dave,
Thanks for the response, all is working well now.

Michael
Previous Topic:WTP & copying project assets without redeploy
Next Topic:Running Java code for Facet validation
Goto Forum:
  


Current Time: Mon Jul 28 04:24:04 EDT 2014

Powered by FUDForum. Page generated in 0.03448 seconds