Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » TreeContainerEditPolicy commands are executed but do not appear in undo/redo stack?
TreeContainerEditPolicy commands are executed but do not appear in undo/redo stack? [message #217166] Thu, 01 June 2006 14:42 Go to next message
drew frantz is currently offline drew frantz
Messages: 340
Registered: July 2009
Senior Member
I have impl'd a TreeContainerEditPolicy for a TreeEditPart that perfoms
returns the appropritae cmd from getAddCommand. The cmd is executed fine,
but it is not shown in the undo/redo stack in eclipse.

any ideas?
Re: TreeContainerEditPolicy commands are executed but do not appear in undo/redo stack? [message #217192 is a reply to message #217166] Thu, 01 June 2006 16:01 Go to previous message
drew frantz is currently offline drew frantz
Messages: 340
Registered: July 2009
Senior Member
nevermind . Had the wrong EditDomain set for the treeviewer.

"Drew" <drew@acm.org> wrote in message
news:e5mu8f$30f$1@utils.eclipse.org...
> I have impl'd a TreeContainerEditPolicy for a TreeEditPart that perfoms
> returns the appropritae cmd from getAddCommand. The cmd is executed fine,
> but it is not shown in the undo/redo stack in eclipse.
>
> any ideas?
>
>
>
Previous Topic:redistribute gef with plugin?
Next Topic:How to determine size of parent figure based on a child label???
Goto Forum:
  


Current Time: Fri Sep 19 07:49:25 GMT 2014

Powered by FUDForum. Page generated in 0.01733 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software