Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Tomcat with SSL
Tomcat with SSL [message #216808] Fri, 04 July 2008 16:39 Go to next message
Eclipse User
Originally posted by: web-100.elephantstask.com

I did a Google search and searched the Eclipse newsgroups for a relevant
thread on this topic but I haven't seen anything that could help me with
this. I'm attempting to use SSL with Tomcat inside Eclipse and I'm having
trouble.

I've got SSL functioning with Tomcat 5.5.25 outside of Eclipse. Outside
of Eclipse, I created the Keystore file, edited the server.xml file in the
conf directory of Tomcat and started tomcat via command line. And when I
access https://localhost:8443 I see the pop up warning message, "unable to
verify localhost as a trusted site" as I would expect. I agree to accept
the certificate, I acknowledge the standard encryption warning, and I am
forwarded to the home page of tomcat where the url bar is yellow and the
lock appears. All is well.

Then I shutdown Tomcat and launch Eclipse 3.3.0. I have a web application
set up to use Tomcat. I start the server inside of eclipse, launch a new
session of the same browser, Firefox. I see that Tomcat is started and I
can view non SSL pages of my web application just fine. I attempt to
access the same page, https://localhost:8443 however, and I see a page
that says Unable to connect. Firefox can't establish a connection to the
server at localhost:8443.

What am I missing or have forgotten to do? Thanks for any feedback.
Re: Tomcat with SSL [message #216816 is a reply to message #216808] Fri, 04 July 2008 17:15 Go to previous messageGo to next message
Eclipse User
Originally posted by: cooll.free.fr

lillian wrote:
> What am I missing or have forgotten to do? Thanks for any feedback.

Did you check the server.xml file in the server project ?
My guess is that you created the server configuration before uncommenting
the ssl connector in tomcat's server.xml. The one in the server project is
maybe still commented.
Re: Tomcat with SSL [message #216832 is a reply to message #216816] Sat, 05 July 2008 00:14 Go to previous message
Eclipse User
Originally posted by: web-100.elephantstask.com

Thanks! Indeed that was it. I didn't realize that Eclipse used a
different representation of the server.xml file for Tomcat. I thought
once I edited it outside of the IDE that Eclipse would read from the same
file. But it doesn't. Good to know. Thanks for your help.
Previous Topic:JBoss Publish error on Eclipse 3.4
Next Topic:Static Web projects: where to find the features listed in the documentation?
Goto Forum:
  


Current Time: Fri Sep 19 18:03:40 GMT 2014

Powered by FUDForum. Page generated in 0.04637 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software