Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Installation of new version of Web tools
Installation of new version of Web tools [message #216392] Mon, 30 June 2008 16:33 Go to next message
Milan Milanovich is currently offline Milan Milanovich
Messages: 201
Registered: July 2009
Senior Member
Hi,

I have downloaded last year Eclipse web tools full bundle (for Eclipse
Europa):

wtp-all-in-one-sdk-R-2.0-200706260303-win32

which I have been using since then.

Is it possible now to install version 2.2 or 3.0 just by downloading .jars
from Eclipse Web Tools download site and by putting them in my existing
eclipse/plugins folder ? If not, is it possible to be done in my actual
Eclipse Europa installation ?

--
Regards, Milan
Re: Installation of new version of Web tools [message #216459 is a reply to message #216392] Tue, 01 July 2008 08:57 Go to previous messageGo to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Milan Milanovic ha scritto:
> Is it possible now to install version 2.2 or 3.0 just by downloading
> .jars from Eclipse Web Tools download site and by putting them in my
> existing eclipse/plugins folder ? If not, is it possible to be done in
> my actual Eclipse Europa installation ?

Search for updates of the currently installed feature using Help |
Software Updates from within Eclipse.

Please note that WTP 3.0 requires Eclipse 3.4 (Ganymede).

Mauro.
Re: Installation of new version of Web tools [message #216494 is a reply to message #216459] Tue, 01 July 2008 14:41 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan Milanovich
Messages: 201
Registered: July 2009
Senior Member
Hi Mauro,

when I click to search for updates in Eclipse for Eclipse Web tools,
it goes to: Contacting [China] Actuate Shanghai (http)...
and wait here, it seems that server don't work, but I cannot do anything
else ?

--
Thx, Milan

Mauro Molinari wrote:

> Milan Milanovic ha scritto:
>> Is it possible now to install version 2.2 or 3.0 just by downloading
>> .jars from Eclipse Web Tools download site and by putting them in my
>> existing eclipse/plugins folder ? If not, is it possible to be done in
>> my actual Eclipse Europa installation ?

> Search for updates of the currently installed feature using Help |
> Software Updates from within Eclipse.

> Please note that WTP 3.0 requires Eclipse 3.4 (Ganymede).

> Mauro.
Re: Installation of new version of Web tools [message #216502 is a reply to message #216494] Tue, 01 July 2008 14:48 Go to previous messageGo to next message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Milan Milanovic ha scritto:
> Hi Mauro,
>
> when I click to search for updates in Eclipse for Eclipse Web tools,
> it goes to: Contacting [China] Actuate Shanghai (http)...
> and wait here, it seems that server don't work, but I cannot do anything
> else ?

The old update manager can actually be very slow...
I can suggest you to wait or to try to select another mirror.

Go to Window | Preferences | Install/Update and uncheck "Automatically
select mirrors". Then repeat the procedure I described in my previous
post and, when Eclipse asks you to select a mirror for the WTP update
site, try to select the nearest to your location.

HTH.

Mauro.
Re: Installation of new version of Web tools [message #216518 is a reply to message #216502] Tue, 01 July 2008 16:32 Go to previous messageGo to next message
Milan Milanovich is currently offline Milan Milanovich
Messages: 201
Registered: July 2009
Senior Member
Hi Mauro,

O.K. Thank you for this. I have done it, and I tried to update, after
waiting about half an hour and selecting 5-6 mirror servers I get this:

Network connection problems encountered during search.
Unable to access
" http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml".
Unable to access site:
" http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml"
[Server returned HTTP response code: "404 Not Found" for URL:
http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.]
Server returned HTTP response code: "404 Not Found" for URL:
http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.
Unable to access site:
" http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml"
[Server returned HTTP response code: "404 Not Found" for URL:
http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.]
Server returned HTTP response code: "404 Not Found" for URL:
http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.

And complete process failed, even though I didn't have oportuinity to
select what to install ?

--
Thx, Milan Milanovic

Mauro Molinari wrote:

> Milan Milanovic ha scritto:
>> Hi Mauro,
>>
>> when I click to search for updates in Eclipse for Eclipse Web tools,
>> it goes to: Contacting [China] Actuate Shanghai (http)...
>> and wait here, it seems that server don't work, but I cannot do anything
>> else ?

> The old update manager can actually be very slow...
> I can suggest you to wait or to try to select another mirror.

> Go to Window | Preferences | Install/Update and uncheck "Automatically
> select mirrors". Then repeat the procedure I described in my previous
> post and, when Eclipse asks you to select a mirror for the WTP update
> site, try to select the nearest to your location.

> HTH.

> Mauro.
Re: Installation of new version of Web tools [message #216589 is a reply to message #216518] Wed, 02 July 2008 07:02 Go to previous message
Eclipse User
Originally posted by: mauro.molinari.cardinis.com

Milan Milanovic ha scritto:
> Hi Mauro,
>
> O.K. Thank you for this. I have done it, and I tried to update, after
> waiting about half an hour and selecting 5-6 mirror servers I get this:
>
> Network connection problems encountered during search.
> Unable to access
> " http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml".
> Unable to access site:
> " http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml"
> [Server returned HTTP response code: "404 Not Found" for URL:
> http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.]
> Server returned HTTP response code: "404 Not Found" for URL:
> http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.
> Unable to access site:
> " http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml"
> [Server returned HTTP response code: "404 Not Found" for URL:
> http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.]
> Server returned HTTP response code: "404 Not Found" for URL:
> http://download.eclipse.org/modeling/gmf/update-site/batik/s ite.xml.
>
> And complete process failed, even though I didn't have oportuinity to
> select what to install ?

Hmmmm... I'm sorry, I can just suggest you to try again, maybe selecting
other mirrors.
Otherwise, try to post a help request in eclipse.modeling.gmf newsgroup,
as it seems like the GMF project is giving you problems in the update
process.

An alternative would be to download the latest ZIP packages of WTP 2.0.2
(the latest released 2.x WTP version) from here:
http://download.eclipse.org/webtools/downloads/drops/R2.0/R- 2.0.2-20080223205547/
You can download the non-SDK package of Web Tools Platform Complete and
extract its contents so that the plugins and features subfolders in the
ZIP are unpacked inside the corresponding folders in Eclipse
installation directory.

Mauro.
Previous Topic:WST RunOnServerActionDelegate futures
Next Topic:*.jspx auto-format in Eclipse 3.2
Goto Forum:
  


Current Time: Mon Oct 20 21:20:53 GMT 2014

Powered by FUDForum. Page generated in 0.10091 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software