Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » I'm trying to use the ibmaio package and I can't seem to tell eclipse about the .so file.
I'm trying to use the ibmaio package and I can't seem to tell eclipse about the .so file. [message #215898] Mon, 23 June 2008 11:20 Go to next message
Eclipse User
Originally posted by: jim.fayettedigital.com

At least I think that's the problem.

Here's the error message:

Exception in thread "main" java.lang.UnsatisfiedLinkError: no ibmaio in
java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
at java.lang.Runtime.loadLibrary0(Runtime.java:822)

So how do I set the java.library.path? I have
/usr/local/lib/libibmaio.so. I did a ldconfig -v /usr/local/lib (even
though it is in the ld.co.conf.d list)

Partial output is:

sudo ldconfig -v /usr/local/lib
/sbin/ldconfig.real: Path `/usr/local/lib' given more than once
/sbin/ldconfig.real: Can't stat /lib64: No such file or directory
/sbin/ldconfig.real: Can't stat /usr/lib64: No such file or directory
/usr/local/lib:
libibmaio.so -> libibmaio.so
libxapian.so.15 -> libxapian.so.15.4.0

So I know that the system knows about the library, but how do I get
Eclipse to use it? I went to the project/properties/Java Build Path,
libraries tab and didn't see any entries that appeared to let me name a
system library.

I also have the same issue with another project trying to use the
libxapian.so file mentioned above.

Thanks,
Jim.
Re: I'm trying to use the ibmaio package and I can't seem to tell eclipse about the .so file. [message #216127 is a reply to message #215898] Thu, 26 June 2008 02:48 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Mon, 23 Jun 2008 07:20:20 -0400, Jim Lynch <jim@fayettedigital.com> wrote:

> At least I think that's the problem.
>
> Here's the error message:
>
> Exception in thread "main" java.lang.UnsatisfiedLinkError: no ibmaio in
> java.library.path
> at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
> at java.lang.Runtime.loadLibrary0(Runtime.java:822)
>

What Java VM are you using? My guess is there's something amiss there (but, really is a guess :)
Re: I'm trying to use the ibmaio package and I can't seem to tell eclipse about the .so file. [message #216721 is a reply to message #216127] Thu, 03 July 2008 12:55 Go to previous message
Eclipse User
Originally posted by: jim.fayettedigital.com

David Williams wrote:
> On Mon, 23 Jun 2008 07:20:20 -0400, Jim Lynch <jim@fayettedigital.com> wrote:
>
>> At least I think that's the problem.
>>
>> Here's the error message:
>>
>> Exception in thread "main" java.lang.UnsatisfiedLinkError: no ibmaio in
>> java.library.path
>> at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1682)
>> at java.lang.Runtime.loadLibrary0(Runtime.java:822)
>>
>
> What Java VM are you using? My guess is there's something amiss there (but, really is a guess :)
>
>
>
echo $JAVA_HOME
/opt/jdk1.5.0_15

Outside of Eclipse I can set LD_LIBRARY_PATH and execute a jar and it
finds the library OK. However the only way I've been able to get
Eclipse to work is add the .so file to one of the directories listed in
the java.library.path property.

I went into the project/properties menu and looked at the java
build/libraries tab. I didn't see anywhere that I could add a .so file
to anything that made sense.

Jim.
Previous Topic:IWAB0380E Error
Next Topic:SAX parser in WST?
Goto Forum:
  


Current Time: Sat Oct 25 17:34:08 GMT 2014

Powered by FUDForum. Page generated in 0.01581 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software