Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Endless rebuilding in IAM Maven Builder
Endless rebuilding in IAM Maven Builder [message #20941] Thu, 25 June 2009 00:53 Go to next message
BenH is currently offline BenH
Messages: 39
Registered: July 2009
Member
In the last few days, our project has been affected by a problem where the
IAM Maven builder continuously rebuilds the project. After each build,
which completes OK without errors, it pauses about 2 secs before the next
one starts. This continues until the IDE crashes with an out of memory
error after 30-45 mins.

Workaround: Disable auto-build. Manually build with Ctl-B as needed.

This behavior seems to be associated with a particular POM, Gmap2 from
Wicketstuff. Its happened on 2 developer machines (Eclipse 3.4.2, IAM 0.9)
and 2 different projects (our own, and gmap2-examples), the common factor
being use of the Gmap2 artefacts.

Here is the details of the open source gmap2-examples project, which shows
this behavior:

<parent>
<groupId>org.wicketstuff</groupId>
<artifactId>gmap2-parent</artifactId>
<version>1.4-SNAPSHOT</version>
</parent>

<artifactId>gmap2-examples</artifactId>
<packaging>war</packaging>

<name>GMap2 - Examples</name>
<description>Examples gmap2 component.</description>

<repositories>
<repository>
<id>org.wicketstuff</id>
<name>Wicket Stuff Repository</name>
<url>http://wicketstuff.org/maven/repository</url>
</repository>
</repositories>


Any help appreciated...
-Ben
Re: Endless rebuilding in IAM Maven Builder [message #20946 is a reply to message #20941] Thu, 25 June 2009 13:32 Go to previous messageGo to next message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
Hello Ben,

I could not reproduce the problem with that pom alone.
Can you provide the URL where I can checkout gmap2-examples?

Thanks!

Ben H wrote:
> In the last few days, our project has been affected by a problem where
> the IAM Maven builder continuously rebuilds the project. After each
> build, which completes OK without errors, it pauses about 2 secs before
> the next one starts. This continues until the IDE crashes with an out of
> memory error after 30-45 mins.
>
> Workaround: Disable auto-build. Manually build with Ctl-B as needed.
>
> This behavior seems to be associated with a particular POM, Gmap2 from
> Wicketstuff. Its happened on 2 developer machines (Eclipse 3.4.2, IAM
> 0.9) and 2 different projects (our own, and gmap2-examples), the common
> factor being use of the Gmap2 artefacts.
>
> Here is the details of the open source gmap2-examples project, which
> shows this behavior:
>
> <parent>
> <groupId>org.wicketstuff</groupId>
> <artifactId>gmap2-parent</artifactId>
> <version>1.4-SNAPSHOT</version>
> </parent>
>
> <artifactId>gmap2-examples</artifactId>
> <packaging>war</packaging>
>
> <name>GMap2 - Examples</name>
> <description>Examples gmap2 component.</description>
> <repositories>
> <repository>
> <id>org.wicketstuff</id>
> <name>Wicket Stuff Repository</name>
> <url>http://wicketstuff.org/maven/repository</url>
> </repository>
> </repositories>
>
>
> Any help appreciated...
> -Ben
>
Re: Endless rebuilding in IAM Maven Builder [message #20961 is a reply to message #20946] Mon, 29 June 2009 20:07 Go to previous messageGo to next message
BenH is currently offline BenH
Messages: 39
Registered: July 2009
Member
Hi Abel,

Thanks for looking into it my issue. Sorry for delay replay, havent been
at work last days as I work part time.

https://wicket-stuff.svn.sourceforge.net/svnroot/wicket-stuf f/trunk/wicketstuff-core/gmap2-parent/gmap2-examples

-Ben
Re: Endless rebuilding in IAM Maven Builder [message #482258 is a reply to message #20961] Tue, 25 August 2009 17:07 Go to previous messageGo to next message
Gabriel LANDON is currently offline Gabriel LANDON
Messages: 14
Registered: July 2009
Junior Member
I had the same issue with IAM, Wicket and Gmaps.
I've solve it. My project was still having the old Q4e in the classpath
(my fault!).

The way I solved it :
-in the Maven2 context menu, uncheck "use maven dependancy management"
-remove the old Q4E from the classpath (right click on the project ->
properties -> Java build path -> librairies)
-Reactivate maven for the project (check "use maven dependancy management"
in the maven2 context menu).

Hope this help.

Regards,

Gabriel.
Re: Endless rebuilding in IAM Maven Builder [message #482766 is a reply to message #482258] Thu, 27 August 2009 16:35 Go to previous messageGo to next message
Gabriel LANDON is currently offline Gabriel LANDON
Messages: 14
Registered: July 2009
Junior Member
At first I thought it was working, but a couple hours later the endless
rebuilding starts again.
I'm also using wicket (1.4.1), but not the GMaps jar.

The only solution I've found is to restart Eclipse!
Re: Endless rebuilding in IAM Maven Builder [message #482923 is a reply to message #482766] Fri, 28 August 2009 10:39 Go to previous messageGo to next message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
Hello Gabriel,

Did you follow the steps for upgrading from Q4E to IAM?
http://code.google.com/p/q4e/wiki/UpgradingToEclipseIAM

There might be some q4e plugins causing unwanted effects.

If after following the instructions it is still causing trouble, please
create a new bugzilla and attach a project pom we can use for testing.

Thanks!

Gabriel LANDON wrote:
> At first I thought it was working, but a couple hours later the endless
> rebuilding starts again.
> I'm also using wicket (1.4.1), but not the GMaps jar.
>
> The only solution I've found is to restart Eclipse!
>
>
Re: Endless rebuilding in IAM Maven Builder [message #483508 is a reply to message #482923] Tue, 01 September 2009 15:17 Go to previous message
Gabriel LANDON is currently offline Gabriel LANDON
Messages: 14
Registered: July 2009
Junior Member
Hi Abel,

I've reinstalled Eclipse (Galileo) from scratch and download the IAM
plugin (and also checksyle, subversion and hibernate tools plugins).

Everything works smoothly now. Maybe there where some leftovers from the
previous Q4e plugin.

Thank you very much for your help.

Regards,

Gabriel.
Re: Endless rebuilding in IAM Maven Builder [message #569910 is a reply to message #20941] Thu, 25 June 2009 13:32 Go to previous message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
Hello Ben,

I could not reproduce the problem with that pom alone.
Can you provide the URL where I can checkout gmap2-examples?

Thanks!

Ben H wrote:
> In the last few days, our project has been affected by a problem where
> the IAM Maven builder continuously rebuilds the project. After each
> build, which completes OK without errors, it pauses about 2 secs before
> the next one starts. This continues until the IDE crashes with an out of
> memory error after 30-45 mins.
>
> Workaround: Disable auto-build. Manually build with Ctl-B as needed.
>
> This behavior seems to be associated with a particular POM, Gmap2 from
> Wicketstuff. Its happened on 2 developer machines (Eclipse 3.4.2, IAM
> 0.9) and 2 different projects (our own, and gmap2-examples), the common
> factor being use of the Gmap2 artefacts.
>
> Here is the details of the open source gmap2-examples project, which
> shows this behavior:
>
> <parent>
> <groupId>org.wicketstuff</groupId>
> <artifactId>gmap2-parent</artifactId>
> <version>1.4-SNAPSHOT</version>
> </parent>
>
> <artifactId>gmap2-examples</artifactId>
> <packaging>war</packaging>
>
> <name>GMap2 - Examples</name>
> <description>Examples gmap2 component.</description>
> <repositories>
> <repository>
> <id>org.wicketstuff</id>
> <name>Wicket Stuff Repository</name>
> <url>http://wicketstuff.org/maven/repository</url>
> </repository>
> </repositories>
>
>
> Any help appreciated...
> -Ben
>
Re: Endless rebuilding in IAM Maven Builder [message #569981 is a reply to message #20946] Mon, 29 June 2009 20:07 Go to previous message
BenH is currently offline BenH
Messages: 39
Registered: July 2009
Member
Hi Abel,

Thanks for looking into it my issue. Sorry for delay replay, havent been
at work last days as I work part time.

https://wicket-stuff.svn.sourceforge.net/svnroot/wicket-stuf f/trunk/wicketstuff-core/gmap2-parent/gmap2-examples

-Ben
Re: Endless rebuilding in IAM Maven Builder [message #570806 is a reply to message #20961] Tue, 25 August 2009 17:07 Go to previous message
Gabriel LANDON is currently offline Gabriel LANDON
Messages: 14
Registered: July 2009
Junior Member
I had the same issue with IAM, Wicket and Gmaps.
I've solve it. My project was still having the old Q4e in the classpath
(my fault!).

The way I solved it :
-in the Maven2 context menu, uncheck "use maven dependancy management"
-remove the old Q4E from the classpath (right click on the project ->
properties -> Java build path -> librairies)
-Reactivate maven for the project (check "use maven dependancy management"
in the maven2 context menu).

Hope this help.

Regards,

Gabriel.
Re: Endless rebuilding in IAM Maven Builder [message #570957 is a reply to message #482258] Thu, 27 August 2009 16:35 Go to previous message
Gabriel LANDON is currently offline Gabriel LANDON
Messages: 14
Registered: July 2009
Junior Member
At first I thought it was working, but a couple hours later the endless
rebuilding starts again.
I'm also using wicket (1.4.1), but not the GMaps jar.

The only solution I've found is to restart Eclipse!
Re: Endless rebuilding in IAM Maven Builder [message #570967 is a reply to message #482766] Fri, 28 August 2009 10:39 Go to previous message
Abel Mui is currently offline Abel Mui
Messages: 247
Registered: July 2009
Senior Member
Hello Gabriel,

Did you follow the steps for upgrading from Q4E to IAM?
http://code.google.com/p/q4e/wiki/UpgradingToEclipseIAM

There might be some q4e plugins causing unwanted effects.

If after following the instructions it is still causing trouble, please
create a new bugzilla and attach a project pom we can use for testing.

Thanks!

Gabriel LANDON wrote:
> At first I thought it was working, but a couple hours later the endless
> rebuilding starts again.
> I'm also using wicket (1.4.1), but not the GMaps jar.
>
> The only solution I've found is to restart Eclipse!
>
>
Re: Endless rebuilding in IAM Maven Builder [message #570987 is a reply to message #482923] Tue, 01 September 2009 15:17 Go to previous message
Gabriel LANDON is currently offline Gabriel LANDON
Messages: 14
Registered: July 2009
Junior Member
Hi Abel,

I've reinstalled Eclipse (Galileo) from scratch and download the IAM
plugin (and also checksyle, subversion and hibernate tools plugins).

Everything works smoothly now. Maybe there where some leftovers from the
previous Q4e plugin.

Thank you very much for your help.

Regards,

Gabriel.
Previous Topic:IAM Installed but not active on galileo?
Next Topic:Cannot install IAM
Goto Forum:
  


Current Time: Mon Jul 28 02:24:41 EDT 2014

Powered by FUDForum. Page generated in 0.13447 seconds