Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Unable to use night build
Unable to use night build [message #20913] Sun, 18 May 2008 14:55 Go to next message
Eclipse UserFriend
Originally posted by: fab.spinelli.gmail.com

Hi all. I'm an italian student trying to port an existing project based on
Eclipse plugins onto mobile devices.
I've founded the MTJ project and downloaded the N20080430 nightly build.
I've installed a fresh Eclipse 3.3.2 and succesfully installed the MTJ
runtime plugins and future, but when I try to create a new "Midlet
Project" or "Java ME Midlet" I obtain the following error messages:
1) trying to create new "Midlet Project" ---> Plugin org.eclipse.mtj.ui
was unable ti load class
org.eclipse.mtj.ui.internal.wizards.NewJ2MEProjectWizard
2) trying to create new "Java ME Midlet" ---> Plugin org.eclipse.mtj.ui
was unable ti load class
org.eclipse.mtj.ui.internal.wizards.NewMidletWizard.

It seems that some classes are not present in the downloaded plugin and
futures.
It's a strange thing, and the two error messages seems to be "switched".

I'm also experience some trouble trying to configure preferences. If I
open the menu Windows-->Preferences and select any of the "Mobile Tools
for Java" preferences page I alway get this error message "Unable to
create the selected preference page.Reason :
org/eclipse/mtj/ui/internal/preferences/xxxPage (Unsupported major.minor
version 49.0)" where xxx is the name of the preference page I'm trying to
select.

I know this kind of error is related to installed and used JRE, but I'm
using Java 6 Update 6 Sdk and properly configured preferences for compiler
(don't know if this can help).

What's my error? Do I need to download something else? I extracted the
jar plugins and I can't find org.eclipse.mtj.ui.internal package...

Any suggest will be very appreciate, thank you so much.

(Please, sorry for my poor English :) )
Re: Unable to use night build [message #20919 is a reply to message #20913] Sun, 18 May 2008 15:21 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fab.spinelli.gmail.com

Sorry for mistake.I still obtain this error messages, but I've founded
packeage org.eclipse.mtj.ui.internal in plugin jar! And I founded the
NewJ2MEProjectWizard.class and
NewMidletWizard.class... I don't understand.

Fabrizio

F. Spinelli ha scritto:
> Hi all. I'm an italian student trying to port an existing project
> based on Eclipse plugins onto mobile devices.
> I've founded the MTJ project and downloaded the N20080430 nightly
> build. I've installed a fresh Eclipse 3.3.2 and succesfully installed
> the MTJ runtime plugins and future, but when I try to create a new
> "Midlet Project" or "Java ME Midlet" I obtain the following error
> messages:
> 1) trying to create new "Midlet Project" ---> Plugin
> org.eclipse.mtj.ui was unable ti load class
> org.eclipse.mtj.ui.internal.wizards.NewJ2MEProjectWizard
> 2) trying to create new "Java ME Midlet" ---> Plugin
> org.eclipse.mtj.ui was unable ti load class
> org.eclipse.mtj.ui.internal.wizards.NewMidletWizard.
>
> It seems that some classes are not present in the downloaded plugin
> and futures.
> It's a strange thing, and the two error messages seems to be "switched".
>
> I'm also experience some trouble trying to configure preferences. If I
> open the menu Windows-->Preferences and select any of the "Mobile
> Tools for Java" preferences page I alway get this error message
> "Unable to create the selected preference page.Reason :
> org/eclipse/mtj/ui/internal/preferences/xxxPage (Unsupported
> major.minor version 49.0)" where xxx is the name of the preference
> page I'm trying to select.
>
> I know this kind of error is related to installed and used JRE, but
> I'm using Java 6 Update 6 Sdk and properly configured preferences for
> compiler (don't know if this can help).
>
> What's my error? Do I need to download something else? I extracted the
> jar plugins and I can't find org.eclipse.mtj.ui.internal package...
>
> Any suggest will be very appreciate, thank you so much.
>
> (Please, sorry for my poor English :) )
>
Re: Unable to use night build [message #20925 is a reply to message #20919] Mon, 19 May 2008 18:02 Go to previous message
Eclipse UserFriend
Originally posted by: fab.spinelli.gmail.com

Hi MTJ guys. I've "resolved" my problem. Thanks for reading naive
questions and sorry for wasting your time. As i supposed it was a
problem with JRE, as mentioned I've installed JDK 6 Update 6 on my
system, but Eclipse continued to start with JRE 1.4! Simply add -vm
switch pointing to correct JRE path in eclipse.ini resolved the problem.
I'll open a new thread for a new ( also naive :) ) question.

Spinelli Fabrizio ha scritto:
> Sorry for mistake.I still obtain this error messages, but I've founded
> packeage org.eclipse.mtj.ui.internal in plugin jar! And I founded the
> NewJ2MEProjectWizard.class and
> NewMidletWizard.class... I don't understand.
>
> Fabrizio
>
> F. Spinelli ha scritto:
>> Hi all. I'm an italian student trying to port an existing project
>> based on Eclipse plugins onto mobile devices.
>> I've founded the MTJ project and downloaded the N20080430 nightly
>> build. I've installed a fresh Eclipse 3.3.2 and succesfully installed
>> the MTJ runtime plugins and future, but when I try to create a new
>> "Midlet Project" or "Java ME Midlet" I obtain the following error
>> messages:
>> 1) trying to create new "Midlet Project" ---> Plugin
>> org.eclipse.mtj.ui was unable ti load class
>> org.eclipse.mtj.ui.internal.wizards.NewJ2MEProjectWizard
>> 2) trying to create new "Java ME Midlet" ---> Plugin
>> org.eclipse.mtj.ui was unable ti load class
>> org.eclipse.mtj.ui.internal.wizards.NewMidletWizard.
>>
>> It seems that some classes are not present in the downloaded plugin
>> and futures.
>> It's a strange thing, and the two error messages seems to be "switched".
>>
>> I'm also experience some trouble trying to configure preferences. If
>> I open the menu Windows-->Preferences and select any of the "Mobile
>> Tools for Java" preferences page I alway get this error message
>> "Unable to create the selected preference page.Reason :
>> org/eclipse/mtj/ui/internal/preferences/xxxPage (Unsupported
>> major.minor version 49.0)" where xxx is the name of the preference
>> page I'm trying to select.
>>
>> I know this kind of error is related to installed and used JRE, but
>> I'm using Java 6 Update 6 Sdk and properly configured preferences for
>> compiler (don't know if this can help).
>>
>> What's my error? Do I need to download something else? I extracted
>> the jar plugins and I can't find org.eclipse.mtj.ui.internal package...
>>
>> Any suggest will be very appreciate, thank you so much.
>>
>> (Please, sorry for my poor English :) )
>>
Re: Unable to use night build [message #566981 is a reply to message #20913] Sun, 18 May 2008 15:21 Go to previous message
Eclipse UserFriend
Originally posted by: fab.spinelli.gmail.com

Sorry for mistake.I still obtain this error messages, but I've founded
packeage org.eclipse.mtj.ui.internal in plugin jar! And I founded the
NewJ2MEProjectWizard.class and
NewMidletWizard.class... I don't understand.

Fabrizio

F. Spinelli ha scritto:
> Hi all. I'm an italian student trying to port an existing project
> based on Eclipse plugins onto mobile devices.
> I've founded the MTJ project and downloaded the N20080430 nightly
> build. I've installed a fresh Eclipse 3.3.2 and succesfully installed
> the MTJ runtime plugins and future, but when I try to create a new
> "Midlet Project" or "Java ME Midlet" I obtain the following error
> messages:
> 1) trying to create new "Midlet Project" ---> Plugin
> org.eclipse.mtj.ui was unable ti load class
> org.eclipse.mtj.ui.internal.wizards.NewJ2MEProjectWizard
> 2) trying to create new "Java ME Midlet" ---> Plugin
> org.eclipse.mtj.ui was unable ti load class
> org.eclipse.mtj.ui.internal.wizards.NewMidletWizard.
>
> It seems that some classes are not present in the downloaded plugin
> and futures.
> It's a strange thing, and the two error messages seems to be "switched".
>
> I'm also experience some trouble trying to configure preferences. If I
> open the menu Windows-->Preferences and select any of the "Mobile
> Tools for Java" preferences page I alway get this error message
> "Unable to create the selected preference page.Reason :
> org/eclipse/mtj/ui/internal/preferences/xxxPage (Unsupported
> major.minor version 49.0)" where xxx is the name of the preference
> page I'm trying to select.
>
> I know this kind of error is related to installed and used JRE, but
> I'm using Java 6 Update 6 Sdk and properly configured preferences for
> compiler (don't know if this can help).
>
> What's my error? Do I need to download something else? I extracted the
> jar plugins and I can't find org.eclipse.mtj.ui.internal package...
>
> Any suggest will be very appreciate, thank you so much.
>
> (Please, sorry for my poor English :) )
>
Re: Unable to use night build [message #567010 is a reply to message #20919] Mon, 19 May 2008 18:02 Go to previous message
Eclipse UserFriend
Originally posted by: fab.spinelli.gmail.com

Hi MTJ guys. I've "resolved" my problem. Thanks for reading naive
questions and sorry for wasting your time. As i supposed it was a
problem with JRE, as mentioned I've installed JDK 6 Update 6 on my
system, but Eclipse continued to start with JRE 1.4! Simply add -vm
switch pointing to correct JRE path in eclipse.ini resolved the problem.
I'll open a new thread for a new ( also naive :) ) question.

Spinelli Fabrizio ha scritto:
> Sorry for mistake.I still obtain this error messages, but I've founded
> packeage org.eclipse.mtj.ui.internal in plugin jar! And I founded the
> NewJ2MEProjectWizard.class and
> NewMidletWizard.class... I don't understand.
>
> Fabrizio
>
> F. Spinelli ha scritto:
>> Hi all. I'm an italian student trying to port an existing project
>> based on Eclipse plugins onto mobile devices.
>> I've founded the MTJ project and downloaded the N20080430 nightly
>> build. I've installed a fresh Eclipse 3.3.2 and succesfully installed
>> the MTJ runtime plugins and future, but when I try to create a new
>> "Midlet Project" or "Java ME Midlet" I obtain the following error
>> messages:
>> 1) trying to create new "Midlet Project" ---> Plugin
>> org.eclipse.mtj.ui was unable ti load class
>> org.eclipse.mtj.ui.internal.wizards.NewJ2MEProjectWizard
>> 2) trying to create new "Java ME Midlet" ---> Plugin
>> org.eclipse.mtj.ui was unable ti load class
>> org.eclipse.mtj.ui.internal.wizards.NewMidletWizard.
>>
>> It seems that some classes are not present in the downloaded plugin
>> and futures.
>> It's a strange thing, and the two error messages seems to be "switched".
>>
>> I'm also experience some trouble trying to configure preferences. If
>> I open the menu Windows-->Preferences and select any of the "Mobile
>> Tools for Java" preferences page I alway get this error message
>> "Unable to create the selected preference page.Reason :
>> org/eclipse/mtj/ui/internal/preferences/xxxPage (Unsupported
>> major.minor version 49.0)" where xxx is the name of the preference
>> page I'm trying to select.
>>
>> I know this kind of error is related to installed and used JRE, but
>> I'm using Java 6 Update 6 Sdk and properly configured preferences for
>> compiler (don't know if this can help).
>>
>> What's my error? Do I need to download something else? I extracted
>> the jar plugins and I can't find org.eclipse.mtj.ui.internal package...
>>
>> Any suggest will be very appreciate, thank you so much.
>>
>> (Please, sorry for my poor English :) )
>>
Previous Topic:Unable to use night build
Next Topic:Eclipse plugins and MTJ
Goto Forum:
  


Current Time: Sat Dec 20 11:32:05 GMT 2014

Powered by FUDForum. Page generated in 0.02392 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software