Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » deployment with wtp includes no lib jars
deployment with wtp includes no lib jars [message #215036] Tue, 10 June 2008 04:55 Go to next message
Eclipse User
Originally posted by: b.v.weert.valbosoft.com

Hello,

I had my wtp working perfectly until a few days ago: I had my classes,
webapp and libs defined and when I started debugging, they all got
deployed to the temporary webapp directory and the server got started
correctly.
However, since a few days, everything gets deployed except the jars in the
lib directory. Actually, the jars that are directly placed in the
WEB-INF/lib directory ARE being deployed, but the ones defined with "" in
the .classpath aren't. These entries are like " <classpathentry
kind="var"
path="M2_REPO/javax/activation/activation/1.1/activation-1.1.jar "/>
". M2_REPO is defined and the eclipse project gives no errors.
Not only for one project; no project gets deployed correctly anymore.
I've downloaded a new eclipse installation to see if it was a plugin
mixup; no success. I created a new workspace and loaded an existing
project; no success.

The problem seems to be with "var" entries.

I'm a bit out of ideas on how to debug this issue. Any ideas?

Cheers, Bo
Re: deployment with wtp includes no lib jars [message #215093 is a reply to message #215036] Wed, 11 June 2008 06:06 Go to previous message
Eclipse User
Originally posted by: b.v.weert.valbosoft.com

I'm a step further now: to get published, the
settings/org.eclipse.wst.common.component needs entries like:
<dependent-module archiveName="chartengineapi-2.2.2.jar"
deploy-path="/WEB-INF/lib"
handle=" module:/classpath/var/M2_REPO/org/eclipse/birt/chartengineap i/2.2.2/chartengineapi-2.2.2.jar ">
<dependency-type>uses</dependency-type>
</dependent-module>

When I generate these with maven2 they get deployed. However, as soon as I
do a refresh of the project, all "var" entries disappear...

Any explanation for this?

Regards, Bo
Previous Topic:Get an Entity fields
Next Topic:Adding an EJB 3.0 to DD
Goto Forum:
  


Current Time: Wed Jul 23 18:29:06 EDT 2014

Powered by FUDForum. Page generated in 0.01655 seconds