Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » localhost:8080 absent if server is in eclipse
localhost:8080 absent if server is in eclipse [message #214528] Thu, 29 May 2008 18:03 Go to next message
Vinay is currently offline Vinay
Messages: 36
Registered: July 2009
Member
Hello Group,

If I start my tomcat server in eclipse then the default page

http://localhost:8080/

gives 404 status error on IE and Firefox on my Windows platform. It does
display the newly created web application, which follows the server path

http://localhost:8080/WTP-Tutorial-1/snoop

I am using elcipse J2EE 3.3 version.

However, if I start the server from command line, then the default page
displays on both browsers.

Why do browsers not recognize the server and/or port if the server starts
from eclipse.

Please explain.

Thanks.

nagrik
Re: localhost:8080 absent if server is in eclipse [message #214552 is a reply to message #214528] Thu, 29 May 2008 19:29 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1305
Registered: July 2009
Senior Member
Nagrik wrote:
> Hello Group,
>
> If I start my tomcat server in eclipse then the default page
> http://localhost:8080/
>
> gives 404 status error on IE and Firefox on my Windows platform. It
> does display the newly created web application, which follows the server
> path
>
> http://localhost:8080/WTP-Tutorial-1/snoop
>
> I am using elcipse J2EE 3.3 version.
>
> However, if I start the server from command line, then the default page
> displays on both browsers.
>
> Why do browsers not recognize the server and/or port if the server
> starts from eclipse.
>
> Please explain.
>
> Thanks.
>
> nagrik
>

See this question in the WTP Tomcat FAQ:

http://wiki.eclipse.org/WTP_Tomcat_FAQ#If_I_start_my_Tomcat_ server_and_try_to_display_Tomcat.27s_default_page.2C_why_do_ I_see_a_directory_listing_or_404_error_page.3F

Cheers,
Larry
Re: localhost:8080 absent if server is in eclipse [message #214558 is a reply to message #214552] Thu, 29 May 2008 20:18 Go to previous message
Vinay is currently offline Vinay
Messages: 36
Registered: July 2009
Member
Thank you Larry.

nagrik
Previous Topic:How to make Eclipse put jars into WEB-INF/lib?
Next Topic:Web project does not start
Goto Forum:
  


Current Time: Fri Sep 19 01:57:24 GMT 2014

Powered by FUDForum. Page generated in 0.12089 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software