Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » Old XSD for compendium in Blueprint 2.0.0.M02
Old XSD for compendium in Blueprint 2.0.0.M02 [message #1284172] Fri, 04 April 2014 06:56 Go to next message
Mickael Marrache is currently offline Mickael Marrache
Messages: 7
Registered: February 2014
Junior Member
Hi,

I tried to use the update-strategy feature as explained in the documentation and I get the following error at execution:

2014-04-03 18:38:35,290 | ERROR | ExtenderThread-6 | WaiterApplicationContextExecutor|16 - org.eclipse.gemini.blueprint.extender - 2.0.0.M02 | Unable to create application context for [com.mycompany.app], unsatisfied dependencies: none
org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 21 in XML document from URL [bundle://37.7:0/META-INF/spring/osgi-context.xml] is invalid; nested exception is org.xml.sax.SAXParseException; lineNumber: 21; columnNumber: 138; cvc-complex-type.3.2.2: Attribute 'update-strategy' is not allowed to appear
in element 'osgix:managed-properties'.


It seems that the XSD shipped in the Gemini Blueprint distributables is the old one (i.e. spring-osgi-compendium-2.0.xsd).

Mickael

[Updated on: Fri, 04 April 2014 06:56]

Report message to a moderator

Re: Old XSD for compendium in Blueprint 2.0.0.M02 [message #1288686 is a reply to message #1284172] Tue, 08 April 2014 19:43 Go to previous messageGo to next message
Dmitry Sklyut is currently offline Dmitry Sklyut
Messages: 272
Registered: January 2010
Senior Member
Hi,
Can you provide your xml config including namespaces used?

Thanks
Dmitry
Re: Old XSD for compendium in Blueprint 2.0.0.M02 [message #1312485 is a reply to message #1288686] Thu, 24 April 2014 10:12 Go to previous message
Mickael Marrache is currently offline Mickael Marrache
Messages: 7
Registered: February 2014
Junior Member
<beans:beans xmlns="http://www.eclipse.org/gemini/blueprint/schema/blueprint"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:beans="http://www.springframework.org/schema/beans"
	xmlns:context="http://www.springframework.org/schema/context" xmlns:osgix="http://www.springframework.org/schema/osgi-compendium"
	xsi:schemaLocation="http://www.eclipse.org/gemini/blueprint/schema/blueprint http://www.eclipse.org/gemini/blueprint/schema/blueprint/gemini-blueprint.xsd
		http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.2.xsd
		http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-3.2.xsd
		http://www.springframework.org/schema/osgi-compendium http://www.springframework.org/schema/osgi-compendium/spring-osgi-compendium-2.0-m1.xsd">
		
	<!-- Declare the service exported by this bundle. -->
	
	<beans:bean id="myServiceImpl" class="com.example.myservice.impl.MyServiceImpl">
		<osgix:managed-properties persistent-id="com.example.myservice" update-strategy="bean-managed" update-method="updateConfig" />
	</beans:bean>
	
	<!-- Export the new service. -->
	
	<service ref="myServiceImpl" interface="com.example.myservice.api.MyService" />

</beans:beans>


Mickael
Previous Topic:Weaving and early bundle activation
Next Topic:issues reading classpath resources using Spring and Karaf
Goto Forum:
  


Current Time: Mon Sep 22 04:20:16 GMT 2014

Powered by FUDForum. Page generated in 0.01922 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software