Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Axis2 code generation dialog borked!
Axis2 code generation dialog borked! [message #214482] Thu, 29 May 2008 10:34 Go to next message
Michael Marconi is currently offline Michael MarconiFriend
Messages: 4
Registered: July 2009
Junior Member
I'm using the WTP plugins to generate Axis2 code from WSDL contracts.
This works perfectly the first time I create any new Dynamic Web Project
and opt to generate a new Web Service from the WSDL definition.

Unfortunately, future attempts to regenerate the code (using Generate Java
bean skeleton command) fail: The wizard page entitled 'Axis2 Web Service
skeleton Java Bean Configuration' always comes up empty, i.e. none of the
drop-downs offer any options. Pressing Next leads to a NPE.

The only work-around I have found is to create a new Dynamic Web Project
and a new WSDL document and then invoke the code generation wizard again.
I see a message (too fast to capture accurately) that says something like
'Installing Axis2 web project facet' and then the wizard page comes up
with the correct options in the drop-down boxes.

At this point, I can return to the original web service WSDL definition
and regenerate the code perfectly.

This is obviously time-consuming and annoying. It would seem that some
project facet state is being set up in memory and never persisted properly.

Any ideas how we could fix this?
Re: Axis2 code generation dialog borked! [message #214608 is a reply to message #214482] Fri, 30 May 2008 20:34 Go to previous message
Kathy Chan is currently offline Kathy ChanFriend
Messages: 93
Registered: July 2009
Member
Hi Michael,

I used the WTP 3.0 05/23 driver and was able to run Axis2 Generate Java
skeleton multiple times without running into the problem you are reporting.
Please open a bugzilla on the jst.ws component if you are still seeing this
problem. Please be specific on which driver you are using and the exact
steps to reproduce the problem. Do you get any error in .log file when you
see this problem?

Regards,

Kathy Chan

"Michael Marconi" <michael.marconi@trafigura.com> wrote in message
news:1a4b866f977be6f3b1c842db25f85047$1@www.eclipse.org...
> I'm using the WTP plugins to generate Axis2 code from WSDL contracts.
> This works perfectly the first time I create any new Dynamic Web Project
> and opt to generate a new Web Service from the WSDL definition.
>
> Unfortunately, future attempts to regenerate the code (using Generate Java
> bean skeleton command) fail: The wizard page entitled 'Axis2 Web Service
> skeleton Java Bean Configuration' always comes up empty, i.e. none of the
> drop-downs offer any options. Pressing Next leads to a NPE.
>
> The only work-around I have found is to create a new Dynamic Web Project
> and a new WSDL document and then invoke the code generation wizard again.
> I see a message (too fast to capture accurately) that says something like
> 'Installing Axis2 web project facet' and then the wizard page comes up
> with the correct options in the drop-down boxes.
>
> At this point, I can return to the original web service WSDL definition
> and regenerate the code perfectly.
>
> This is obviously time-consuming and annoying. It would seem that some
> project facet state is being set up in memory and never persisted
> properly.
>
> Any ideas how we could fix this?
>
Previous Topic:Changing "“Always use this server..." option
Next Topic:EJB3|Schemaexport
Goto Forum:
  


Current Time: Sun Dec 21 07:05:48 GMT 2014

Powered by FUDForum. Page generated in 0.14999 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software