Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Importing WAR file sets Java compiler compliance level to 1.4
Importing WAR file sets Java compiler compliance level to 1.4 [message #213577] Fri, 09 May 2008 22:50
Eclipse UserFriend
Originally posted by: guruji323.hotmail.com

Is there a way to make it set the compliance level to 5?
By setting it to 1.4, a full build is kicked off which we don't want to
happen. Plus Java 5 constructs throw errors.

The file org.eclipse.jdt.core.prefs that gets created in the .settings
folder contains the line
org.eclipse.jdt.core.compiler.compliance=1.4

This file is automatically created by the import WAR process which I am
invoking programmatically. Is there a way to ask it to create this file
with a 5 level?

Appreciate any insight.

Thanks,
Satish
Previous Topic:JSR-181 Web Service Client
Next Topic:connect websphere 6.1 from Eclipse SDK 3.4.0
Goto Forum:
  


Current Time: Sat Nov 22 14:28:47 GMT 2014

Powered by FUDForum. Page generated in 0.01629 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software