Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Re: WTP project
Re: WTP project [message #213066] Tue, 29 April 2008 10:43 Go to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------000703080703000707080102
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Irene,

I've added the WTP newsgroup to the "to" list of the reply since it's
more likely you'll get WTP-specific help there. Perhaps the WTP folks
have a document like this EMF one
<http://wiki.eclipse.org/EMF/Getting_Source>

http://wiki.eclipse.org/EMF/Getting_Source

Or maybe one of the developers can export a team project set that you
could use to extract all the right things...


irene wrote:
> Hi!
>
> I am an absolute beginner in Eclipse but I have to do a project for my
> university... I have to improve the WSDL editor of the WTP package.
>
> I try to download from the CVS Server all the file related but they
> have a lot of errors...
> I'm not sure if I downloaded all the directories related...
> To test the plug in is it better if I use Eclipse IDE for Java EE
> Developers (but here the editor is just included) or a classical version?
>
> Thanks for help!
>
> Irene
>
>


--------------000703080703000707080102
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Irene,<br>
<br>
I've added the WTP newsgroup to the "to" list of the reply since it's
more likely you'll get WTP-specific help there.
Re: WTP project [message #213080 is a reply to message #213066] Tue, 29 April 2008 13:31 Go to previous messageGo to next message
Eclipse User
Originally posted by: codeslave.ca.ibm.com

Irene:

Read this:

http://www.eclipse.org/webtools/faq/CommitterFAQ.php#general _3

And use this:

http://www.eclipse.org/webtools/development/team_project_set /wtp.psf

N


Ed Merks wrote:
> Irene,
>
> I've added the WTP newsgroup to the "to" list of the reply since it's
> more likely you'll get WTP-specific help there. Perhaps the WTP folks
> have a document like this EMF one
> <http://wiki.eclipse.org/EMF/Getting_Source>
>
> http://wiki.eclipse.org/EMF/Getting_Source
>
> Or maybe one of the developers can export a team project set that you
> could use to extract all the right things...
>
>
> irene wrote:
>> Hi!
>>
>> I am an absolute beginner in Eclipse but I have to do a project for my
>> university... I have to improve the WSDL editor of the WTP package.
>>
>> I try to download from the CVS Server all the file related but they
>> have a lot of errors...
>> I'm not sure if I downloaded all the directories related...
>> To test the plug in is it better if I use Eclipse IDE for Java EE
>> Developers (but here the editor is just included) or a classical version?
>>
>> Thanks for help!
>>
>> Irene
>>
>>
>
Re: WTP project [message #213088 is a reply to message #213080] Tue, 29 April 2008 17:36 Go to previous messageGo to next message
Eclipse User
Originally posted by: irenerigon.gmail.com

Thank for help!

I have download the wtp.psf file and I tried to checkout the project
sources from CVS and encountered the following error:

The server reported an error while performing the "cvs expand-modules"
command.
: cvs server: cannot find module
`jst/components/common/plugins/org.eclipse.jst.common.annota tions.controller'
- ignored

And then it stops there and then and I cannot continue the checkout.

Any ideas?Thanks in advance,

Irene
Re: WTP project [message #213101 is a reply to message #213088] Tue, 29 April 2008 18:48 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2234
Registered: July 2009
Senior Member
irene wrote:
> I have download the wtp.psf file and I tried to checkout the project
> sources from CVS and encountered the following error:
> The server reported an error while performing the "cvs expand-modules"
> command.
> : cvs server: cannot find module
> `jst/components/common/plugins/org.eclipse.jst.common.annota tions.controller'
> - ignored
>
> And then it stops there and then and I cannot continue the checkout.
>
> Any ideas?Thanks in advance,

That file was created in 2005, and we've restructured quite a bit
since then. I've updated, please retry it. Be aware, though, that
there are close to 300 projects imported from that monolithic file.
You might want to edit it down, by hand, before importing it.

--
---
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: WTP project [message #213109 is a reply to message #213101] Tue, 29 April 2008 21:10 Go to previous messageGo to next message
Eclipse User
Originally posted by: codeslave.ca.ibm.com

I don't suppose I could push my luck and ask that you chop the monolith
into smaller pieces? One per subproject, perhaps?

Nick

Nitin Dahyabhai wrote:
> irene wrote:
>> I have download the wtp.psf file and I tried to checkout the project
>> sources from CVS and encountered the following error:
>> The server reported an error while performing the "cvs expand-modules"
>> command.
>> : cvs server: cannot find module
>> `jst/components/common/plugins/org.eclipse.jst.common.annota tions.controller'
>> - ignored
>>
>> And then it stops there and then and I cannot continue the checkout.
>>
>> Any ideas?Thanks in advance,
>
> That file was created in 2005, and we've restructured quite a bit since
> then. I've updated, please retry it. Be aware, though, that there are
> close to 300 projects imported from that monolithic file. You might
> want to edit it down, by hand, before importing it.
>
Re: WTP project [message #213125 is a reply to message #213109] Thu, 01 May 2008 05:35 Go to previous messageGo to next message
Eclipse User
Originally posted by: irenerigon.gmail.com

I chopped the monolith into smaller pieces:

<psf version="2.0">
&#8722;
<provider id="org.eclipse.team.cvs.core.cvsnature">
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl,org.eclipse.wst.wsdl "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl.validation,org.eclipse.w st.wsdl.validation "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsi/plugins/org.eclipse.wst.wsi,org.eclipse.wst.wsi "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests,org.eclipse.wst.wsdl .tests "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests.ui,org.eclipse.wst.w sdl.tests.ui "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.validation.tests,org.eclip se.wst.wsdl.validation.tests "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsi/tests/org.eclipse.wst.wsi.tests,org.eclipse.wst.wsi.te sts "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests.performance,org.ecli pse.wst.wsdl.tests.performance "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/ws/plugins/org.eclipse.wst.ws.ui,org.eclipse.wst.ws.ui "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/ws/plugins/org.eclipse.wst.ws.explorer,org.eclipse.wst.ws. explorer "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl.ui,org.eclipse.wst.wsdl. ui "/>
</provider>
</psf>

But the error is the same...

I would modify the WSDL editor but it seems impossible!!I am demoralized...

Thanks for help!

IRene
Re: WTP project [message #213132 is a reply to message #213109] Thu, 01 May 2008 05:44 Go to previous messageGo to next message
Eclipse User
Originally posted by: irenerigon.gmail.com

I have chopped the monolith file into smaller pieces:

&#8722;
<psf version="2.0">
&#8722;
<provider id="org.eclipse.team.cvs.core.cvsnature">
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl,org.eclipse.wst.wsdl "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl.validation,org.eclipse.w st.wsdl.validation "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsi/plugins/org.eclipse.wst.wsi,org.eclipse.wst.wsi "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests,org.eclipse.wst.wsdl .tests "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests.ui,org.eclipse.wst.w sdl.tests.ui "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.validation.tests,org.eclip se.wst.wsdl.validation.tests "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsi/tests/org.eclipse.wst.wsi.tests,org.eclipse.wst.wsi.te sts "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests.performance,org.ecli pse.wst.wsdl.tests.performance "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/ws/plugins/org.eclipse.wst.ws.ui,org.eclipse.wst.ws.ui "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/ws/plugins/org.eclipse.wst.ws.explorer,org.eclipse.wst.ws. explorer "/>
<project
reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl.ui,org.eclipse.wst.wsdl. ui "/>
</provider>
</psf>

But the error is the same... I begin to be demoralized...

I would modify the WSDL editor but I'm not sure about which file I have to
donwload.

Thanks for help,

Irene
Re: WTP project [message #213162 is a reply to message #213132] Thu, 01 May 2008 07:17 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------030703040900000907010504
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Irene,

There are few things I find more frustrating than someone wanting to
contribute but is demoralized when trying to get started. I've attached
a small psf for the project's you're interested in. It seems that
plugins mentioned below don't release exist at the locations given below
so I would suggest that the WTP team consider updating this file for
their contributors.

In any case, these extracted projects don't compile for me because they
have dependencies on whack of other plugins. However, I'm pretty sure
if you install the latest WTP in your IDE (perhaps using the EE Ganymede
package, but these are a few weeks old now
http://www.eclipse.org/downloads/packages/ ), the extracted plugins in
the psf should compile against the plugins in the IDE. If not, you can
always go the the CVS repository explorer and add the missing plugins
(look at each MANIFEST.MF to see which plugin dependencies are marked red).

If you're still stuck, don't be afraid to ask for more help.


irene wrote:
> I have chopped the monolith file into smaller pieces:
>
> &#8722;
> <psf version="2.0">
> &#8722;
> <provider id="org.eclipse.team.cvs.core.cvsnature">
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl,org.eclipse.wst.wsdl "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl.validation,org.eclipse.w st.wsdl.validation "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsi/plugins/org.eclipse.wst.wsi,org.eclipse.wst.wsi "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests,org.eclipse.wst.wsdl .tests "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests.ui,org.eclipse.wst.w sdl.tests.ui "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.validation.tests,org.eclip se.wst.wsdl.validation.tests "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsi/tests/org.eclipse.wst.wsi.tests,org.eclipse.wst.wsi.te sts "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/tests/org.eclipse.wst.wsdl.tests.performance,org.ecli pse.wst.wsdl.tests.performance "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/ws/plugins/org.eclipse.wst.ws.ui,org.eclipse.wst.ws.ui "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/ws/plugins/org.eclipse.wst.ws.explorer,org.eclipse.wst.ws. explorer "/>
>
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl.ui,org.eclipse.wst.wsdl. ui "/>
>
> </provider>
> </psf>
>
> But the error is the same... I begin to be demoralized...
>
> I would modify the WSDL editor but I'm not sure about which file I
> have to donwload.
>
> Thanks for help,
>
> Irene
>


--------------030703040900000907010504
Content-Type: text/xml;
name="wtp.psf"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
filename="wtp.psf"

PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4NCjxwc2Yg dmVyc2lvbj0i
Mi4wIj4NCjxwcm92aWRlciBpZD0ib3JnLmVjbGlwc2UudGVhbS5jdnMuY29y ZS5jdnNuYXR1
cmUiPg0KPHByb2plY3QgcmVmZXJlbmNlPSIxLjAsOnBzZXJ2ZXI6ZGV2LmVj bGlwc2Uub3Jn
Oi9jdnNyb290L3dlYnRvb2xzLHdlYnNlcnZpY2VzL3BsdWdpbnMvb3JnLmVj bGlwc2Uud3N0
LndzLG9yZy5lY2xpcHNlLndzdC53cyIvPg0KPHByb2plY3QgcmVmZXJlbmNl PSIxLjAsOnBz
ZXJ2ZXI6ZGV2LmVjbGlwc2Uub3JnOi9jdnNyb290L3dlYnRvb2xzLHdlYnNl cnZpY2VzL3Bs
dWdpbnMvb3JnLmVjbGlwc2Uud3N0LndzLmV4cGxvcmVyLG9yZy5lY2xpcHNl LndzdC53cy5l
eHBsb3JlciIvPg0KPHByb2plY3QgcmVmZXJlbmNlPSIxLjAsOnBzZXJ2ZXI6 ZGV2LmVjbGlw
c2Uub3JnOi9jdnNyb290L3dlYnRvb2xzLHdlYnNlcnZpY2VzL2RvY3Mvb3Jn LmVjbGlwc2Uu
d3N0LndzLmluZm9wb3Asb3JnLmVjbGlwc2Uud3N0LndzLmluZm9wb3AiLz4N Cjxwcm9qZWN0
IHJlZmVyZW5jZT0iMS4wLDpwc2VydmVyOmRldi5lY2xpcHNlLm9yZzovY3Zz cm9vdC93ZWJ0
b29scyx3ZWJzZXJ2aWNlcy9wbHVnaW5zL29yZy5lY2xpcHNlLndzdC53cy5w YXJzZXIsb3Jn
LmVjbGlwc2Uud3N0LndzLnBhcnNlciIvPg0KPHByb2plY3QgcmVmZXJlbmNl PSIxLjAsOnBz
ZXJ2ZXI6ZGV2LmVjbGlwc2Uub3JnOi9jdnNyb290L3dlYnRvb2xzLHdlYnNl cnZpY2VzL3Rl
c3RzL29yZy5lY2xpcHNlLndzdC53cy50ZXN0cyxvcmcuZWNsaXBzZS53c3Qu d3MudGVzdHMi
Lz4NCjxwcm9qZWN0IHJlZmVyZW5jZT0iMS4wLDpwc2VydmVyOmRldi5lY2xp cHNlLm9yZzov
Y3Zzcm9vdC93ZWJ0b29scyx3ZWJzZXJ2aWNlcy9wbHVnaW5zL29yZy5lY2xp cHNlLndzdC53
cy51aSxvcmcuZWNsaXBzZS53c3Qud3MudWkiLz4NCjxwcm9qZWN0IHJlZmVy ZW5jZT0iMS4w
LDpwc2VydmVyOmRldi5lY2xpcHNlLm9yZzovY3Zzcm9vdC93ZWJ0b29scyx3 ZWJzZXJ2aWNl
cy9wbHVnaW5zL29yZy5lY2xpcHNlLndzdC53c2RsLG9yZy5lY2xpcHNlLndz dC53c2RsIi8+
DQo8cHJvamVjdCByZWZlcmVuY2U9IjEuMCw6cHNlcnZlcjpkZXYuZWNsaXBz ZS5vcmc6L2N2
c3Jvb3Qvd2VidG9vbHMsd2Vic2VydmljZXMvdGVzdHMvb3JnLmVjbGlwc2Uu d3N0LndzZGwu
dGVzdHMsb3JnLmVjbGlwc2Uud3N0LndzZGwudGVzdHMiLz4NCjxwcm9qZWN0 IHJlZmVyZW5j
ZT0iMS4wLDpwc2VydmVyOmRldi5lY2xpcHNlLm9yZzovY3Zzcm9vdC93ZWJ0 b29scyx3ZWJz
ZXJ2aWNlcy90ZXN0cy9vcmcuZWNsaXBzZS53c3Qud3NkbC50ZXN0cy51aSxv cmcuZWNsaXBz
ZS53c3Qud3NkbC50ZXN0cy51aSIvPg0KPHByb2plY3QgcmVmZXJlbmNlPSIx LjAsOnBzZXJ2
ZXI6ZGV2LmVjbGlwc2Uub3JnOi9jdnNyb290L3dlYnRvb2xzLHdlYnNlcnZp Y2VzL3BsdWdp
bnMvb3JnLmVjbGlwc2Uud3N0LndzZGwudWksb3JnLmVjbGlwc2Uud3N0Lndz ZGwudWkiLz4N
Cjxwcm9qZWN0IHJlZmVyZW5jZT0iMS4wLDpwc2VydmVyOmRldi5lY2xpcHNl Lm9yZzovY3Zz
cm9vdC93ZWJ0b29scyx3ZWJzZXJ2aWNlcy9wbHVnaW5zL29yZy5lY2xpcHNl LndzdC53c2Rs
LnZhbGlkYXRpb24sb3JnLmVjbGlwc2Uud3N0LndzZGwudmFsaWRhdGlvbiIv Pg0KPHByb2pl
Y3QgcmVmZXJlbmNlPSIxLjAsOnBzZXJ2ZXI6ZGV2LmVjbGlwc2Uub3JnOi9j dnNyb290L3dl
YnRvb2xzLHdlYnNlcnZpY2VzL3Rlc3RzL29yZy5lY2xpcHNlLndzdC53c2Rs LnZhbGlkYXRp
b24udGVzdHMsb3JnLmVjbGlwc2Uud3N0LndzZGwudmFsaWRhdGlvbi50ZXN0 cyIvPg0KPHBy
b2plY3QgcmVmZXJlbmNlPSIxLjAsOnBzZXJ2ZXI6ZGV2LmVjbGlwc2Uub3Jn Oi9jdnNyb290
L3dlYnRvb2xzLHdlYnNlcnZpY2VzL3BsdWdpbnMvb3JnLmVjbGlwc2Uud3N0 LndzaSxvcmcu
ZWNsaXBzZS53c3Qud3NpIi8+DQo8cHJvamVjdCByZWZlcmVuY2U9IjEuMCw6 cHNlcnZlcjpk
ZXYuZWNsaXBzZS5vcmc6L2N2c3Jvb3Qvd2VidG9vbHMsd2Vic2VydmljZXMv dGVzdHMvb3Jn
LmVjbGlwc2Uud3N0LndzaS50ZXN0cyxvcmcuZWNsaXBzZS53c3Qud3NpLnRl c3RzIi8+DQo8
cHJvamVjdCByZWZlcmVuY2U9IjEuMCw6cHNlcnZlcjpkZXYuZWNsaXBzZS5v cmc6L2N2c3Jv
b3Qvd2VidG9vbHMsd2Vic2VydmljZXMvcGx1Z2lucy9vcmcuZWNsaXBzZS53 c3Qud3NpLnVp
LG9yZy5lY2xpcHNlLndzdC53c2kudWkiLz4NCjwvcHJvdmlkZXI+DQo8L3Bz Zj4=
--------------030703040900000907010504--
Re: WTP project [message #213191 is a reply to message #213125] Thu, 01 May 2008 11:25 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2234
Registered: July 2009
Senior Member
irene wrote:
> I chopped the monolith into smaller pieces:
>
> <psf version="2.0">
> &#8722;
> <provider id="org.eclipse.team.cvs.core.cvsnature">
> <project
> reference=" 1.0,:pserver:dev.eclipse.org:/cvsroot/webtools,wst/component s/wsdl/plugins/org.eclipse.wst.wsdl,org.eclipse.wst.wsdl "/>

This looks like parts of the older version of the file--did you
update "the monolith" before cutting it down? Maybe your browser
was caching it?

--
---
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: WTP project [message #213792 is a reply to message #213191] Wed, 14 May 2008 03:41 Go to previous message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Thu, 01 May 2008 11:25:37 -0400, Nitin Dahyabhai <nitind@us.ibm.com> wrote:

irene, let's go back to some basics, first, and then to back to the source code.

Have you actually got a version of WTP up and running yet? That should be your first step.
And doing that successfull means you at least have all the right pre-reqs, etc.
And, you should always look for the "SDK" version to install. You probably only need wst-sdk
and all it's pre-reqs, of course.

Then, just having the SDK there gives you all the source, and you can tweak it, to change behavior, etc.

(Or, better yet, there's probably ways you can improve the editor, wihtout changing the editor code, but by writing your own plugins, that "extend" some functionality of the editor, and you don't need to modify the editor code at all. For example, you can add some context menus very easily.

I'll stop here, in case I'm way off base and you already kmow all of the above.

HTH
Previous Topic:Eclipse+WTP 3.4M7 startup trouble!?
Next Topic:Eclipse + JBoss Debug Mode issue
Goto Forum:
  


Current Time: Thu Jul 24 19:06:54 EDT 2014

Powered by FUDForum. Page generated in 0.01955 seconds