Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » [BUG] After newest update I cannot store credentials...
[BUG] After newest update I cannot store credentials... [message #1277660] Wed, 26 March 2014 09:38 Go to next message
Lukasz T. is currently offline Lukasz T.
Messages: 3
Registered: March 2014
Junior Member
I've updated Egit plugin today with all it's connected components through Eclipse software update (alongside Android updates, but I doubt it's connected to git/egit) and now everytime I do pull/push/fetch it keeps asking me for credentials over and over again, despite them being stored in secure storage.

Previously (which didn't have this problem) I had:
Eclipse Git Team Provider 3.3.0.201403021825-r

Currently I have
Eclipse Git Team Provider 3.3.1.201403241930-r

I have same config at home (pre-update), so I will confirm later, that over there, there is no problem.

If it is not EGit related, but you know where should I direct my problem, please refer me to such place.
Re: [BUG] After newest update I cannot store credentials... [message #1278023 is a reply to message #1277660] Wed, 26 March 2014 20:13 Go to previous messageGo to next message
Lukasz T. is currently offline Lukasz T.
Messages: 3
Registered: March 2014
Junior Member
Just checked and confirmed my suspicions.

My Home station setup works perfectly, as long as I do not update the EGit plugin (if I update anything else, like the newest Android ADT plugin all works well).

I made a clone of Eclipse folder priorly, and checked it couple times.

As soon as I update EGit plugin the first pull I do, everything works as expected, but the second and everyone afterwards, I get popup asking for credentials, and even though I check the checkbox to store credentials in secure storage, the popup keeps showing everytime I do any remote operation.

I also copied the Eclipse folder with previous config to my notebook, and the problem went away, so I eliminated the notebook/OS issue here.

Some further information:
1) I'm using Eclipse 3.8.2
2) Windows 7 x64
3) (If it matters) I'm using Team Foundation Server (Microsoft's TFS) repository
Re: [BUG] After newest update I cannot store credentials... [message #1278024 is a reply to message #1277660] Wed, 26 March 2014 20:14 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 324
Registered: July 2009
Senior Member
Lukasz T. skrev 2014-03-26 13.31:
> I've updated Egit plugin today with all it's connected components through Eclipse software update (alongside Android updates, but I doubt it's connected to git/egit) and
> now everytime I do pull/push/fetch it keeps asking me for credentials over and over again, despite them being stored in secure storage.
>
> Previously (which didn't have this problem) I had:
> Eclipse Git Team Provider 3.3.0.201403021825-r
>
> Currently I have
> Eclipse Git Team Provider 3.3.1.201403241930-r
>
> I have same config at home (pre-update), so I will confirm later, that over there, there is no problem.
>
> If it is not EGit related, but you know where should I direct my problem, please refer me to such place.

There were some supposed bug fixes for credentials in 3.3.1 and given the hairy nature of the code I wouldn't
be very surprised if something broke. Create a bug report in bugs.eclipse.org and please provide as much
details as you can.

-- robin
Re: [BUG] After newest update I cannot store credentials... [message #1278031 is a reply to message #1278024] Wed, 26 March 2014 20:22 Go to previous message
Lukasz T. is currently offline Lukasz T.
Messages: 3
Registered: March 2014
Junior Member
Thank you Robin for guidance. I did as advised:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=431289

For now I will stay with the 3.2, and will wait for a bug fix.
Previous Topic:Project disappeared from workspace after restart
Next Topic:Unable to remove .DS_Store from unstaged changes list
Goto Forum:
  


Current Time: Wed Sep 17 07:36:02 GMT 2014

Powered by FUDForum. Page generated in 0.02643 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software