Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » JSP JDK Issues Eclipse Kepler
JSP JDK Issues Eclipse Kepler [message #1276638] Mon, 24 March 2014 21:19 Go to next message
cristian ambaek is currently offline cristian ambaekFriend
Messages: 3
Registered: March 2014
Junior Member
I am new to this forum so hopefully im in the right section.

I have been using Netbeans IDE for JSP development(no issues) but switched to Eclipse Kepler. But i have an error where Eclipse Kepler says
"There is an error in invoking javac. A full JDK (not just JRE) is required"

I have downloaded and installed the JDK from
"h t t p ://download.oracle.com/otn-pub/java/jdk/7u51-b13/jdk-7u51-windows-x64.exe"
And been in Eclipse and select the jdk Window -> Preferences -> Java -> Installed JREs and selected the jdk from the path C:\Program Files\Java\jdk1.7.0_51\jre.

The path C:\Program Files\Java\jdk1.7.0_51 was not good enough since Eclipse could not see it as the root of the directory.

What do i do? It seems no matter what i do then Eclipse wont work with my JSP pages and the local server inside the program. But normal Java console programs have no JDK issues.

Hope that someone can help me.
Thanks on advance
Kind regards.
Re: JSP JDK Issues Eclipse Kepler [message #1276667 is a reply to message #1276638] Mon, 24 March 2014 22:16 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2335
Registered: July 2009
Senior Member
For setting up an Installed JRE using a JDK installation, always use the root of the jDK installation and not the coincidentally-named "jre" directory within it. What action on your part prompted the message about requiring a full JDK?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:JSDT Errors on Type Incompatibility and Missing Declarations
Next Topic:The preferences for the xdoclet runtime does not point to a valid installation
Goto Forum:
  


Current Time: Wed Nov 26 05:54:13 GMT 2014

Powered by FUDForum. Page generated in 0.02264 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software