Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » How to verify that WebTools Platform is successfully installed?
How to verify that WebTools Platform is successfully installed? [message #212311] Mon, 14 April 2008 17:59 Go to next message
Eclipse User
Originally posted by: under.lycos.co.uk

I downloaded wtp-S-3.0M6-20080404175400.zip
and extracted it into the appropriate directories of my Eclipse v3.2.2 installation.

Do I have to do something more to get WTP working ?

How can I verify that everything is successfully installed?

Are there any special menus in Eclipse which should appear after the WTP installation?

Jeff
Re: How to verify that WebTools Platform is successfully installed? [message #212324 is a reply to message #212311] Mon, 14 April 2008 19:29 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

Jeff,

Help->About Eclipse SDK and looking at features or plugins should let
you confirm the version that's active and present.


Jeff Korn wrote:
> I downloaded wtp-S-3.0M6-20080404175400.zip
> and extracted it into the appropriate directories of my Eclipse v3.2.2 installation.
>
> Do I have to do something more to get WTP working ?
>
> How can I verify that everything is successfully installed?
>
> Are there any special menus in Eclipse which should appear after the WTP installation?
>
> Jeff
>
Re: How to verify that WebTools Platform is successfully installed? [message #212330 is a reply to message #212311] Mon, 14 April 2008 19:35 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2277
Registered: July 2009
Senior Member
Jeff Korn wrote:
> I downloaded wtp-S-3.0M6-20080404175400.zip
> and extracted it into the appropriate directories of my Eclipse v3.2.2 installation.
>
> Do I have to do something more to get WTP working ?
>
> How can I verify that everything is successfully installed?
>
> Are there any special menus in Eclipse which should appear after the WTP installation?

There would be additional entries in the Preferences dialog, but you
won't get a working installation mixing 3.0M6 with Eclipse
3.2.2--the 3.0 milestones are built for Eclipse 3.4 milestones. The
easiest way to get WTP it is to start with the Eclipse IDE for Java
EE Developers, available from
http://www.eclipse.org/downloads/moreinfo/jee.php . It includes
Eclipse 3.2.2 with the latest WTP release, currently 2.0.2. You can
also download WTP 2.0.2 directly from
http://download.eclipse.org/webtools/downloads/, as long as you take
note of and also install the "Required Prerequisites" listed at the top.

---
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: How to verify that WebTools Platform is successfully installed? [message #212341 is a reply to message #212311] Mon, 14 April 2008 20:16 Go to previous messageGo to next message
Wayne Beaton is currently offline Wayne Beaton
Messages: 499
Registered: July 2009
Senior Member
I'm no expert on web tools prerequisites, but I'm pretty sure that the
very latest and greatest version of WTP (3.0M6) won't work with Eclipse
3.2.2. It almost certainly uses features available only in the 3.3
stream.

If you just want to use web tools, I recommend that you download one of
the packaged IDEs for it from the downloads page [1]. If you really want
to use the latest and greatest (i.e. pre-release software), grab the
Ganymede milestone from the M5 packages page [2].

HTH,

Wayne

[1]http://www.eclipse.org/downloads
[2]http://phoenix.eclipse.org/packages/

On Mon, 2008-04-14 at 17:59 +0000, Jeff Korn wrote:
> I downloaded wtp-S-3.0M6-20080404175400.zip
> and extracted it into the appropriate directories of my Eclipse v3.2.2 installation.
>
> Do I have to do something more to get WTP working ?
>
> How can I verify that everything is successfully installed?
>
> Are there any special menus in Eclipse which should appear after the WTP installation?
>
> Jeff
Re: How to verify that WebTools Platform is successfully installed? [message #212356 is a reply to message #212311] Tue, 15 April 2008 00:33 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3196
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

Jeff Korn wrote:
> I downloaded wtp-S-3.0M6-20080404175400.zip
> and extracted it into the appropriate directories of my Eclipse v3.2.2 installation.
>
> Do I have to do something more to get WTP working ?
>
> How can I verify that everything is successfully installed?
>
> Are there any special menus in Eclipse which should appear after the WTP installation?
>
> Jeff

And, since it's not a commercial product, I feel safe putting in a plug
for Pulse (www.poweredbypulse.com) which will not only help you get all
this that you want (solving the very question you've just asked), but
will help you set up a profile so that you can duplicate it a) for
yourself on a subsequent development host and b) share your profile and
therefore development environment with others.

Russ Bateman
Re: How to verify that WebTools Platform is successfully installed? [message #212360 is a reply to message #212311] Tue, 15 April 2008 06:25 Go to previous messageGo to next message
Volodymyr Gryshko is currently offline Volodymyr Gryshko
Messages: 28
Registered: July 2009
Junior Member
Hello Jeff,

To check whether it's working or not launch eclipse, go to help -> about
eclipse ...-> configuration details.

Press "Copy to Clipboard" and then paste to some text editor.

Search for word "installed" in front of plugins - installed means that
plugin is not started.

There are several reasons for that: newer version of same plugin exists or
some dependency missing.

To make sure you install with all dependencies in place, use update site of
WTP project.

WTP will complain immediately if something missing.

http://download.eclipse.org/webtools/updates/

Or use Europa update (3.2.2 should have link to Europa by default):

Go to Help -> Software Updates -> Find And Install -> Search For New
Features for Install. Select Europa there.

And when you select features to install uncheck "show the latest version
only" at the bottom - 3.2.2 is a bit old. Select WTP version (1.5 for 3.2.2
I guess) and if you see message on the top that something missing - press
"Select Required" button.

Hope it helps.

Vlad.

"Jeff Korn" <under@lycos.co.uk> wrote in message
news:fu062m$bs4$1@build.eclipse.org...
>I downloaded wtp-S-3.0M6-20080404175400.zip
> and extracted it into the appropriate directories of my Eclipse v3.2.2
> installation.
>
> Do I have to do something more to get WTP working ?
>
> How can I verify that everything is successfully installed?
>
> Are there any special menus in Eclipse which should appear after the WTP
> installation?
>
> Jeff
Re: How to verify that WebTools Platform is successfully installed? [message #212368 is a reply to message #212311] Tue, 15 April 2008 10:09 Go to previous messageGo to next message
Eclipse User
Originally posted by: groups.pellaton.li

Hi

> Do I have to do something more to get WTP working ?
Assuming you unzipped the four prerequisite archives too, no.

> How can I verify that everything is successfully installed?
Window > Show View > Other... Plug-in Regsitry

The now appearing Plug-in registry view displays all currently
available Plug-ins of your Eclipse instance.

You should see a bunch of org.eclipse.jst.* and org.eclipse.wst.*
plug-ins. Quickly browse through the list and check that no plug-in icon
has a red error marker.

> Are there any special menus in Eclipse which should appear after the
> WTP installation?
Yes, WTP adds many things. One of the easiest to check is whether the
WTP specific project types are avialbe in the new project wizard:

File > New Project > Other

WTP is installed if project categories like EJB, Web, ... show up.

HTH

Michael
Re: How to verify that WebTools Platform is successfully installed? [message #212541 is a reply to message #212311] Fri, 18 April 2008 16:22 Go to previous message
Eclipse User
Originally posted by: eclipse-news.rizzoweb.com

Jeff Korn wrote:
> I downloaded wtp-S-3.0M6-20080404175400.zip
> and extracted it into the appropriate directories of my Eclipse v3.2.2 installation.
>
> Do I have to do something more to get WTP working ?
>
> How can I verify that everything is successfully installed?
>
> Are there any special menus in Eclipse which should appear after the WTP installation?

You should see manifestations of WTP in the Preferences dialog. For
example, "Server" and "Web and XML" top-level categories.
You can also open Help > About Eclipse > Plugin Details... and look for
plugins that begin with org.eclipse.wst.*(specifically,
org.eclipse.wst.webtools.doc.user)
Also, in the Run dialog you should see a category named "Run on Server"

Hope this helps,
Eric
Previous Topic:Escape special characters.
Next Topic:web service - "The service implementation selected is invalid"
Goto Forum:
  


Current Time: Mon Sep 22 18:18:38 GMT 2014

Powered by FUDForum. Page generated in 0.09128 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software