Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Tomcat runs good but don't stop correctly
Tomcat runs good but don't stop correctly [message #212230] Thu, 10 April 2008 12:34 Go to next message
Eclipse User
Originally posted by: alessandro.zucchi.zucchetti.it

Hi all,
I'm using Eclispe 3.3.2 (WTP 2.0.2) with Tomcat 6 and Java5 (update 15) on
Windows Xp sp2.
My web application runs ok but when I try to stop Tomcat by "server view"
Eclipse is not able to shutdown tomcat process the wait for ever. Only
killing the process with Task Manager resolve the problem.
I tried with Tomcat 5.5 ,with java5 but nothing.

Any ideas?
Best regards
Alex
Re: Tomcat runs good but don't stop correctly [message #212246 is a reply to message #212230] Thu, 10 April 2008 14:22 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1308
Registered: July 2009
Senior Member
Alex wrote:
> Hi all,
> I'm using Eclispe 3.3.2 (WTP 2.0.2) with Tomcat 6 and Java5 (update 15)
> on Windows Xp sp2.
> My web application runs ok but when I try to stop Tomcat by "server
> view" Eclipse is not able to shutdown tomcat process the wait for ever.
> Only killing the process with Task Manager resolve the problem.
> I tried with Tomcat 5.5 ,with java5 but nothing.
>
> Any ideas?
> Best regards
> Alex
>
>

I assume that Tomcat starts to shutdown, but never finishes shutting
down. This can be an expected Tomcat behavior. Tomcat will wait
forever for all webapps to "cleanup" before exiting. The typical cause
is a webapp starting a Thread, directly or indirectly, which is not set
to daemon mode (i.e. Thread.setDaemon(true) ). The means that the
webapp will have to stop the thread itself before Tomcat will exit. If
this appears to apply to your situation, you can start Tomcat in debug
mode and after attempting to shutdown, check the Debug view to see if
you can spot any "extra" threads.

If it seems like something else is going wrong, please provide more details.

Cheers,
Larry
Previous Topic:ClassCastException using wsdl validator
Next Topic:How to set/force specific content type for a StructuredTextEditor in a MultiPageEditor
Goto Forum:
  


Current Time: Tue Oct 21 13:43:51 GMT 2014

Powered by FUDForum. Page generated in 0.03149 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software