Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Opening editor failed error in EGIT 3.3
Opening editor failed error in EGIT 3.3 [message #1273955] Thu, 20 March 2014 16:02 Go to next message
Missing name Mising name is currently offline Missing name Mising name
Messages: 3
Registered: July 2012
Junior Member
Hi,

I am using eclipse 4.3.2 with egit 3.3 on ubuntu 12.04.

I setup a local git repository. When I show history and then click on 1 commit and click 'Compare version with Ancestor', I get this error saying 'opening editor failed'

Do you know how can I fix this problem?

Thank you.

!ENTRY org.eclipse.egit.ui 4 0 2014-03-20 12:53:26.436
!MESSAGE Opening Editor Failed
!STACK 0
java.lang.NullPointerException
	at org.eclipse.egit.ui.internal.CompareUtils.compare(CompareUtils.java:590)
	at org.eclipse.egit.ui.internal.history.CommitFileDiffViewer.showTwoWayFileDiff(CommitFileD
iffViewer.java:534)
	at org.eclipse.egit.ui.internal.history.CommitFileDiffViewer$7.run(CommitFileDiffViewer.jav
a:249)
	at org.eclipse.jface.action.Action.runWithEvent(Action.java:499)
	at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContribution
Item.java:584)
	at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501
)
	at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.jav
a:411)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1392)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3742)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3363)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.j
ava:1113)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.jav
a:997)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:140)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:611)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLa
uncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.ja
va:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Re: Opening editor failed error in EGIT 3.3 [message #1274315 is a reply to message #1273955] Fri, 21 March 2014 05:31 Go to previous message
Robin Rosenberg is currently offline Robin Rosenberg
Messages: 319
Registered: July 2009
Senior Member
Missing name Mising name skrev 2014-03-20 21.02:
> Hi,
>
> I am using eclipse 4.3.2 with egit 3.3 on ubuntu 12.04.
>
> I setup a local git repository. When I show history and then click on 1 commit and click 'Compare version with Ancestor', I get this error saying 'opening editor failed'
>
> Do you know how can I fix this problem?

No, but if you have any information on how to reproduce the error, please comment on
https://bugs.eclipse.org/bugs/show_bug.cgi?id=424585

-- robin
Previous Topic:bisect
Next Topic:EGit variables
Goto Forum:
  


Current Time: Thu Aug 21 04:18:58 EDT 2014

Powered by FUDForum. Page generated in 0.13390 seconds