Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Sphinx » Installing Sphinx fails
Installing Sphinx fails [message #1273294] Wed, 19 March 2014 21:17 Go to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 66
Registered: March 2011
Member
I'm trying to install Sphinx from the update site, but it complains with the following error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Sphinx Runtime (Incubation) 0.7.0.201306251122 (org.eclipse.sphinx.feature.group 0.7.0.201306251122)
  Missing requirement: Sphinx EMF Compare Plug-in (Incubation) 0.7.0.201306251122 (org.eclipse.sphinx.emf.compare 0.7.0.201306251122) requires 'bundle org.eclipse.emf.compare.match 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: Sphinx Compare Engine & Editor (Incubation) 0.7.0.201306251122 (org.eclipse.sphinx.emf.compare.feature.group 0.7.0.201306251122)
    To: org.eclipse.sphinx.emf.compare [0.7.0.201306251122]
  Cannot satisfy dependency:
    From: Sphinx Runtime (Incubation) 0.7.0.201306251122 (org.eclipse.sphinx.feature.group 0.7.0.201306251122)
    To: org.eclipse.sphinx.emf.compare.feature.group [0.7.0.201306251122]


It looks like it's missing EMF Compare, but I am certain it is there (EMF Compare - Model Comparison Version: 2.1.3.201402040808)

What's going on?

PS: I'm using Eclipse Kepler SR2 with:

Eclipse Modeling Tools 2.0.2.20140224-0000 epp.package.modeling null
Graphical Editing Framework Zest Visualization Toolkit 1.5.1.201308190730 org.eclipse.zest.feature.group Eclipse.org
Guice Plugin 0.3.9 com.google.inject.tools.ideplugin.eclipse.guiceplugin.feature.group Google
m2e - slf4j over logback logging (Optional) 1.4.0.20130601-0317 org.eclipse.m2e.logback.feature.feature.group Eclipse.org - m2e
Xtext SDK 2.5.3.v201402240820 org.eclipse.xtext.sdk.feature.group Eclipse Modeling Project

(Java 1.7.0_051 on Mac OS X 10.9)



Re: Installing Sphinx fails [message #1586079 is a reply to message #1273294] Mon, 26 January 2015 16:59 Go to previous message
Idrissa Dieng is currently offline Idrissa DiengFriend
Messages: 9
Registered: April 2013
Location: Paris, France
Junior Member
Hello Ernesto Posse,

Sphinx 0.7.x versions is not compatible with Eclipse Kepler or recents versions.
If you're using Eclipse Kepler (or more recent) as platform please take Sphinx 0.8 or 0.9 version.
Previous Topic:Re: ValidationMarkerManager marks objects with partly matching
Next Topic:Problem while installing Sphinx
Goto Forum:
  


Current Time: Wed May 06 02:25:27 GMT 2015

Powered by FUDForum. Page generated in 0.07726 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software