Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » OCL validation at RCP runtime
OCL validation at RCP runtime [message #1273069] Wed, 19 March 2014 08:50 Go to next message
Salwa Alzahmi is currently offline Salwa Alzahmi
Messages: 18
Registered: June 2013
Junior Member
Hello,

I have an issue with OCL constrains that I added as annotation in Ecore model.
I generate the RCP application, and create new model of my ecore. I create some elements to validate the constrains. When I click on validate model, I got always the constrains that i added as an "error", although the model comply with the rule.

The strange things is that when i create xmi version of my Ecores , the constrains and validation working properly,however in the generated RCP application that validation always trigger an error.

any help regarding this issue.

Salwa
Re: OCL validation at RCP runtime [message #1273077 is a reply to message #1273069] Wed, 19 March 2014 09:04 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 4036
Registered: July 2009
Senior Member
https://wiki.eclipse.org/OCL/ForumNetiquette

On 19/03/2014 12:50, Salwa Alzahmi wrote:
> Hello,
>
> I have an issue with OCL constrains that I added as annotation in
> Ecore model.
> I generate the RCP application, and create new model of my ecore. I
> create some elements to validate the constrains. When I click on
> validate model, I got always the constrains that i added as an
> "error", although the model comply with the rule.
>
> The strange things is that when i create xmi version of my Ecores ,
> the constrains and validation working properly,however in the
> generated RCP application that validation always trigger an error.
> any help regarding this issue.
> Salwa
Previous Topic:org.eclipse.ocl.examples.feature.group in target platform
Next Topic:OCL binding for UML-like metamodel
Goto Forum:
  


Current Time: Tue Sep 02 10:15:21 EDT 2014

Powered by FUDForum. Page generated in 0.02093 seconds