Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Xtend scripts written for 2.3 developed in 2.4
Xtend scripts written for 2.3 developed in 2.4 [message #1271178] Fri, 14 March 2014 12:40 Go to next message
Felix Dorner is currently offline Felix Dorner
Messages: 261
Registered: March 2012
Senior Member
Hi,

I use the kepler modeling package to develop plugins for a juno/xtext
2.3 target. Now, all Xtend scripts have this error: "Couldn't find the
mandatory library 'org.eclipse.xtext.xbase.lib' 2.4.0 or higher on the
project's classpath". Is there maybe an option somewhere to tell the
Xtend 2.4 compiler that I want to use an Xtend runtime?
Re: Xtend scripts written for 2.3 developed in 2.4 [message #1272166 is a reply to message #1271178] Mon, 17 March 2014 08:30 Go to previous messageGo to next message
Felix Dorner is currently offline Felix Dorner
Messages: 261
Registered: March 2012
Senior Member
On 14/03/2014 13:40, Felix Dorner wrote:
> Is there maybe an option somewhere to tell the
> Xtend 2.4 compiler that I want to use an Xtend runtime?

Should read: .. an Xtend 2.3 runtime
Re: Xtend scripts written for 2.3 developed in 2.4 [message #1276162 is a reply to message #1272166] Mon, 24 March 2014 07:09 Go to previous messageGo to next message
Sven Efftinge is currently offline Sven Efftinge
Messages: 1769
Registered: July 2009
Senior Member
Am 17/03/14 09:30, schrieb Felix Dorner:
> On 14/03/2014 13:40, Felix Dorner wrote:
>> Is there maybe an option somewhere to tell the
>> Xtend 2.4 compiler that I want to use an Xtend runtime?
>
> Should read: .. an Xtend 2.3 runtime
>
>
>

No, that's not supported.

--
Need professional support for Xtext or other Eclipse Modeling technologies?
Go to: http://xtext.itemis.com
Twitter : @svenefftinge
Blog : http://blog.efftinge.de


--
Need professional support on Xtext or Xtend?
Mail to: xtext (at) itemis.com
Twitter : @svenefftinge
Blog : blog.efftinge.de
Re: Xtend scripts written for 2.3 developed in 2.4 [message #1288116 is a reply to message #1276162] Tue, 08 April 2014 09:35 Go to previous message
Felix Dorner is currently offline Felix Dorner
Messages: 261
Registered: March 2012
Senior Member
Hi Sven,

On 24/03/2014 08:09, Sven Efftinge wrote:
> Am 17/03/14 09:30, schrieb Felix Dorner:
>> On 14/03/2014 13:40, Felix Dorner wrote:
>>> Is there maybe an option somewhere to tell the
>>> Xtend 2.4 compiler that I want to use an Xtend runtime?
>>
>> Should read: .. an Xtend 2.3 runtime
>>
>>
>>
>
> No, that's not supported.
>

Do you think it's worthwile to raise a bugzilla?


Felix
Previous Topic:XtextCON
Next Topic:Getting hidden tokens for a model element
Goto Forum:
  


Current Time: Mon Oct 20 08:16:38 GMT 2014

Powered by FUDForum. Page generated in 0.02370 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software