Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » org.eclipse.ocl.examples.feature.group in target platform
org.eclipse.ocl.examples.feature.group in target platform [message #1271103] Fri, 14 March 2014 09:14 Go to next message
Ralph Gerbig is currently offline Ralph GerbigFriend
Messages: 697
Registered: November 2009
Senior Member
Hi,

I want to use <unit id="org.eclipse.ocl.examples.feature.group" version="0.0.0"/> in my target platform. Unfortunately I run from one missing dependency into the next one. For me it looks mainly like XText is messing things up here. I now have added <unit id="org.eclipse.xtext.sdk.feature.group" version="0.0.0"/> and <unit id="org.eclipse.xtend.feature.group" version="0.0.0"/> from the luna repositories and <unit id="com.google.inject" version="0.0.0"/> from the orbit repositories. Is there an example target platform for usage with ocl examples or do I need to go on adding dependencies by using try and error?

Ralph
Re: org.eclipse.ocl.examples.feature.group in target platform [message #1272165 is a reply to message #1271103] Mon, 17 March 2014 08:31 Go to previous messageGo to next message
Ralph Gerbig is currently offline Ralph GerbigFriend
Messages: 697
Registered: November 2009
Senior Member
Hi,

to get it running one needs to set all update sites to planner. I had it for the Luna only. I hope this helps others running into the same Problem Smile

Ralph
Re: org.eclipse.ocl.examples.feature.group in target platform [message #1272173 is a reply to message #1272165] Mon, 17 March 2014 08:51 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4154
Registered: July 2009
Senior Member
Hi

Sorry, I seem to have missed your original message.

Looking back at it I don't really understand, and I certainly don't
understand your solution. What is 'planner'.

Perhaps you can write something a bit clearer for me and others. Then
maybe I'll put it on the FAQ.

Regards

Ed Willink

On 17/03/2014 08:31, Ralph Gerbig wrote:
> Hi,
>
> to get it running one needs to set all update sites to planner. I had
> it for the Luna only. I hope this helps others running into the same
> Problem :)
>
> Ralph
Previous Topic:ocl for reflexive associationclass navigation bug
Next Topic:OCL validation at RCP runtime
Goto Forum:
  


Current Time: Thu Nov 27 06:00:56 GMT 2014

Powered by FUDForum. Page generated in 0.03901 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software