Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » IDE hang: "Copying resources to the output folder"
IDE hang: "Copying resources to the output folder" [message #210657] Fri, 22 July 2005 16:53 Go to next message
Eclipse UserFriend
Originally posted by: ken.williams.thomson.com

Hi,

My Eclipse installation has unfortunately become unusable. When I start
it up, it starts trying to clean & compile my java project, and then
consumes all the CPU resources on my machine. When I look at the progress
monitor, I see that it is "Copying resources to the output folder". If I
leave it alone, it will stay this way for several hours or overnight,
until I kill the process.

I can close the main Eclipse application, but it doesn't fully exit,
giving me a "Progress Information" window saying that it's waiting for
"Building workspace" and "Copying resources to the output folder". That
will wait around indefinitely until I kill it.

There's at least one other person in my office with the same problem.

I could use some help figuring out the problem and restoring things back
to working order. Unfortunately I'm behind a firewall and can't read the
newsgroups through NNTP, nor can I find a searchable archive of this list
(does one exist?), so if this issue is already discussed somewhere, or if
there's a standard litany of things to try, I'd be happy to be pointed to
a URL.

My setup:
Eclipse 3.1.0 on Windows XP
P4Eclipse 0.2.24 plugin installed
Not using CVS at all

-Ken
Re: IDE hang: "Copying resources to the output folder" [message #210813 is a reply to message #210657] Mon, 25 July 2005 19:37 Go to previous message
Eclipse UserFriend
Originally posted by: eclipse3.rizzoweb.com

Ken Williams wrote:
> Hi,
>
> My Eclipse installation has unfortunately become unusable. When I start
> it up, it starts trying to clean & compile my java project, and then
> consumes all the CPU resources on my machine. When I look at the
> progress monitor, I see that it is "Copying resources to the output
> folder". If I leave it alone, it will stay this way for several hours
> or overnight, until I kill the process.
>
> I can close the main Eclipse application, but it doesn't fully exit,
> giving me a "Progress Information" window saying that it's waiting for
> "Building workspace" and "Copying resources to the output folder". That
> will wait around indefinitely until I kill it.
>
> There's at least one other person in my office with the same problem.

It is possible that there is one particular file in your source tree
that, for some reason I would have no idea about, is corrupted or
somehow giving Eclipse fits. Can you try temporarily removing all
non-Java files from your source directory(ies) and see if that makes it
go away. If so, try adding the files back one at a time until you find
which one is causing the problem.
IF that leads you to a "bad" file, please enter a bug and include the
content of that file and your config details: http://bugs.eclipse.org/bugs


> I could use some help figuring out the problem and restoring things back
> to working order. Unfortunately I'm behind a firewall and can't read
> the newsgroups through NNTP, nor can I find a searchable archive of this
> list (does one exist?), so if this issue is already discussed somewhere,
> or if there's a standard litany of things to try, I'd be happy to be
> pointed to a URL.

Google (not Google Groups) indexes the archives of these groups. Also,
Eclipse.org hosts a somewhat limited search feature; go to
www.eclipse.org and click the Search link in the left gutter.

HTH,
Eric
Previous Topic:problem applying changes after AST modification
Next Topic:Calling PDE programatically
Goto Forum:
  


Current Time: Fri Dec 19 16:41:31 GMT 2014

Powered by FUDForum. Page generated in 0.01613 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software