Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMF Forms] Dynamic EMF not supported
[EMF Forms] Dynamic EMF not supported [message #1269022] Tue, 11 March 2014 05:33 Go to next message
Paweł Doleciński is currently offline Paweł Doleciński
Messages: 36
Registered: January 2014
Member
Hi,

I created my model using dynamic EMF as described here: https://www.ibm.com/developerworks/library/os-eclipse-dynamicemf/

After passing EObject to the ECPSWTViewRenderer I can see nothing.
After small investigation I found that ReflectiveItemProviderAdapterFactory is not used all the time, especially ECPAbstractControl is bulding EditingDomain based on ComposedAdapterFactory.Descriptor.Registry.INSTANCE only.

Should I request a bug or maybe it was done on purpose. If yes, what's a purpose of that?

Cheers,
Paweł.
Re: [EMF Forms] Dynamic EMF not supported [message #1269089 is a reply to message #1269022] Tue, 11 March 2014 07:09 Go to previous message
Maximilian Koegel is currently offline Maximilian Koegel
Messages: 184
Registered: July 2009
Senior Member
Hi Pawel,

thank you for reporting this!
There is currently no explicit support for dynamic EMF, but this is
definitely not on purpose...;)
In the contrary we are working on getting Dynamic EMF to work with ECP
as expected, since we need it for the improved IDE tooling. The 1.3.x
releases will contain this support, it will soon also be available on
the develop branch and therefore in the nightly builds.
It would be great if you opened an explicit bug. If you would like to
get early access, please let me know. Contributions are also welcome at
any point!

Cheers,
Maximilian

Am 11.03.2014 10:33, schrieb Paweł Doleciński:
> Hi,
>
> I created my model using dynamic EMF as described here:
> https://www.ibm.com/developerworks/library/os-eclipse-dynamicemf/
>
> After passing EObject to the ECPSWTViewRenderer I can see nothing.
> After small investigation I found that
> ReflectiveItemProviderAdapterFactory is not used all the time,
> especially ECPAbstractControl is bulding EditingDomain based on
> ComposedAdapterFactory.Descriptor.Registry.INSTANCE only.
>
> Should I request a bug or maybe it was done on purpose. If yes, what's a
> purpose of that?
>
> Cheers,
> Paweł.


--
Maximilian Kögel

Get Professional Eclipse Support: http://eclipsesource.com/munich
Previous Topic:[Texo] Annotations model in ECore
Next Topic:[EMF Forms] Unable to link a EClass to my view model
Goto Forum:
  


Current Time: Tue Jul 29 11:05:52 EDT 2014

Powered by FUDForum. Page generated in 0.01886 seconds