Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » Unable to launch project(Can not run after importing )
Unable to launch project [message #1265894] Thu, 06 March 2014 13:01 Go to next message
Russell Wilkie is currently offline Russell Wilkie
Messages: 1
Registered: March 2014
Junior Member
I have e-mailed GitHub in regards to this issue and was told to consult eclipse first. The following e-mail was sent:

Quote:
Here it is:

Hello.

I'm importing an existing EGit project from a shared organization respiratory.

The organization was originally authored by another organization member. He provided 4 classes and uploaded his code to the respiratory. I performed the following steps when trying to import his project:

1. I went to File>Import>Git>Projects from Git
2. I clicked on next and went to CloneURL.
3. Inputted the following URL into the URL field:
(BLOCK)
4. Clicked on next. Selected master branch.
5. Created the directory:
BLOCK
6. Clicked next, Imported it as existing projects
7. Following projects were selected:

AssignmentFour (BLOCK)
Project4(BLOCK)

8. Clicked finish

When I try to run any of the classes I get the following error:

"The selection cannot be launched, and there are no recent launches"

Why am I unable run my classes?
Re: Unable to launch project [message #1266514 is a reply to message #1265894] Fri, 07 March 2014 10:03 Go to previous message
Steve Elsemore is currently offline Steve Elsemore
Messages: 9
Registered: July 2009
Junior Member
You'll get the same answer here as you did from GitHub. This is a general Eclipse question, not an EGit question. When you launch a file or project for the first time, you need to tell Eclipse what you want. Right-click and select Run As -> Run Configurations... You need to create a run configuration of the appropriate type (Eclipse Application, Java Application, etc.). Google "Eclipse run configurations" or search Eclipse help for more information.

Russell Wilkie wrote on Thu, 06 March 2014 13:01
I have e-mailed GitHub in regards to this issue and was told to consult eclipse first. The following e-mail was sent:

Quote:
Here it is:

Hello.

I'm importing an existing EGit project from a shared organization respiratory.

The organization was originally authored by another organization member. He provided 4 classes and uploaded his code to the respiratory. I performed the following steps when trying to import his project:

1. I went to File>Import>Git>Projects from Git
2. I clicked on next and went to CloneURL.
3. Inputted the following URL into the URL field:
(BLOCK)
4. Clicked on next. Selected master branch.
5. Created the directory:
BLOCK
6. Clicked next, Imported it as existing projects
7. Following projects were selected:

AssignmentFour (BLOCK)
Project4(BLOCK)

8. Clicked finish

When I try to run any of the classes I get the following error:

"The selection cannot be launched, and there are no recent launches"

Why am I unable run my classes?

Previous Topic:Merge tool - better remove conflict markers functionality when rejecting change?
Next Topic:How to checkout a file
Goto Forum:
  


Current Time: Tue Jul 22 07:25:09 EDT 2014

Powered by FUDForum. Page generated in 0.01526 seconds