Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Error "The requested resource is not available" when trying WPT Tutorial
Error "The requested resource is not available" when trying WPT Tutorial [message #209530] Tue, 04 March 2008 19:54 Go to next message
Eclipse User
Originally posted by: markus.heid.email.de

Hi,
I've trying the buttom up webservice example as described here:
http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html
But when I'm starting the tutorial with Run as -> Run on Server
I'm getting a 404 error page in eclipse.
The error page tells me: The requested resource is not available.
The console messages while starting the tomcat tells me that:


Mar 4, 2008 7:48:39 PM org.apache.tomcat.util.digester.SetPropertiesRule
begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting
property 'source' to 'org.eclipse.jst.jee.server:HGWS' did not find a
matching property.
Mar 4, 2008 7:48:39 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal
performance in production environments was not found on the
java.library.path:
C:\Programme\Java\jre1.6.0_04\bin;.;C:\WINDOWS\Sun\Java\bin; C:\WINDOWS\system32;C:\WINDOWS;C:\Programme\Java\jre1.6.0_04 \bin\client;C:\Programme\Java\jre1.6.0_04\bin;C:\WINDOWS\sys tem32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Programme\ATI
Technologies\ATI.ACE\;C:\Programme\QuickTime\QTSystem\;d:\an droid\sdk\tools;C:\Programme\Microsoft
SQL
Server\90\Tools\binn\;C:\Programme\Subversion\bin;C:\Program \Files\jboss-4.0.5.GA\bin;d:\ant\bin;d:\axis2-1.3\bin;;C:\Su n\SDK\bin;d:\android\sdk
Mar 4, 2008 7:48:40 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Mar 4, 2008 7:48:40 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1796 ms
Mar 4, 2008 7:48:40 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Mar 4, 2008 7:48:40 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.16
[INFO] Deploying module: addressing-1.3
[INFO] Deploying module: metadataExchange-1.3
[INFO] Deploying module: ping-1.3
[INFO] Deploying module: script-1.3
[INFO] Deploying module: soapmonitor-1.3
[INFO] script module activated
[INFO] Deploying Web service: HuntGameWS2
[INFO] Deploying Web service: version.aar
Mar 4, 2008 7:48:46 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Mar 4, 2008 7:48:46 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Mar 4, 2008 7:48:46 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/93 config=null
Mar 4, 2008 7:48:46 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 6104 ms

My eclipse version is Version: 3.3.0
Build id: I20070625-1500
My WPT version is: 2.0.0
My Tomcat is 6.0.16

I've searching the web for a while for a solutions but found nothing yet.

Thank you for helping

Markus
Re: Error "The requested resource is not available" when trying WPT Tutorial [message #209638 is a reply to message #209530] Wed, 05 March 2008 14:59 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1310
Registered: July 2009
Senior Member
Markus Heid wrote:
> Hi,
> I've trying the buttom up webservice example as described here:
> http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html
>
> But when I'm starting the tutorial with Run as -> Run on Server
> I'm getting a 404 error page in eclipse.
> The error page tells me: The requested resource is not available.
> The console messages while starting the tomcat tells me that:
>
>
> Mar 4, 2008 7:48:39 PM org.apache.tomcat.util.digester.SetPropertiesRule
> begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting
> property 'source' to 'org.eclipse.jst.jee.server:HGWS' did not find a
> matching property.
> Mar 4, 2008 7:48:39 PM org.apache.catalina.core.AprLifecycleListener init
> INFO: The APR based Apache Tomcat Native library which allows optimal
> performance in production environments was not found on the
> java.library.path:
> C:\Programme\Java\jre1.6.0_04\bin;.;C:\WINDOWS\Sun\Java\bin; C:\WINDOWS\system32;C:\WINDOWS;C:\Programme\Java\jre1.6.0_04 \bin\client;C:\Programme\Java\jre1.6.0_04\bin;C:\WINDOWS\sys tem32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Programme\ATI
> Technologies\ATI.ACE\;C:\Programme\QuickTime\QTSystem\;d:\an droid\sdk\tools;C:\Programme\Microsoft
> SQL
> Server\90\Tools\binn\;C:\Programme\Subversion\bin;C:\Program \Files\jboss-4.0.5.GA\bin;d:\ant\bin;d:\axis2-1.3\bin;;C:\Su n\SDK\bin;d:\android\sdk
>
> Mar 4, 2008 7:48:40 PM org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> Mar 4, 2008 7:48:40 PM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 1796 ms
> Mar 4, 2008 7:48:40 PM org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> Mar 4, 2008 7:48:40 PM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/6.0.16
> [INFO] Deploying module: addressing-1.3
> [INFO] Deploying module: metadataExchange-1.3
> [INFO] Deploying module: ping-1.3
> [INFO] Deploying module: script-1.3
> [INFO] Deploying module: soapmonitor-1.3
> [INFO] script module activated
> [INFO] Deploying Web service: HuntGameWS2
> [INFO] Deploying Web service: version.aar
> Mar 4, 2008 7:48:46 PM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> Mar 4, 2008 7:48:46 PM org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009
> Mar 4, 2008 7:48:46 PM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/93 config=null
> Mar 4, 2008 7:48:46 PM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 6104 ms
>
> My eclipse version is Version: 3.3.0
> Build id: I20070625-1500
> My WPT version is: 2.0.0
> My Tomcat is 6.0.16
>
> I've searching the web for a while for a solutions but found nothing yet.
>
> Thank you for helping
>
> Markus

When you create the Dynamic Web Project, make sure you change the
Dynamic Web Module version on the Project Facets page to "2.4", like it
is shown in the tutorial. It is probably defaulting to "2.5" because of
Tomcat 6.0.16. Using "2.4" works for me, where "2.5" yields the same
result that you are seeing. I'm not sure of the source of this
behavioral difference.

Cheers,
Larry
thx [message #209683 is a reply to message #209638] Wed, 05 March 2008 20:16 Go to previous message
Eclipse User
Originally posted by: markus.heid.email.de

Larry Isaacs schrieb:
> Markus Heid wrote:
>> Hi,
>> I've trying the buttom up webservice example as described here:
>> http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html
>>
>> But when I'm starting the tutorial with Run as -> Run on Server
>> I'm getting a 404 error page in eclipse.
>> The error page tells me: The requested resource is not available.
>> The console messages while starting the tomcat tells me that:
>>
>>
>> Mar 4, 2008 7:48:39 PM
>> org.apache.tomcat.util.digester.SetPropertiesRule begin
>> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context}
>> Setting property 'source' to 'org.eclipse.jst.jee.server:HGWS' did not
>> find a matching property.
>> Mar 4, 2008 7:48:39 PM org.apache.catalina.core.AprLifecycleListener init
>> INFO: The APR based Apache Tomcat Native library which allows optimal
>> performance in production environments was not found on the
>> java.library.path:
>> C:\Programme\Java\jre1.6.0_04\bin;.;C:\WINDOWS\Sun\Java\bin; C:\WINDOWS\system32;C:\WINDOWS;C:\Programme\Java\jre1.6.0_04 \bin\client;C:\Programme\Java\jre1.6.0_04\bin;C:\WINDOWS\sys tem32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Programme\ATI
>> Technologies\ATI.ACE\;C:\Programme\QuickTime\QTSystem\;d:\an droid\sdk\tools;C:\Programme\Microsoft
>> SQL
>> Server\90\Tools\binn\;C:\Programme\Subversion\bin;C:\Program \Files\jboss-4.0.5.GA\bin;d:\ant\bin;d:\axis2-1.3\bin;;C:\Su n\SDK\bin;d:\android\sdk
>>
>> Mar 4, 2008 7:48:40 PM org.apache.coyote.http11.Http11Protocol init
>> INFO: Initializing Coyote HTTP/1.1 on http-8080
>> Mar 4, 2008 7:48:40 PM org.apache.catalina.startup.Catalina load
>> INFO: Initialization processed in 1796 ms
>> Mar 4, 2008 7:48:40 PM org.apache.catalina.core.StandardService start
>> INFO: Starting service Catalina
>> Mar 4, 2008 7:48:40 PM org.apache.catalina.core.StandardEngine start
>> INFO: Starting Servlet Engine: Apache Tomcat/6.0.16
>> [INFO] Deploying module: addressing-1.3
>> [INFO] Deploying module: metadataExchange-1.3
>> [INFO] Deploying module: ping-1.3
>> [INFO] Deploying module: script-1.3
>> [INFO] Deploying module: soapmonitor-1.3
>> [INFO] script module activated
>> [INFO] Deploying Web service: HuntGameWS2
>> [INFO] Deploying Web service: version.aar
>> Mar 4, 2008 7:48:46 PM org.apache.coyote.http11.Http11Protocol start
>> INFO: Starting Coyote HTTP/1.1 on http-8080
>> Mar 4, 2008 7:48:46 PM org.apache.jk.common.ChannelSocket init
>> INFO: JK: ajp13 listening on /0.0.0.0:8009
>> Mar 4, 2008 7:48:46 PM org.apache.jk.server.JkMain start
>> INFO: Jk running ID=0 time=0/93 config=null
>> Mar 4, 2008 7:48:46 PM org.apache.catalina.startup.Catalina start
>> INFO: Server startup in 6104 ms
>>
>> My eclipse version is Version: 3.3.0
>> Build id: I20070625-1500
>> My WPT version is: 2.0.0
>> My Tomcat is 6.0.16
>>
>> I've searching the web for a while for a solutions but found nothing yet.
>>
>> Thank you for helping
>>
>> Markus
>
> When you create the Dynamic Web Project, make sure you change the
> Dynamic Web Module version on the Project Facets page to "2.4", like it
> is shown in the tutorial. It is probably defaulting to "2.5" because of
> Tomcat 6.0.16. Using "2.4" works for me, where "2.5" yields the same
> result that you are seeing. I'm not sure of the source of this
> behavioral difference.
>
> Cheers,
> Larry

Thank you,
is was the solutions i've been looking for so long.
Previous Topic:WSDL Generation
Next Topic:Page Rendering Puzzle
Goto Forum:
  


Current Time: Fri Oct 24 12:47:48 GMT 2014

Powered by FUDForum. Page generated in 0.01996 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software