Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Problem with facet categories?
Problem with facet categories? [message #208414] Mon, 11 February 2008 14:56 Go to next message
Eclipse UserFriend
Originally posted by: david_whiteman.us.ibm.com

Hello again,

I'm trying to follow the steps in this article to create categories for
facets:

http://www.eclipse.org/articles/Article-BuildingProjectFacet s/tutorial.html

I discovered that the <category> child element of <project-facet> has
been replaced by <member category="MYID"/>. I also declared a category
with an id of "MYID" as part of the core.facets extension point. As
soon as I do all this, my facet no longer appears in the UI. I comment
out the <member> element and it appears again. Is there a bug in 3.0M4
here, has the usage changed since this article was written, or did I
make a mistake here?

Thanks in advance,
David
Re: Problem with facet categories? [message #208428 is a reply to message #208414] Mon, 11 February 2008 15:09 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: kosta.bea.com

Take a look at your log. Any usage problems will be reported there.

- Konstantin
Re: Problem with facet categories? [message #208445 is a reply to message #208428] Mon, 11 February 2008 15:41 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: david_whiteman.us.ibm.com

Konstantin Komissarchik wrote:
> Take a look at your log. Any usage problems will be reported there.
>
> - Konstantin

Thanks, Konstantin. I checked the log, and there were no usage problems
reported related to categories. Here is what I have:

<extension point="org.eclipse.wst.common.project.facet.core.facets">
<category id="org.eclipse.cosmos.me.dmtoolkit.category">
<label>Foo</label>
<description>Foo bar.</description>
</category>

<project-facet id="org.eclipse.cosmos.me.dmtoolkit.facet">
<label>Bar</label>
<description>This is a description</description>
<member category="org.eclipse.cosmos.me.dmtoolkit.category"/>
</project-facet>

...
</extension>

As soon as I remove <member>, the facet shows up. Do I need to do
anything else to enable a category?

Thanks,
David
Re: Problem with facet categories? [message #208558 is a reply to message #208445] Tue, 12 February 2008 15:24 Go to previous message
Eclipse UserFriend
Originally posted by: kosta.bea.com

Make sure that you also have a facet version declared. If you are still
having problems with this, can you produce a stand-alone repro and open
a bug?

- Konstantin
Previous Topic:Getting the action that contributed a facet wizard page
Next Topic:JSP with jsf standard 2.0 components error
Goto Forum:
  


Current Time: Fri Nov 28 10:06:54 GMT 2014

Powered by FUDForum. Page generated in 0.02466 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software