Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Product Export creates no launcher and does not find plugins(I stumbled over two problems during the export of an RCP product)
Product Export creates no launcher and does not find plugins [message #1260418] Sat, 01 March 2014 12:49 Go to next message
Thomas Weskamp is currently offline Thomas Weskamp
Messages: 2
Registered: October 2013
Junior Member
Hello everybody,

thanks for reading this post. Actually I am unable to export an RCP product to be standalone. I am working with Kepler 4.3.0 on Ubuntu 13.10 64 bit. Today I downloaded a fresh Kepler and a belonging delta pack. I created a fresh product definition. I am developing a feature based product, which runs fine in the eclipse IDE.
I ran into problems that sound similar to a couple of posts I found here and elsewhere, but actually I am not able to solve it :
- When exporting the product just for my Ubuntu platform, the export process works fine, but ends up with a launcher that cannot start. It seems that this is an executable, but does not execute.
- When trying to export to multiple platforms, I stumbled over the wellknown "Cannot find plugin xxxxlauncherxxx. But the delta pack fits exactly to the IDE, and all the launchers are visible in the target. The target by the way is created into a seperate project, as recommended in the book "Eclipse Rich client Platform" by Affer, Lemieux and Aniszcyk.
Now I am totally stucked. Is anyone out there able and willing to help?
If there is any more information necessary, I will of course provide it immidiately...

Thanks in advance!
Re: Product Export creates no launcher and does not find plugins [message #1276622 is a reply to message #1260418] Mon, 24 March 2014 20:42 Go to previous message
Jim Klo is currently offline Jim Klo
Messages: 26
Registered: September 2012
Junior Member
I found that the PDE export functionality is just plain broken for anything but Hello World. I found that Tycho mostly solved my issues, but still have some specific issues to resolve that seem related to the product's classpath when running standalone vs as a child of the eclipse ide via Run.. or Debug...

[Updated on: Mon, 24 March 2014 20:42]

Report message to a moderator

Previous Topic:RCP 3.x app: Command Parameters not passed to command after app export!!
Next Topic:will Eclipse RCP 3.x run on Java 8?
Goto Forum:
  


Current Time: Thu Oct 02 12:37:24 GMT 2014

Powered by FUDForum. Page generated in 0.10662 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software