Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Update site - not updated?
Update site - not updated? [message #20088] Mon, 02 June 2008 19:48 Go to next message
Eclipse User
Originally posted by: thomas.olson.codeassist.dk

I have tryed to download the new version of IMP (for 3.4 M5) from
http://download.eclipse.org/technology/imp/updates/
But from what I can tell the update site does not contain the actual
plug-ins but only the features.

/T
Re: Update site - not updated? [message #21373 is a reply to message #20088] Tue, 10 June 2008 07:30 Go to previous messageGo to next message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
seem no problem as for my testing.

"Thomas" <thomas.olson@codeassist.dk> д
Re: Update site - not updated? [message #21414 is a reply to message #20088] Wed, 11 June 2008 16:53 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Thomas wrote:
> I have tryed to download the new version of IMP (for 3.4 M5) from
> http://download.eclipse.org/technology/imp/updates/
> But from what I can tell the update site does not contain the actual
> plug-ins but only the features.

The update site is not quite ready yet - we're still waiting on the
IP process to clear a dependency on LPG. [Unfortunately, it's a minor
dependency, but removing it would be more trouble than it's worth.]

Please grab the code from SVN for now. Sorry! The IP folks have
undoubtedly been swamped with requests during the 3.4 end-game.

And stay tuned for an announcement re: the update site.

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IMP Team Lead (http://www.eclipse.org/imp)
X10: Productivity for High-Performance Parallel Programming (http://x10.sf.net)
Re: Update site - not updated? [message #22948 is a reply to message #20088] Sun, 13 July 2008 18:47 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
> I have tryed to download the new version of IMP (for 3.4 M5) from
> http://download.eclipse.org/technology/imp/updates/
> But from what I can tell the update site does not contain the actual
> plug-ins but only the features.

Seems ok now for 3.4, but the p2 Ganymede installer is much fussier than the old Update Manager.

The three IMP features cannot be installed in isolation from the IMP site.
The LPG feature must be installed first, or at the same time, from the LPG site.

So add the http://download.eclipse.org/technology/imp/updates/ and
http://lpg.sourceforge.net/updates/ sites to the Available Software Tab,
then select all four IMP, LPG features and then Install.

Otherwise you get the somewhat daunting:

Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.imp.runtime.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.lpg.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.lpg.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.imp.runtime.feature.gr oup/0.1.74
Unsatisfied dependency: [org.eclipse.imp.lpg.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.runtime.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.imp.runtime.feature.gr oup/0.1.74
Unsatisfied dependency: [org.eclipse.imp.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12

Regards

Ed Willink
Re: Update site - not updated? [message #571018 is a reply to message #20088] Tue, 10 June 2008 07:30 Go to previous message
Jin Missing name is currently offline Jin Missing name
Messages: 100
Registered: July 2009
Senior Member
seem no problem as for my testing.

"Thomas" <thomas.olson@codeassist.dk> д
Re: Update site - not updated? [message #571123 is a reply to message #20088] Wed, 11 June 2008 16:53 Go to previous message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Thomas wrote:
> I have tryed to download the new version of IMP (for 3.4 M5) from
> http://download.eclipse.org/technology/imp/updates/
> But from what I can tell the update site does not contain the actual
> plug-ins but only the features.

The update site is not quite ready yet - we're still waiting on the
IP process to clear a dependency on LPG. [Unfortunately, it's a minor
dependency, but removing it would be more trouble than it's worth.]

Please grab the code from SVN for now. Sorry! The IP folks have
undoubtedly been swamped with requests during the 3.4 end-game.

And stay tuned for an announcement re: the update site.

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IMP Team Lead (http://www.eclipse.org/imp)
X10: Productivity for High-Performance Parallel Programming (http://x10.sf.net)
Re: Update site - not updated? [message #572448 is a reply to message #20088] Sun, 13 July 2008 18:47 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
> I have tryed to download the new version of IMP (for 3.4 M5) from
> http://download.eclipse.org/technology/imp/updates/
> But from what I can tell the update site does not contain the actual
> plug-ins but only the features.

Seems ok now for 3.4, but the p2 Ganymede installer is much fussier than the old Update Manager.

The three IMP features cannot be installed in isolation from the IMP site.
The LPG feature must be installed first, or at the same time, from the LPG site.

So add the http://download.eclipse.org/technology/imp/updates/ and
http://lpg.sourceforge.net/updates/ sites to the Available Software Tab,
then select all four IMP, LPG features and then Install.

Otherwise you get the somewhat daunting:

Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.imp.runtime.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.lpg.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.lpg.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.imp.runtime.feature.gr oup/0.1.74
Unsatisfied dependency: [org.eclipse.imp.lpg.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.runtime.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12
Unsatisfied dependency: [org.eclipse.imp.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.imp.runtime.feature.gr oup/0.1.74
Unsatisfied dependency: [org.eclipse.imp.feature.group 0.1.74] requiredCapability:
org.eclipse.equinox.p2.iu/lpg.runtime.feature.group/2.0.12

Regards

Ed Willink
Previous Topic:New IMP User's Guide
Next Topic:"setFilePath() should be called before calling this method"
Goto Forum:
  


Current Time: Sat Sep 20 09:58:12 GMT 2014

Powered by FUDForum. Page generated in 0.01902 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software