Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » How to install PDT 3.2.2
How to install PDT 3.2.2 [message #1259668] Fri, 28 February 2014 17:09 Go to next message
Michele Locati is currently offline Michele Locati
Messages: 5
Registered: July 2011
Location: Como, Italy
Junior Member
I just downloaded Eclipse 4.3.2 (Kepler SR2).

I wanted to install the latest PDT: from Eclipse I can find only PDT 3.2.0 (3.2.0.201306051924).

From the releases list I can see that the latest version should be PDT 3.2.2, but from the downloads page I can see only instructions on how to install older versions.

I also tried to add to Eclipse the software site http://download.eclipse.org/tools/pdt/updates/release, but it offers only PDT 3.1.2 (3.1.2.201212211235).

How can I install PDT 3.2.2?

[Updated on: Fri, 28 February 2014 17:12]

Report message to a moderator

Re: How to install PDT 3.2.2 [message #1259934 is a reply to message #1259668] Fri, 28 February 2014 23:49 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 353
Registered: July 2009
Location: Japan
Senior Member
There is no such version. PDT 3.2 is no longer maintained but is developing towards 3.3 for Luna(eclipse 4.4). The last version is 3.2.0.
In other words, PDT 3.2 is abandoned with all its bugs.
(it is possible to install newer unreliable/unstable nightly build from http://download.eclipse.org/tools/pdt/updates/3.2-nightly of course)

(note that I'm not a pdt developer and this is not an official announcement.)
Re: How to install PDT 3.2.2 [message #1263637 is a reply to message #1259934] Tue, 04 March 2014 16:56 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid Pakula
Messages: 52
Registered: March 2013
Member
"stable" PDT 3.2 version is available here: http://download.eclipse.org/tools/pdt/updates/3.2/release
I'm using 3.2-nightly with DLTK-5.0 nightly in production. Its stable and fast, besides most plugins form PDT-Eg (Symfony2, Composer etc..) require nightly version Wink

PDT 3.2-nightly works on Kepler and Luna.

See also:
https://projects.eclipse.org/projects/tools.pdt/downloads - other links and informations
http://p2-dev.pdt-extensions.org - this p2 site contain both, DLTK 5 nightly and PDT 3.2 nightly
http://www.eclipse.org/downloads/packages/eclipse-php-developers/lunam5 - Luna milestone with PDT nightly


Re: How to install PDT 3.2.2 [message #1264035 is a reply to message #1263637] Wed, 05 March 2014 00:21 Go to previous message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 353
Registered: July 2009
Location: Japan
Senior Member
>"stable" PDT 3.2 version is available here: http://download.eclipse.org/tools/pdt/updates/3.2/release
There are same features/plugins, same version 3.2.0.201306051924, same binaries. No any updates.
The only difference from kepler repository is there are "JUnit Tests" and "Souce Code" features which are not necessary for ordinary users.
Previous Topic:PHP in wordpress
Next Topic:PHP CS Fixer is not running
Goto Forum:
  


Current Time: Thu Oct 30 23:59:15 GMT 2014

Powered by FUDForum. Page generated in 0.04773 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software