Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Tutorials "Creating a top-down Axis2 Web service" and "Creating a bottom-up Axis2 Web
Tutorials "Creating a top-down Axis2 Web service" and "Creating a bottom-up Axis2 Web [message #207858] Fri, 01 February 2008 07:59 Go to next message
Florian Hackenberger is currently offline Florian Hackenberger
Messages: 123
Registered: July 2009
Senior Member
Hi!

I followed the instructions of the top-down tutorial [1] and unfortunately
they cause errors when trying to deploy the WebService. The missing piece
of information are the settings on the
Window->Preferences->WebServices->Server and Runtime page. I had to select
my Tomcat installation (5.5) and Apache Axis 2 (v. 1.3) in order to
complete the top-down tutorial. I suppose the same applies to the bottom up
approach. The error I got was:
IWAB0489E Error when deploying Web service to Axis runtime
axis-admin failed with {http://schemas.xmlsoap.org/soap/envelope/}Client The
service cannot be found for the endpoint reference (EPR)
http://localhost:8080/axisTest/services/AdminService

Could someone with write access to those tutorial please update the
instructions?

Cheers,
Florian Hackenberger

[1]
http://www.eclipse.org/webtools/community/tutorials/TopDownA xis2WebService/td_tutorial.html
[2]
http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html

--
Florian Hackenberger
Re: Tutorials "Creating a top-down Axis2 Web service" and "Creating a bottom-up Axis2 [message #207883 is a reply to message #207858] Fri, 01 February 2008 20:15 Go to previous message
Kathy Chan is currently offline Kathy Chan
Messages: 93
Registered: July 2009
Member
Hi Florian,

Yes. I agree that the instruction for the tutorial can be more explicit in
choosing the right server and runtime. You can actually update them by
clicking on the Server and Web service runtime hyperlink rather than
changing the Window->Preferences->WebServices->Server and Runtime
preference.

The instruction at for the various Web services tutorials is being updated
right now. Thanks for pointing it out!

Regards,
Kathy Chan

"DI Florian Hackenberger" <f.hackenberger@chello.at> wrote in message
news:fnujgl$kar$1@build.eclipse.org...
> Hi!
>
> I followed the instructions of the top-down tutorial [1] and unfortunately
> they cause errors when trying to deploy the WebService. The missing piece
> of information are the settings on the
> Window->Preferences->WebServices->Server and Runtime page. I had to select
> my Tomcat installation (5.5) and Apache Axis 2 (v. 1.3) in order to
> complete the top-down tutorial. I suppose the same applies to the bottom
> up
> approach. The error I got was:
> IWAB0489E Error when deploying Web service to Axis runtime
> axis-admin failed with {http://schemas.xmlsoap.org/soap/envelope/}Client
> The
> service cannot be found for the endpoint reference (EPR)
> http://localhost:8080/axisTest/services/AdminService
>
> Could someone with write access to those tutorial please update the
> instructions?
>
> Cheers,
> Florian Hackenberger
>
> [1]
> http://www.eclipse.org/webtools/community/tutorials/TopDownA xis2WebService/td_tutorial.html
> [2]
> http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html
>
> --
> Florian Hackenberger
Previous Topic:WTP-Tutorial Axis WS Client stubs not generated
Next Topic:INodeNotifier behavior on SSE editor
Goto Forum:
  


Current Time: Fri Oct 31 18:06:23 GMT 2014

Powered by FUDForum. Page generated in 0.01556 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software