Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Updating the org.eclipse.osgi bundle only
Updating the org.eclipse.osgi bundle only [message #1258391] Thu, 27 February 2014 10:33 Go to next message
Silvestre Martins is currently offline Silvestre Martins
Messages: 41
Registered: July 2009
Member
I'm using the eclipse platform 3.6 and we don't have any requirement to update it. However, the 3.6 version implements the OSGI spec 4.2 and we need to use a 3rd-party lib that requires OSGi 4.3, which is implemented in eclipse 3.7.

Can I simply update the bundle org.eclipse.osgi to the 3.7.x version?
Looking to the dependencies it seems yes, but I'm wondering if is there any incompatibility or some dependency in the equinox bundles that is not visible at compile time.

In case someone is aware of some issue with this I would appreciate any advice to avoid problems during runtime, which are harder to solve.

Re: Updating the org.eclipse.osgi bundle only [message #1258536 is a reply to message #1258391] Thu, 27 February 2014 13:35 Go to previous messageGo to next message
Thomas Watson is currently offline Thomas Watson
Messages: 427
Registered: July 2009
Senior Member
Equinox org.eclipse.osgi is the framework itself. It has no dependencies outside of the VM. That being said 3.7 is almost 3 releases old. You should consider moving up to Kepler SR2 (3.9.2) for org.eclipse.osgi which implements the OSGi R5 core specification.

There should be no compatibility issues upgrading from 3.6 to 3.9.
Re: Updating the org.eclipse.osgi bundle only [message #1258890 is a reply to message #1258536] Thu, 27 February 2014 21:42 Go to previous message
Silvestre Martins is currently offline Silvestre Martins
Messages: 41
Registered: July 2009
Member
Thomas Watson wrote on Thu, 27 February 2014 08:35
Equinox org.eclipse.osgi is the framework itself. It has no dependencies outside of the VM. That being said 3.7 is almost 3 releases old. You should consider moving up to Kepler SR2 (3.9.2) for org.eclipse.osgi which implements the OSGi R5 core specification.

There should be no compatibility issues upgrading from 3.6 to 3.9.



Thanks for the advice.
The main reason for choosing 3.7.1 was simply because it's already in the maven central repository, and it's sufficient for what I need. But of course we can add the latest version to our private repository.
I'm wondering what is the criteria for the versions to be available in the maven central repository...
http://mvnrepository.com/artifact/org.eclipse.osgi/org.eclipse.osgi

You're suggesting to use the 3.9.2 which is part of 4.3.2 platform but I see that it was not released yet. According to this page it should be released tomorrow Smile
http://wiki.eclipse.org/Simultaneous_Release
Previous Topic:Dropins & feature
Next Topic:[p2] maven tycho not able to identify target platform
Goto Forum:
  


Current Time: Tue Sep 16 07:39:42 GMT 2014

Powered by FUDForum. Page generated in 0.01573 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software