Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Tomcat with Eclipse.
Tomcat with Eclipse. [message #207574] Mon, 28 January 2008 12:42 Go to next message
Eclipse User
Originally posted by: ash_b123.yahoo.com

Hello,

I am trying to get the most stable version of Eclipse and most stable
version of Tomcat and the Tomcat plug-in for Eclipse.

What version do you folks suggest?

It does not have to be latest and the greatest versions for all the three.
It just has to tried and tested combination for easy integration.

Thanks
Ash
Re: Tomcat with Eclipse. [message #207590 is a reply to message #207574] Mon, 28 January 2008 13:28 Go to previous messageGo to next message
Eclipse User
Originally posted by: dcarver.starstandard.org

Ash wrote:
> Hello,
>
> I am trying to get the most stable version of Eclipse and most stable
> version of Tomcat and the Tomcat plug-in for Eclipse.
>
> What version do you folks suggest?
>
> It does not have to be latest and the greatest versions for all the
> three. It just has to tried and tested combination for easy integration.
>

I've used both Tomcat 5.5 and Tomcat 6.0 with the Eclipse Web Tools
project. I would suggest that you go with Web Tools 3.0 though.

Dave
Re: Tomcat with Eclipse. [message #207598 is a reply to message #207590] Mon, 28 January 2008 13:53 Go to previous messageGo to next message
Eclipse User
Originally posted by: ash_b123.yahoo.com

Hi Dave,

Do you suggest I go with Eclipse 3.3.1.1, Web tools 3.0 and TomCat 6.0 ?

Do you recommend any how to guide to setup this environment? Please note I
am setting up this development for the very first time.

Thanks
Ash
Re: Tomcat with Eclipse. [message #207606 is a reply to message #207598] Mon, 28 January 2008 14:19 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2219
Registered: July 2009
Senior Member
ash wrote:
> Do you suggest I go with Eclipse 3.3.1.1, Web tools 3.0 and TomCat 6.0 ?
>
> Do you recommend any how to guide to setup this environment? Please note
> I am setting up this development for the very first time.

As a reminder to all, 3.0 isn't finalized, yet, and is intended for
Eclipse 3.4. Our newest release is still 2.0.1, found in the Europa
Fall Maintenance pack as well as our own download page. The Europa
package for Java EE Developers is a good start.

http://www.eclipse.org/europa and
http://www.eclipse.org/downloads/moreinfo/jee.php

---
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Tomcat with Eclipse. [message #207613 is a reply to message #207606] Mon, 28 January 2008 14:35 Go to previous messageGo to next message
Eclipse User
Originally posted by: dcarver.starstandard.org

Nitin Dahyabhai wrote:
> ash wrote:
>> Do you suggest I go with Eclipse 3.3.1.1, Web tools 3.0 and TomCat 6.0 ?
>>
>> Do you recommend any how to guide to setup this environment? Please
>> note I am setting up this development for the very first time.
>
> As a reminder to all, 3.0 isn't finalized, yet, and is intended for
> Eclipse 3.4. Our newest release is still 2.0.1, found in the Europa
> Fall Maintenance pack as well as our own download page. The Europa
> package for Java EE Developers is a good start.
>
> http://www.eclipse.org/europa and
> http://www.eclipse.org/downloads/moreinfo/jee.php

Doh....my bad. I ment, 2.0.1 and Eclipse Europa.

Dave
Re: Tomcat with Eclipse. [message #207621 is a reply to message #207574] Mon, 28 January 2008 15:23 Go to previous message
John J. Barton is currently offline John J. Barton
Messages: 311
Registered: July 2009
Senior Member
Ash wrote:
> Hello,
>
> I am trying to get the most stable version of Eclipse and most stable
> version of Tomcat and the Tomcat plug-in for Eclipse.
>
> What version do you folks suggest?
>
> It does not have to be latest and the greatest versions for all the
> three. It just has to tried and tested combination for easy integration.
>
> Thanks
> Ash
>

Just so you know, "Tomcat plug-in" could mean "J2EE with Tomcat" or
"Sysdeo". I think the answers you already got meant "J2EE with Tomcat".

Off and on I've used versions of Tomcat from 4 up to 5.5 with various
versions of eclipse and both sysdeo and j2ee. They all 'work' and they
all have problems. Integration isn't the problem, its whether what you
want to do with the combo is the same as how the combo was tested and
whether you can find the right settings in the right mysterious panels
to get it to work.

I suggest that if you go with J2EE+Tomcat, then pick the most recent
eupora with Web Tools and Tomcat 5.5. That is because the J2EE bit is
newer and you can ask about this combo.

John.
Previous Topic:Including a JSP from an other projects
Next Topic:EMF ecore and genmodel for the jee-models?
Goto Forum:
  


Current Time: Thu Jul 10 16:36:45 EDT 2014

Powered by FUDForum. Page generated in 0.08861 seconds