Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP-Tutorial Axis WS Client stubs not generated
WTP-Tutorial Axis WS Client stubs not generated [message #207550] Mon, 28 January 2008 04:27 Go to next message
Eclipse User
Originally posted by: crapulence.gmx.de

Hi out there,

i am trying to create a web service client as described in "Creating a
bottom-up Axis2 Web service" from the WTP tutorial section. When creating
the client stubs i only get two stubs: "ConverterCallbackHandler" and
"ConverterStub".

I don't understand why this don't work like described. There is no error
message using the wizard.

Could it be a proxy or firewall issue? How to to get information what is
happening? Can someone help me out?

Thanks in advance,

ak
Re: WTP-Tutorial Axis WS Client stubs not generated [message #207874 is a reply to message #207550] Fri, 01 February 2008 14:56 Go to previous message
Kathy Chan is currently offline Kathy Chan
Messages: 93
Registered: July 2009
Member
I meant to reply to the whole newsgroup but sent out the response directly
to AK instead. Here's my response in case others run into similar problem.
AK also confirmed that my response fixed the problem.

Hi AK,

The "Creating a bottom-up Axis2 Web service" was written based on using the
Axis2 v1.2 runtime which generates the 3 stubs and 3 callback handlers.
However, the default setting for code generation has changed in Axis2 v1.3
where only 1 stub and 1 callback handler are generated. So I suspect that's
you had set the Axis2 runtime install to point to Axis2 v1.3 and that's why
you are only getting "ConverterCallbackHandler" and "ConverterStub".

So this is no cause for concern. The Web service would run either using
Axis2 v1.2 or v1.3. You could use the Web Services Explorer to test the Web
service or you could modify the client test problem ConverterClient.java as
follow to test the Web service generated using Axis2 v1.3:

package wtp;

import java.rmi.RemoteException;

import org.apache.axis2.AxisFault;

import wtp.ConverterStub.CelsiusToFarenheit;

import wtp.ConverterStub.CelsiusToFarenheitResponse;

public class ConverterClient {

public static void main(String[] args) {

try {

float celsiusValue = 100;

ConverterStub stub = new ConverterStub();

CelsiusToFarenheit c2f = new CelsiusToFarenheit();

c2f.setCelsius(celsiusValue);

CelsiusToFarenheitResponse res =
stub.celsiusToFarenheit(c2f);

System.out.println("Celsius : "+celsiusValue+" =
"+"Farenheit : "+res.get_return());

} catch (AxisFault e) {

e.printStackTrace();

} catch (RemoteException e) {

e.printStackTrace();

}

}

}

Regards,

Kathy Chan

"ak" <crapulence@gmx.de> wrote in message
news:901a79082f9ee613b3dfa2446b2b07a2$1@www.eclipse.org...
> Hi out there,
>
> i am trying to create a web service client as described in "Creating a
> bottom-up Axis2 Web service" from the WTP tutorial section. When creating
> the client stubs i only get two stubs: "ConverterCallbackHandler" and
> "ConverterStub".
>
> I don't understand why this don't work like described. There is no error
> message using the wizard.
>
> Could it be a proxy or firewall issue? How to to get information what is
> happening? Can someone help me out?
>
> Thanks in advance,
>
> ak
>
Previous Topic:could not remove module
Next Topic:Tutorials "Creating a top-down Axis2 Web service" and "Creating a bottom-up Axis2 Web
Goto Forum:
  


Current Time: Wed Apr 16 00:35:46 EDT 2014

Powered by FUDForum. Page generated in 0.01702 seconds