Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Installing 10.0.0M5
Installing 10.0.0M5 [message #1256604] Tue, 25 February 2014 15:59 Go to next message
Gintautas Sulskus is currently offline Gintautas SulskusFriend
Messages: 3
Registered: February 2013
Junior Member
Hello,

I can't get 10.0.0.M5 installed. Actually, I can't get installed any of Papyrus version. What am I missing?
I have installed all EMF related items from update site.

Thanks for your help!
Gin

Platform: Eclipse Standard 4.3.1
Error msg:
Your original request has been modified.
  "Papyrus UML (Incubation)" is already installed, so an update will be performed instead.
Cannot complete the install because one or more required items could not be found.
  Software being installed: Papyrus UML SDK (Incubation) 1.0.0.v201401290914 (org.eclipse.papyrus.sdk.sources.feature.feature.group 1.0.0.v201401290914)
  Missing requirement: Papyrus Embedded Editors extensions point (Incubation) 1.0.0.v201401290914 (org.eclipse.papyrus.extensionpoints.editors 1.0.0.v201401290914) requires 'bundle org.eclipse.emf.ecore 2.10.0' but it could not be found
  Cannot satisfy dependency:
    From: Papyrus GMF diagram (Incubation) 1.0.0.v201401290914 (org.eclipse.papyrus.infra.gmfdiag.feature.feature.group 1.0.0.v201401290914)
    To: org.eclipse.papyrus.infra.gmfdiag.xtext.glue [1.0.0.v201401290914]
  Cannot satisfy dependency:
    From: XText GMF Glue (Incubation) 1.0.0.v201401290914 (org.eclipse.papyrus.infra.gmfdiag.xtext.glue 1.0.0.v201401290914)
    To: bundle org.eclipse.papyrus.extensionpoints.editors 1.0.0
  Cannot satisfy dependency:
    From: Papyrus UML (Incubation) 1.0.0.v201401290914 (org.eclipse.papyrus.sdk.feature.feature.group 1.0.0.v201401290914)
    To: org.eclipse.papyrus.infra.gmfdiag.feature.feature.group [1.0.0.v201401290914]
  Cannot satisfy dependency:
    From: Papyrus UML SDK (Incubation) 1.0.0.v201401290914 (org.eclipse.papyrus.sdk.sources.feature.feature.group 1.0.0.v201401290914)
    To: org.eclipse.papyrus.sdk.feature.feature.group [1.0.0.v201401290914]

[Updated on: Tue, 25 February 2014 15:59]

Report message to a moderator

Re: Installing 10.0.0M5 [message #1256628 is a reply to message #1256604] Tue, 25 February 2014 16:24 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 502
Registered: February 2011
Senior Member
Hi,

Did you install Papyrus M5 on an Eclipse Luna M5 platform?

Currently, Papyrus doesn't guarantee any backward compatibility with the previous Eclipse version (e.g. 4.3/Kepler). Each Papyrus version targets exactly one Eclipse version. For 1.0.0 M5, you need Eclipse 4.4 M5 (And other Luna M5 components, including UML2 5.0.0 M5)

Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Installing 10.0.0M5 [message #1256632 is a reply to message #1256604] Tue, 25 February 2014 16:29 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4150
Registered: July 2009
Senior Member
Hi

You haven't installed all the EMF-related items.

org.eclipse.emf.ecore 2.10.0

is in EMF 2.10.0M5.

Regards

Ed Willink

On 25/02/2014 15:59, Gintautas Sulskus wrote:
> Hello,
>
> I can't get 10.0.0.M5 installed. Actually, I can't get installed any
> of Papyrus version. What am I missing?
> I have installed all EMF related items from update site.
> Thanks for your help!
> Gin
>
> Platform: Eclipse Standard 4.3.1
> Error msg:
>
> Your original request has been modified.
> "Papyrus UML (Incubation)" is already installed, so an update will be
> performed instead.
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: Papyrus UML SDK (Incubation)
> 1.0.0.v201401290914
> (org.eclipse.papyrus.sdk.sources.feature.feature.group
> 1.0.0.v201401290914)
> Missing requirement: Papyrus Embedded Editors extensions point
> (Incubation) 1.0.0.v201401290914
> (org.eclipse.papyrus.extensionpoints.editors 1.0.0.v201401290914)
> requires 'bundle org.eclipse.emf.ecore 2.10.0' but it could not be found
> Cannot satisfy dependency:
> From: Papyrus GMF diagram (Incubation) 1.0.0.v201401290914
> (org.eclipse.papyrus.infra.gmfdiag.feature.feature.group
> 1.0.0.v201401290914)
> To: org.eclipse.papyrus.infra.gmfdiag.xtext.glue [1.0.0.v201401290914]
> Cannot satisfy dependency:
> From: XText GMF Glue (Incubation) 1.0.0.v201401290914
> (org.eclipse.papyrus.infra.gmfdiag.xtext.glue 1.0.0.v201401290914)
> To: bundle org.eclipse.papyrus.extensionpoints.editors 1.0.0
> Cannot satisfy dependency:
> From: Papyrus UML (Incubation) 1.0.0.v201401290914
> (org.eclipse.papyrus.sdk.feature.feature.group 1.0.0.v201401290914)
> To: org.eclipse.papyrus.infra.gmfdiag.feature.feature.group
> [1.0.0.v201401290914]
> Cannot satisfy dependency:
> From: Papyrus UML SDK (Incubation) 1.0.0.v201401290914
> (org.eclipse.papyrus.sdk.sources.feature.feature.group
> 1.0.0.v201401290914)
> To: org.eclipse.papyrus.sdk.feature.feature.group
> [1.0.0.v201401290914]
>
Previous Topic:0.10.2 release notes et al...
Next Topic:CSS Tooling menu item not present in Papyrus 0.10.2
Goto Forum:
  


Current Time: Sun Nov 23 13:33:12 GMT 2014

Powered by FUDForum. Page generated in 0.10648 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software